Help Wizard

Step 1


Google Assistant Plays Censored Versions of Songs

Google Assistant Plays Censored Versions of Songs






Samsung S9 SM-G960U

Operating System

Android 9 Pie

My Question or Issue

When I use voice commands through Google Assistant to play music on Spotify, it sometimes defaults to censored/edited versions of the song. If I use the mic button from within Spotify, it plays the original version of the music.

I have "allow explicit content" set to ON in my settings.

There is no Google Assistant setting that looks relevant. 

Example album: Aesop Rock's "Impossible Kid"

Recreation steps: 

1. Search for "Impossible Kid" by typing in album in search bar from Spotify. Explicit content shows first. Plays normally.

2. Tap search in Spotify, then tap mic icon and say "Play Impossible Kid". Explicit content shows first. Plays normally.

3. Say "Okay Google" and wait for tone prompt. Then say "Play Impossible Kid on Spotify" or "Play Impossible Kid" or "Play the album Impossible Kid" etc., and the clean, censored version of the album plays. This is most easily noted on track 3 at around the 0:40s mark. "I should give a sh-t less".


Would be great to have a fix to this, but also, no music should default away from its original version. The setting from within the app(s) should be to block explicit content as preferred, not allow explicit as preferred. Not only will this solve tertiary problems caused by inverse sorting (fewer songs need to be edited than don't), but it doesn't seem to assume that music requires censorship.

Either way, please fix or provide steps.

16 Replies

I still have this exact problem all the time. Spotify app will list explicit first and play the unedited version, but Google home will only play censored versions. I have music restrictions turned entirely off in my Google home

I think more people are having this issue then are talking about it.  This has happened to me several times in the couple of years that I've been using Google Home devices.  It will get fixed then it pops back up.  There are explicit setting in the Google Home app and in Spotify.  For me, I have both set to play explicit versions of music with no filters.  But albums I listen to without any issue will stop playing the explicit version and only play the clean version.  I think it is a joint issue between both Google Assistant and Spotify.  I think it has to do with the coding of the request.  It is very frustrating the only way I can play songs is by casting them through the Spotify app versus using voice commands which is a little irritating especially if you are sending requests while in the shower.  I understand we have to protect innocent ears but there has to be a more efficient way to satisfy all users.

Yeah I have the same problem happening as well. One thing that I noticed that is if you manually play the Explicit version of the song and then ask Google Home to play the same song, then it doesn't switch to the radio version, but of course, doing this isn't practical since you have to play the song manually.

For songs where there's no clean version available on Spotify, I have no problem in playing the explicit version, e.g. "**bleep** the police - NWA". But songs with radio edits default to radio edits.

A workaround that Spotify can do is allow a user to hide radio versions of songs if they have no problems with only the explicit versions of the songs.

Hey folks,

Thanks posting here in the Community! We'll gladly help you out.


As a first step, it's a good idea to check if you have the playback of explicit content activated for both Spotify and  your Google device. You can learn how to do this for the Spotify app here. With Google this option can be toggled in the settings under Digital Wellbeing and parrental controls. You should afterwards restart all devices where the issue comes up, so that the new information is synced with the servers.

If you're experiencing this with Google Home and Google Nest devices, we recommend that you also relink your Google and Spotify accounts. This support article has the necessary steps listed. 

Hope you find this useful. Keep us posted how you get on.

Mihail Moderator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

I'm sorry but none of these articles resolves this issue, I have no search filters in Google home under digital wellbeing.

No matter what if I ask this Google to play a song it is defaulting to censored music.


I want an option to filter all clean songs. Seriously who wants to listen to that anyways? Make those optional and enforce them on child accounts if that's a thing.



Hi there @Terrylee23,


Thank you for your reply and confirmation.


Can you perform a clean reinstall of the app? This will make sure there's no old cache files causing this.


On another note, does this occur on one specific device or multiple devices?

We'll keep an eye out for your reply.



Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Live, love, laugh and listen to music 🙂

Digital wellbeing settings in the Google home app will allow you to chose content filters for videos and music on all of your Google devices. 

This issue is still happening. I just tried it on my car - when I tried to get it to play My Notes by Atmosphere, it defaults to the censored version (which is a far worse version of the song - it's even 20 seconds shorter for some reason!). I cannot figure out a way to get Google Assistant to play the uncensored version, which is even more frustrating - it seems there's no option! This is unacceptable, but I don't know if it's a Spotify issue or Google Assistant issue (though I have confirmed that I have no parental controls filters on in GA or Spotify). 

I'm still having this issue on both my Galaxy S20 and my Google Home Mini. When I ask Google Assistant to play a song with a radio edit, it always plays the radio edit, for example "My Band" by D12. But when I ask Google Assistant to play a song without a radio edit, it plays the explicit song normally, for example "Straight Outta Compton" by N.W.A..


I've tried all the things mentioned above, i.e. re-installing the Spotify app, un-linking a re-linking Spotify from my Google Assistant, and making sure the content filters were turned off in the Google Home app, making sure "Allow Explicit Content" is turned on in the Spotify app, but none of them worked.

Me as well. Using an iPhone 12 Pro Max running 15.1.1 and a Google home mini. I Have:

-reinstalled Spotify

- un-linked in google home app

-reset the Google home

- re linked them

- confirmed the correct settings are toggled in both apps


And it failed again as well, but not immediately. This clearly is an interaction between Google assistant and Spotify, and seems to not be limited to any one smartphone platform.

Hey folks, 


Thanks for trying all the suggested steps so far and letting us know.


Considering the issue seems to be happening strictly when playing via the Google device (as opposed to playing directly in the Spotify app), are you still experiencing the same if you uninstall any related recent Google app updates?

To try this:

  1. Open Google Play Store
  2. Search for Google (G) app > open app > Uninstall > OK > Update
  3. Wait for the process to be completed
  4. Restart your phone


Hope this helps. Let us know how you get on!

Mario Moderator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

This solution worked for me, tried it on a Pixel 6 Pro. Thank you!

Hey @r_ilang,


You're welcome!


It's great to hear that it worked for you, thanks for letting us know.


If you need anything else, the Community is here for you.


Cheers 🙂

Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.

Hi everyone, I have the exact OPPOSITE problem.  We have a google nest mini speaker for my 10 year old.  I have content filters set to "on" for spotify.  We ask the mini to play a song and instead of going to the radio edit, it just says "I can't play that with content filters on".  Then we get out our phones, log into spotify, find the radio edit, push play, and it plays on the speaker.  It's just the darn speaker is lazy and defaults to not playing anything at all.  Any ideas for this?  Maybe I should take content filters off?  Sounds like you were all getting the radio edits with the content filters OFF?!  🙂

SAME!! I have turn on Explicit Content but my Google Nest kept playing either Censored version or Remix version What the **bleep** man

I have the same problem as the two above.  Has there been any solution to this?

Suggested posts