Announcements

Help Wizard

Step 1

NEXT STEP

Google assistant

Google assistant

 

Plan

Premium Student

Country

UK

Device

Samsung A70

Operating System

Latest

 

My Question or Issue

 

if I ask google assistant to play a specific track by title the response is that you need a premium account to do that, but I have a premium account. But if I then go to the app and search for the same song by title it will play no problems. So I tried my Spotify account on Alexa asked to play the same track by title it played fine.

 

I can play a full album using GA but if I ask ‘play happy music’ the response will be that it found a suitable play list but then nothing happens it pauses then says that something went wrong. Again if I ask Alexa to play the same playlist it’s all fine.

 

Reply
14 Replies

Hi @alistairgore,

 

Thanks for reaching out about this in the Community!

 

We'd recommend performing a clean reinstall both for the Spotify app on your phone as well as Google Assistant. This involves clearing all app data and cache.

 

After that try to re-link your Spotify profile to the one you have active on Google. You can check this article out for more info.

 

Hope this help. Don't hesitate to reach out again if you have questions.

 

Cheers.

AlexModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Done that quite a few times already makes no difference

Hi again @alistairgore

 

Thanks for getting back to us.

 

If possible, could you try this with a different device to see if you can replicate the issue?

 

Also, let us know the exact OS version on your Samsung and the Spotify version you're currently running. 

 

Keep us posted. We'll be on the lookout for your reply. 

NovyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Spotify version is 8.5.93.445

android version is 10

 

the only other device I have is an apple it works fine in that. 

Hey @alistairgore

 

Thanks for your reply. 

 

We've noticed that your app version might not be fully up to date. In this case, we'd suggest following these steps one more time to see if you notice anything new. 

 

Also, would you mind letting us know if this started to happen randomly or if you noticed it after a specific event, such as an app or system update?

 

We'll be right here.

NovyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

I’ve done that the same results, Spotify version is now 8.5.94.839

i can’t answer the other question as it’s a new phone, and a new Spotify account so it’s always been like this. 

Hey @alistairgore,

 

Thank you for your reply and confirmation.

 

Can you log in with another account - such as a friend's or a family member's to see if the issue persist?

We'll keep an eye out for your reply.

 

Cheers!

JeremyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Live, love, laugh and listen to music 🙂

I get the same results 

Hey @alistairgore

 

Thanks for your reply. 

 

Could you let us know if this is happening using a different internet connection as well?

 

If it is, can you make sure that Spotify has all necessary permissions enabled?

 

  1. Open your Settings menu.

  2. Scroll to the bottom to find Spotify and open the app setting.

  3. Enable everything you see.

 

It's also a good idea to exclude the app from any Battery optimization software that might be active on your smartphone.

 

Let us know how it goes!

 

 

EniModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 
“Music acts like a magic key, to which the most tightly closed heart opens.”– Maria von Trapp

Checked the permissions all allowed. Same results on WiFi and mobile data 

Hi @alistairgore

 

Thanks for trying it. 

 

In this case, could you head over to Google home app > click on "+" icon in the upper-left corner  > add services > Music > Spotify and send us a screenshot of what you're seeing there? Make sure not to include any private info. 

 

We'll be waiting for your reply 🙂

 

EniModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 
“Music acts like a magic key, to which the most tightly closed heart opens.”– Maria von Trapp

Screenshot_20210123-204528.png

I hope this is what you meant

Hi @alistairgore

 

Thanks for sending us this info. 

 

We can see on the screenshot you sent that the account which is linked there is currently free. 

 

In this case, we suggest that you unlink your Spotify account and then link it again. Before doing so, make sure to log in with your Premium account in your phone. 

 

You can check your subscription status following these steps. 

 

Keep us in the loop 🙂

EniModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 
“Music acts like a magic key, to which the most tightly closed heart opens.”– Maria von Trapp

Well that’s bizarre I’ve done that loads of times. All my other devices use the same account, but now it works so thank you.

Suggested posts