Help Wizard

Step 1


I'm not able to log on spotify on android.

I'm not able to log on spotify on android.

I've got a Nexus 7 2013 version and it's running stock android 5.1.1 Lollipop (Non rooted). It was working fine earlier back in 5.0.2 or something. But in 5.1 it started getting annoying. Cause sometimes when I was logged in I was not able to play any tracks on spotify and it said I was offline when I wasn't. I checked the settings on spotify and on tried a browser and it worked there. The only thing that worked was to uninstall the app and install it agian. I have no problems logging in on a phone (I'm using a relativly unknown phone so it seems kinda strange that a nexus 7 has problems. But now I'm running 5.1.1 Lollipop and now I can't even log on at all on my tablet. I tried logging in via facebook and it just says logged in and stays like that for 5 minutes until it goes back again to where it tells me to log on with an spotify account or facebook. I also tried logging in via the spotify account and that didn't work either and does the same thing. The difference is that when I try logging in via facebook it has a background with artists and some album covers or something. And when I try logging in with the spotify account the button you click to log into just says logging in and goes back to Log in as if I never clicked it. And I really need some music in the upcoming week since I'm travelling..

2 Replies

I have the same device. I too am unable to login using the device with up to date Spotify software. No problems using my iPhone though.

It is the updated app that has caused the issue. I have previously installed an old version of the app which works fine.

I'm not sure what the developers have done to cause this problem.

I conducted an experiment and established a connection with Spotify when using my iPhone as a WiFi hotspot. This being the case I determined that my netgear router was for some reason preventing a direct connection with Spotify and my nexus 7. I accessed my router and enabled the port triggering to 4070 both start and finish. I noted that the router also needed a firmware update and applied that too. These changes now allow my nexus 7 to connect to the Spotify servers. 

I maintain however that a change to the Spotify app has caused this issue. I've had no other network issues with any other app but Spotify. And as already stated previous versions of Spotify did not present an issue.

Suggested posts