Help Wizard

Step 1

NEXT STEP

Liked songs not playing on Google Home

Liked songs not playing on Google Home

 

Plan

Premium

Country

Uk

Device

Samsung android A71

Operating System

Android 11

 

My Question or Issue

Hi,  Liked Songs are not playing when casting to Google home devices. Tried multiple devices and reinstalling Spotify. Anyone else have this issue?

Reply
16 Replies

Hi @musicwoop,

 

Thank you for reaching out to the Community!

 

To start, we'd like to confirm if this is happening only when you're using Connect to stream from your phone to the Google Home, or if it also happens if you start playing your Liked Songs directly from the speaker using voice commands.

 

Also, do you get any errors or what's the behavior when you try to play the songs? 

 

Lastly, does this happen only with your Liked Songs, or also with regular playlists or albums? 

 

Keep us posted.

MafeGModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Hello, it doesn't work if I use a voice command direct to the speaker either. *Correction - it does work with direct voice commands!

 

When starting from Android phone - There is no error, it just doesn't play. Playlists/albums work fine, this is just an issue with 'Liked songs'. I've found that I can cast Liked Songs from the desktop app ok, it's an issue with my android phone. Thanks.

Hey there @musicwoop,

 

Thanks for getting back to us.

 

It sounds like we'll need to try some troubleshooting on your phone. Can you let us know if you've already tried to log out > restart your device > log back in? It's also a good idea to try clearing your cache to remove any old files that might be causing issues.

 

It's also a good idea to restart your router and your Google Home device.

 

If that doesn't do it for you, could you let us your phone's Spotify version and, if possible, if you experience this on other mobile devices?
 
We'll be on the lookout for your answer and we'll see what we can suggest next. Let us know if there's anything else we can do for you in the meantime.

ElenaModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Hello,

 

Thanks for the response. Tried signing out on the Android app and that hasn't worked. I tried on a borrowed iPad device and there's the same issue.

 

Hey @musicwoop,

 

Thanks for getting back to us.

 

Just to double-check-are there any changes after running a clean reinstall and restarting your router and your Google Home device?

 

In case you're using an SD card, you can try removing the SD card, reinstalling Spotify and then try running the app on your phone without the SD. Does that make a difference?

 

If nothing changes, could you please share with us the exact Spotify version that is running on your device?

 

Keep us posted.

Ver Moderator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Hi there,

 

Sorry for the delay and thanks for the help. I'm not sure this is device issue; as I said in my previous post, when I tried on an ipad there was the same issue. I tried the 'clean reinstall' guide and removing the SD card anyway, but no fix unfortunately.

 

The version is 8.7.6.1081 (latest version as I just reinstalled).

Hey @musicwoop,

 

Thank you for keeping us updated.

 

To verify if the device may be the issue, could you try to log in with a different account to check if it makes any difference?. It could be a friend’s or family member's account.

 

Also, would you mind trying with a different WiFi network or with mobile data?. This is to have a better look at the issue.

 

​​​​​​​We'll be waiting for your response. 

OscarDCModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Hi there,

 

Tried using an alternative email testing on a new free account (ie: a new spotify account and liked a few songs) and no issue with that. Tried my main account (where the problem is happening) with a different wifi network (I have a wifi extender) and issue persists there. I wasn't able to try with mobile data as I believe you have to be on the same wifi network as the smart speaker to link up to it?

 

All issues pointing to an account issue I think. Is it because the liked songs playlist is particularly large perhaps? Thanks.

Hey there @musicwoop,

Thanks for your keeping us in the loop.

I'm following your train of thought here and you might be quite right. It's very possible that a collection that is many-thousand-songs large, might be causing issues to load up through the API of the app. In this case, it might be a good idea to try and redistribute/copy some of the songs to other/new playlists that have a more manageable size.

Hope this does the trick for you, reach out if you need more help!

Kiril Moderator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Thanks for sticking with me anyway! Is this something that can be escalated as an issue to be fixed? There are other threads with similar issues for large playlists.

Hi there @musicwoop,

 

Thank you for your reply.

 

We're aware that this can occur with bigger playlists, but for now we can't say when or if it this will change, so for now we suggest that you redistribute/copy some of the songs to a different/new playlists as was mentioned earlier in the reply above.

 

Let us know if we can help you with anything else.

 

Have a great continued weekend 🙂

JeremyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Live, love, laugh and listen to music 🙂

Have the same issue on my Mac and on an Adroid phone. The playlist is "The Jazz Groove" and is more than 6700 songs long.
Devices involved:

  • Mac
  • Android phone
  • Web browser (Chrome) on Linux
  • Wiim streamer
  • piCorePlayer on Rpi

For the playlist mentioned:

  • Both Mac and Android can play locally.
  • Both Mac and Android cannot play on Wiim streamer, piCorePlayer and Web browser.
  • Web browser can play on every device, including Mac and the phone.

Needless to say, everything works fine for other, not so huge, playlists.

 

Seems that until it is fixed, we should stick to the Web client for our extra large playlists.

Hello,

 

This was never fixed for me but the workaround I use is that I can start the playlist with my voice.

Makes sense - I would expect that handling of voice commands happens server-side, same or similar way as from the Web browser.

Someone may have provided this solution already, but simply ask Google to “play my songs on Spotify.” This defaults to your Spotify liked songs playlist. I was having the same issue. I saw this solution on a different forum and it works perfectly. 

Same issue here. Been having this issue for a very long time. None of the solutions above from the mods fix it for me. I guess I will try the copying to a new playlist workaround. I hope this issue is still being escalated and work on as the app still isnt working as intended. 

Suggested posts