Help Wizard

Step 1


Media Control Buttons not working

Media Control Buttons not working

I am having issues contolling music using the music controls on bluetooth and on my wired headphones.


This started happening a few weeks back when the app was updated.  When I press one of the control buttons, the music does not change or play/pause.  The only workaround is force stopping the app and opening it.  Over time, it does not work anymore and I have to repeat the process.  I used other media players just to be sure if it is not a phone issue and all of them worked perfectly.  I did a reinstall of the app and the problem persists.


I can see that this is a Spotify bug because when I press one of the controls when the screen is dimmed, it lights back up, but nothing happens.  Hopefully this will get fixed.


I have a Galaxy Note 8 running the Android verison 7.1.1.

6 Replies

Ive got the same issue here. Note 8 running 7.1.1 can't control audio playback from the lockscreen or Bluetooth.

I've had the same problem with my audi mmi since the latest update  Also Google assistant can't play songs. It searches Spotify, finds the song. Then nothing. ItsI getting annoying now. I hope they fix this bug soon 

I have this as Well, in car and in work van, very frustrating and I'm sure causing some people to use their phone will driving.


Certainly seems to be a Spotify issue as other streaming apps I use work fine.

This is the same as this one here


But there it has been marked solved, but it isn't solved, the solution there is to uninstal android ware which is not a solution, since it would criple my android watch. I have samsung S7 edge and it looks like it is happening only to samsung phones, so maby samsung is just not going to support android ware with spotify to make people by their own watch. I hope not and really would like this to be solved as soon as possible, the older version of spotify was working fine by the way.

It would appear to be an issue with Android I think....


I have a Huawei watch 2 and up until a few weeks ago it was working fine then the issues stated started, unable to skip forward or back at all.


This morning I uninstalled all my Android wear apps to see if that fixed the issue and low and behold, it works.


Clearly this is of no use to anyone with a smart watch...or potentially other Android device to link up with phone as it renders Spotify pretty useless unless you never skip a song.


Going to investigate further to see if there is a setting on watch/phone that will solve it!

yes maybe an android ware update has done this and it might therefore not be a spotify issue at all, but it is happening to quite many people recently, but when I uninstalled spotify, removed all files related to spotify, rebooted the phone and then installed spotify again, then my bluetooth headphones worked again, that is I can skip songs using the headphone buttons, but the bluetooth in the car is still not working (yaris hybrid 2014). So whatever changed it is a strange problem and not easy to find out excactly where it went wrong.



Suggested posts