Help Wizard

Step 1


Moto X4 Android 9 Bluetooth steering wheel controls not working

Moto X4 Android 9 Bluetooth steering wheel controls not working






Motorla X4

Operating System

Android 9 Pie

Version: PPW29.**bleep**-39-1

(It's automatically censoring sixty9 up above)

Spotify Version


2013 Toyota Prius


My Question or Issue

I'm not quite sure what triggered this problem but it definitely began sometime in the past 2 weeks or so. The phone has no trouble connecting to the bluetooth or playing sound, but I am unable to skip, rewind, or pause the music on spotify through the steering wheel controls or through the stereo interface while using spotify. This problem was also consistent inside a BMW I tested inside, it could sync and play fine but unable to skip or rewind songs etc. through the BMW's stereo system. Before this problem arose, I was also unable to view the music metadata(Song name, band name, album name) rather consistantly (but not all the time, it would pop up again once in a blue moon) for roughly 6 months before, yet was still able to control the app through the steering wheel controls. Currently, I can still control the Google Play app (Default software for my phone) through bluetooth controls (in the both the prius and BMW), though the metadata also doesn't show for Google music.


I updated the software for my Prius' stereo (Entune) to the most recent

I've unpaired and forgotten each device from each other then re-paired

I've cleared the bluetooth cache on the device

I have already clean wiped, uninstalled and reinstalled spotify.

I tried factory resetting the phone

The AVRCP version on my phone is currently set 1.3 (I've tested all of them to no avail)

I turned off battery optimization on both the Spotify and my phone's bluetooth

I've enabled Device Broadcast status on the app

I've given spotify every permission (Camera, Contacts, Microphone, and Storage)

The phone was rebooted after every single of the above attempts

None of the above have seemed to help


Using the steering wheel controls is very important to me because I have a long commute and often listen to music and podcatsts daily, hopefully someome has a fix I haven't tried yet, I'm not looking to fix the metadata problem I can live without it but the steering wheel controls are absolutely vital to me.


I've also seen mention of disabling the new ConnectDrive functionality but have not been able to locate it in my app if my version has it. Any help would be appreciated.

4 Replies

When you went into Dev mode on your phone and selected AVRCP 1.3, did you reboot your phone after your selection? The reason being is that you have to do it as it has to reboot the BT stack to 1.3 opposed to default 1.4, toggling it does not do anything till after the reboot? That was my miss when I did it the first time, ever since, everything works again.... OnePlus 6t - Android 9 - 2015 Land Rover Sport



Hey @Buoyantburro.


Thanks for getting in touch!


We are aware of an issue with the app and are currently investigating it. Feel free to contribute in this topic where we gather information from affected users and keep everybody up-to-date. We'll get this sorted as soon as possible.


Sorry for the inconvenience. Let us know if you have further questions.


Have a nice day!

To anyone with the same problem I've found a temporary, but not ideal workaround to the problem while I wait for a fix to be rolled.

If I open up Google Music and play a song before spotify and sync that through bluetooth, both the metadata and bluetooth controls will work. Then I can switch over to spotify and the bluetooth controls and metadata will work, but the fix is only temporary and rather finnicky so it's not ideal. It also does not seem to work if spotify was opened and running before Google Music, so it usually requires a device reboot before, but for hour or longer drives it's worth it. I'm not sure if this works for other music players aside from Google Music.

It isn't working for me, its been like that since an update on the phones firmware back in March. I switched phoned for a warranty repair, and the other phone worked great, but isn't on the newest android, and when the new phone got here, it worked great until the OS got caught up on updates. It sometimes works for one song, usually just plays music with no real controls. (Fun fact, it will play and pause, won't change track, but holding down the next track or prev track button on my jeep will sort of FF or RW the track a bit, but not change song.  moto x4 build number is the same except its 39-2 instead of -1 

Suggested posts