Music stops playing after 10 seconds when casting to Google Mini speaker

Reply

Music stops playing after 10 seconds when casting to Google Mini speaker

Kate_spot
Casual Listener

Plan

Premium

Country

UK

Device

(iPhone 😎

My Question or Issue

I have premium account and was using my Iphone to cast music to Google mini speaker. Recently, when I try to cast song to the speaker, it randomly chooses different song and plays it for exactly 10 seconds and then stops but I can see song  still playing on the phone. The same happneds when I just request song via speaker which is linked to Spoity account.

 

I reinstalled appl several times and restarted phone as well as re-linked Spotify in Google home multiple times. I coundn't find any solution to the problem so far in any similar topics.

Can you please help, as premium account became useless for me due to this issue? 

33 Replies

nec
Regular

This is extremely similar to the problem I have been encountering with my Spotify Premium account and casting to a Google Home device. It randomly selects a track by the artist I have asked for, plays for around 10 seconds and then stops.

 

The most frustrating thing is that this only impacts my Google Home. A Google Nest Mini on the same home network is fine, as are the laptops and phones. It is just the Google Home that is misbehaving with Spotify.

 

Even more frustrating is that it is only music from Spotify that is not working, as podcasts from Spotify work just fine on the Google Home device, which makes me sure it is a Spotify issue. Other music services, live radio etc are fine too.

 

This has been going on for 5 days now and all google devices are at the latest version (1.50.229149). Resetting, unlinking etc. has not worked. 

 

Can someone from Spotify support figure this out as it is clearly an ongoing issue that many people are experiencing as well?

Jeremy
Moderator
Moderator

Hey there @nec,

 

Thank you for your post here in the thread.

 

Can you confirm if you performed a clean reinstall of the app since that will make sure there's no old cache files causing this.

 

It would also be good if you can restart your router, and also  check so your firmware are up to date.

 

Also - does this occur when you play music from one specific device or from multiple devices?

 

We'll keep an eye out for your reply.


Cheers!

 

JeremyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Live, love, laugh and listen to music 🙂

leanneexx
Newbie

Having the exact same problem with my google home. Nothing seems to fix it. Spotify app on MacBook also been lagging and not showing the current song playing, driving me insane!

2020Maddog
Casual Listener
I tried everything Spotify suggested. They finally claimed the problem was corrupted files in my account. All were deleted. Caches deleted. Playlists erased. Problem continues. I believe there is a fundamental compatibility issue between Spotify and Google Mini/Home Mini.
I gave up. I bought the high end Edifier speakers I was looking at with bluetooth. No problems playing Spotify on these speakers.
It would be so much less frustrating if Spotify just admits there is a problem playing Spotify on Google Mini or Home Minis. It would have eliminated a lot of wasted time I put into trying to resolve the problem.

Ver
Moderator
Moderator

Hey folks,

 

Thanks for reaching out to us 🙂

 

We'd suggest you try with another account. That way we can check if it's an account-related issue. Are there any changes?

 

In case battery optimization and cache clearing apps, it's a good idea to deactivate them.

 

Keep us posted! If you have questions, you know where to find us.

 

VerModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
"Difficult roads often lead to beautiful destinations." ―Zig Ziglar

Jess11111
Visitor

I am experiencing this same issue, it just started in the last few days. I can connect and play properly on my Google home mini, but the Home speaker cuts out after about 10 seconds &/or cycles through songs continually. I’ve rebooted everything, reinstalled spotify (following your instructions) cleared my cache, etc. the same thing occurs when my son connects with his phone, or when trying to start spotify directly from the Google home device. This is extremely frustrating and it doesn’t look like you really have a solution. 

Louieh78
Casual Listener

Hi, I ended up calling Spotify and they had to clear my cache from their side. It works fine now.

Ivan
Moderator
Moderator

Hey @Louieh78

 

Thanks for getting back to us. 

 

We’re happy to hear our friends from the support team helped with this. 

 

If you have any questions we're always one post away. 

 

Еnjoy your music! 

IvanModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
“Music is the wine that fills the cup of silence.” - Robert Fripp

dfluff
Regular

Hi,

 

How do I get this fixed for my account?  This has been happening for over a year:

https://www.dropbox.com/s/515v8mm95h464ov/IMG_0503.MOV?dl=0

https://www.dropbox.com/s/29jkk7mbzilgq5c/IMG_0504.MOV?dl=0

 

If Spotify are about to put their prices up, I would at least like to be able to use the service on my Google Home devices!

Novy
Moderator
Moderator

Hey there @dfluff

 

Thanks for reaching out about this in the Community. 

 

Would you mind letting us know if you've already tried any troubleshooting steps? This will help us give you better suggestions. 

 

In case you haven't, we'd recommend performing a clean reinstall of the app as this could be helpful to get rid of any corrupted files that might be causing issues. 

 

We'll keep an eye out for your reply. 

NovyModerator
 
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
"Music touches us emotionally, where words alone can't." -Henry Thoreau

dfluff
Regular

Hi Novy,

 

I tried re-installing, cleaning the cache, etc. on my Android device about a year ago which made no difference.  I also believe that I un-linked my Spotify account from my Google Home account and re-linked it which also didn't make any change to the problem.  The issue is that it doesn't work via voice-command direct to my Google Home Mini, which is something I can't un-install Spotify from, if that makes any sense, and it also doesn't work if I Chromecast to Google Home from either of my Android devices or mine or my partner's multiple iOS devices.

Alex
Moderator
Moderator

Hi @dfluff,


Thanks for the reply and the info.

 

You can try the following:

  • Do a factory reset of your Home Mini speaker. After this you'll need to set up everything anew.
  • Do a clean reinstall of the Spotify app on your devices, following exactly the steps from this Guide.
  • Reinstall google Home and Google Assistant make sure you clear all app cache and data.
  • Try connecting your phone and speaker to a different network such as mobile hotspot to check whether the issue is network related.

Let us know how you get on with this.

AlexModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 
“With freedom, flowers, books, and the moon, who could not be perfectly happy?” ― Oscar Wilde

Eni
Moderator
Moderator

Hey @dfluff

 

Thanks for getting back in touch. 

 

We understand that you performed a clean reinstall on your devices a year ago, but keep in mind that it's very important that you have the latest version installed on your devices to ensure optimal performance. This one is more thorough than the usual one.

 

On another note, make sure to try with a different network such as mobile hotspot to check whether the issue is network related as @Alex mentioned previously.

 

Additionally, we suggest that you check if the firmware of your speaker is up to date. 

 

Keep us posted.

EniModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 
“Music acts like a magic key, to which the most tightly closed heart opens.”– Maria von Trapp

Aeniki
Casual Listener

Hello,

I have the same/similar problem: while casting to Chromecast devices, the music pauses and skips randomly. The timeline keeps running, and Google home is still thinking it's playing music (I asked for the Songs name, skip, pause etc) but you can see in the attached screenshot the timeline is wrong - 37:57 min for a 1:58 track???

Screenshot_20210503-210128.png

I'm sure it's not my (devices) fault. Some facts:

-2 phones, 1 tablet (all Android) voice comand (3 Accounts in premium family) 

-2 Google home, 1 Google home mini, cambridge audio yoyo l both Google cast & Spotify Connect, Google chromecast audio and LG WK7 all the same problems

-Full new install of Spotify

-Router reboot

-rebooted the speaker, some of them even factory reset 

-other audio streaming (YouTube music, TuneIn,) works well

-bluetooth and headphones/works well

 

Is it possible to reset my account by customer Service? 

Thanks 

Eni
Moderator
Moderator

Hi @Aeniki

 

Thanks for getting in touch about this here in the Community. 

 

Just to confirm, have you tried reinstalling the app following these specific steps? This process is more thorough than the usual one. 

 

Additionally, could you let us know if this is only happening when you're using the Connect feature or when you're streaming directly on your phone as well?

 

Lastly, sending us the exact make/model, operating system and Spotify version of your phone would come in handy.

 

If you need further assistance from our Support team, you can reach out to them through any of these channels.

 

We'll be on the lookout for your reply. 

EniModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 
“Music acts like a magic key, to which the most tightly closed heart opens.”– Maria von Trapp

Aeniki
Casual Listener

Hello Again,

 

Just to confirm, have you tried reinstalling the app following these specific steps? This process is more thorough than the usual one. 

-Done (on one Device, still problems)

Additionally, could you let us know if this is only happening when you're using the Connect feature or when you're streaming directly on your phone as well?

- Spotify Connect didn't work well since I've bought the speaker last summer so I used Google Cast. All playback on the Tablet, Smartphone and Desktop PC works fine!

Devices:

Motorola One Vision (Android 10)

Motorola G8+ (Android 10)

Samsung Galaxy Tab S5e (Android 11)

Windows 10 Desktop PC

I updated the Spotify App to 8.6.24.918 lately Yesterday, I tried to cast one Song, it works (This is more than the weeks before 😐) I'll try again later today and let you know!

 

Thanks & Greets

Eni
Moderator
Moderator

Hi @Aeniki

 

Thanks for sending us this info. 

 

Could you also try with a different internet connection to check if that makes any difference? You can create a hotspot on your phone and using that. This would help us to check if the issue is network-related. 

 

Keep us posted 🙂

EniModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 
“Music acts like a magic key, to which the most tightly closed heart opens.”– Maria von Trapp

dfluff
Regular

Hi Moderators,


I have tried the full delete-data, delete-cache, uninstall, turn device off, wait, turn device on, re-install, re-log in process on a couple of my devices now with no change.


I am seeing this problem on the following devices:

1) OnePlus 6T (A6013) running OxygenOS 10.3.9 build A6013_41_210303, and Spotify for Android version 8.6.24.918


2) Huawei MediaPad M5 SHT-W09 running Android v9 build 9.1.0.345(C432E4R1P2), and Spotify version 8.6.24.918.


3) iPhone SE running iOS 14.4.2 and Spotify v8.2.24.1302.


4) ...my partner's iPhone and iPad, which I don't have access to at the moment, but they are both very recent models and will definitely be running the latest version of iOS and, I presume, the latest versions of the iOS Spotify app too. These are using a different profile under the same Family account, and exhibit the same behaviour.


..the most important bit of information is probably the Google Home Mini which shows the problem:


4) Google Home Mini - System firmware v250118, Cast firmware v1.54.250118 "Preview Programme: Off".

5) A second Google Home Mini with identical firmware, which has previously shown the same problem but appears to be working when testing it this morning.


To clarify, when streaming on the mobile devices, everything works. AS SOON as that device uses "Connect" to connect to the affected Google Home Mini devices (which uses "GoogleCast"), the mobile devices immediately skip away from the track that was playing, skip through 3 or 4 other tracks before landing on one, the Google Home plays exactly 8 seconds of that track and then goes mute (although the mobile device still shows the time ticking up). This is the behaviour that can be seen in the two videos that I've posted via Dropbox above, but which I'll paste again below:

https://www.dropbox.com/s/515v8mm95h464ov/IMG_0503.MOV?dl=0

https://www.dropbox.com/s/29jkk7mbzilgq5c/IMG_0504.MOV?dl=0


Connecting to the Google Home via Bluetooth instead allows the correct playback of the music. However, Bluetooth is not always suitable as I cannot walk away from the speaker, so I would rather use Connect/Google Cast.


If I put the affected Google Home Mini devices in to a Google Cast Group and then use Connect/Google Cast to connect to that GROUP, playback works. However, this is not a workable solution as I often do not want to have the music playing in multiple rooms.


If I use Connect/Google Cast to connect Spotify to the Chromecast device plugged in to my TV, playback works fine on that device.


The network connection to the affected Google Home Mini devices is fine - I can send other application audio to them via Google Cast without any probelms - e.g. TuneIn radio, BBC Sounds, Global Radio Player, etc.


If I ask for a song to play using voice-commands to the affected Google Home Mini devices, the behaviour is the same - nothing happens for a few seconds, and then a completely different track plays for 8 seconds and then stops. If I have open on my phone at the same time as I make the voice-request I can see that it's actually doing the same "picking the correct track I asked for, then randomly skipping through 3-4 other tracks before playing 8 seconds of a different track, and then muting but leaving the time duration advancing" behaviour as I see when I use Connect to cast from a mobile device.


I have tried disassociating the Google Home Mini devices from my account and re-setting them up, and I have tried factory resetting them. I tried this a year ago and the result was the same. I haven't tried it again recently because it is a lot of time and effort to set them up again.


I'm not sure that I can easily move the Google Home Mini devices to use a mobile hot-spot to test a different network. I have tried using a different WiFi access point, very close to the Google Home Mini, and that made no difference. My home internet connection is very healthy, regularly getting over 70Mb/s down and 16-18Mb/s up.


Since one of my two Google Home Mini's has seemingly started working recently, I've just tried another test: I asked for a song "on Spotify" using voice commands. This worked on this speaker - it played the correct song and continued to play. I then used the voice command "Move the music to <name of other speaker>". This stopped playing on the working speaker and from the other room I heard, after a delay, the wrong tune starting to play and then muting after 8 seconds.

Ivan
Moderator
Moderator

Hey @dfluff

 

Thanks for describing the steps you've tried. 

 

We understand that it takes time and efforts to set your devices up again after a factory reset, but if you tried this a year ago for the last time we recommend trying these steps again now as the time past would make a difference. Users in this Google Nest Help thread reported that the factory reset solved the issue for them.  

 

Another step we can suggest is checking if you can skip to the next song when accessing the Google Home app. Give it a try and let us know the outcome.  

 

Keep us in the loop here. 

IvanModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
“Music is the wine that fills the cup of silence.” - Robert Fripp

Aeniki
Casual Listener

Hello again,

 

After updating the spotify App I have (almost) no problems any more. The Cambridge Audio speaker is not working right, but the other 4 make no problems. I'll try to factory reset the Cambridge and hope it'll work.

Best wishes and fast solutions to the others with the same problems.

 

Bye Timm

SUGGESTED POSTS