Help Wizard

Step 1

NEXT STEP

No Available Offline option for Playlists

Solved!

No Available Offline option for Playlists

I have premium and I was trying to add local songs into my spotify playlist. Both my desktop app and Android app are connected on the same WiFi. I managed to add the songs into the playlist without problems. I just can't play the local songs on my Android device because they're greyed out and when I click on a track it just says "This song is not available". I've tried everything mentioned in other posts (been doing this for 8 hours now). I keep hearing people say make your playlist available offline, but that's the problem; there is no such option. The only button available is download. I got premium on my facebook account but I can't log in using the facebook button on my desktop. So instead I logged in with my facebook email and password. 

 

Basically my question is: How do I get the option to make my playlists go available offline? There is no such option. I also reinstalled Spotify 5 times on both devices and still no result.

Reply

Accepted Solutions
Marked as solution

First, make sure to import your local files on your desktop. Once you're done, log in to your Spotify app using your phone (using the same WiFi network) and tap the option download on your phone.

 

If these steps don't work, try importing the local files on a new playlists using your desktop. Once your done, go back to your phone and download them.

View solution in original post

5 Replies

Hi there,

 

I think the option Available Offline was changed to Download after the most recent updates, but both options do the same thing.

Oh that makes sense. However, my local songs don't get downloaded. Only songs from the spotify server gets downloaded. How do I get my local songs in my playlist to also be downloaded?And also, do I need a SD card or is my phone's internal storage fine? 

 

Thanks a lot!

Marked as solution

First, make sure to import your local files on your desktop. Once you're done, log in to your Spotify app using your phone (using the same WiFi network) and tap the option download on your phone.

 

If these steps don't work, try importing the local files on a new playlists using your desktop. Once your done, go back to your phone and download them.

Interestingly enough it appears even though I allowed Spotify.exe through my firewall, it still didn't allow syncing. I decided to just turn off firewall and try and voila! All my songs started downloading. Can't believe I spent 8 hours doing this when I could've just turned off firewall in the beginning. Thank you so much for your help! For anybody who may run into this issue, instead of just allowing Spotify through your firewall, try just turning it off.

If you check your firewall log, you should find a second instance of spotify which also needs an exception setting.

Suggested posts