Online features not working and failing to scrobble

Reply
Highlighted

Online features not working and failing to scrobble

Casual Listener
when i try to go to home, browse, or my profile via spotify mobile, the screen in the attached screenshot is all i get, both when connected to my home wifi and my cell data. i am not in offline mode.

not only this, but spotify mobile has been failing to scrobble to last.fm for at least a week. i was a couple updates behind (i don't have auto update on as i've had far too many experiences with apps that worked suddenly no longer working after an update) and i figured this was probably the reason. so i updated spotify and it briefly showed the track i was currently playing on my last.fm page before ultimately not scrobbling it and no longer showing my now-playing after that track.

though i will if need be, i'd prefer not to uninstall and reinstall as i have 7 gbs of songs downloaded offline currently and it'll be no fun redownloading it after a reinstall.

last i checked last.fm still scrobbled from my desktop spotify app.
Screenshot_2016-06-20-12-53-37.png
2 Replies
Highlighted

Re: Online features not working and failing to scrobble

Casual Listener
update: the online pages go back and forth between working and showing the same error page as shown above. as i tested this on multiple connections and it still acted the same way, my connection is not responsible for this.

last.fm picks up the first song i play every time i first start spotify, but doesn't log it permanently, only as now playing, and then doesn't pick up any songs after that.

...please help

Re: Online features not working and failing to scrobble

Newbie

Would be interested in the answer to this. I've just posted over in the last.fm forums, as something I have noticed is that when connect to wifi, my scrobbles appear in playing now. However, when I switch to mobile data (3g/4g) it doesn't scrobble.

 

Is this an issue with Spotify or last.fm? I can't see why where the data comes from would affect the scrobbling component?  As far as I know this is not a device setting but am willing to be proved wrong.

SUGGESTED POSTS