Announcements

Playback Stops in Lock Screen - Galaxy S10

Solved!
Reply

Playback Stops in Lock Screen - Galaxy S10

millkd
Casual Listener

Plan: Premium

Country: USA

Device: Galaxy S10+

Operating System: Android Pie

 

My Question or Issue: Whenever my phone sleeps (goes to the lock screen), Spotify stops playing. I have tried all of the recommended settings for battery management, power settings, etc. and none of them work. This is incredibly frustrating and if Spotify cannot provide a solution I will cancel my premium plan! 

 

Alex
Moderator

Hey folks,

 

For anybody still experiencing this issue we'd suggest heading over to this Thread and following the suggested steps in the Top Answer.

 

Hope this helps 🙂

6 ACCEPTED SOLUTIONS

Accepted Solutions
Solution!

Re: Playback Stops in Lock Screen - Galaxy S10

Manasdama
Casual Listener

Hey..

I use s9+ . From india. i was facing same issues. When locked my screen its stops playbacm aftr few seconds. 

 

I hope this might help you.

Just open the main menu (appdrawer) and search for sleeping apps.  Open it in the settings. Its a 90% chance that the list might include spotify in it. Just long press spotify if it appears there and click on the remove on bottom right. And try it out then 

 

I hope this solves your issues. 

Thankyou. Do revert if its solved.  Attached few screenshots tooScreenshot_20190314-011422_Device care.jpg

 

Screenshot_20190314-011344_Finder.jpg

 

Screenshot_20190314-011347_Finder.jpg

 

View solution in original post

Solution!

Re: Playback Stops in Lock Screen - Galaxy S10

RedFreeman
Visitor

Settings>Apps>Spotify>Battery>Allow background activity

I also pulled up the optimized list and removed spotify from it and so far so good 

View solution in original post

Solution!

Re: Playback Stops in Lock Screen - Galaxy S10

Kylede5280
Casual Listener

Settings > Device Care > Battery > Spotify > Put App To Sleep is OFF. 

 

That should work. Every time you optimize the device, this turns back on so you may have to do this every time your phone gets "optimizied". 

 

Hope this helps!

View solution in original post

Screenshot_20190403-152042_Device care.jpg
Solution!

Re: Playback Stops in Lock Screen - Galaxy S10

Buddahead808
Newbie

i think I figured it out... If you swipe up to bring up your app drawer then in the search type in optimize.  Optimize battery usage will show up. Click on that then choose it again... in the drop down select all apps. Then scroll down to spotify and disable battery optimization.

View solution in original post

Screenshot_20190404-082917_Settings.jpg
Solution!

Re: Playback Stops in Lock Screen - Galaxy S10

samcooke24
Newbie

Using S10. The battery optimization did not work for me. However, I did find this to work: settings > lock screen > FaceWidgets > turn off music widget.

This allows Spotify's widget in the lock screen rather than Samsung's disfunction widget 

View solution in original post

Screenshot_20190423-001500_Settings.jpg
Solution!

Re: Playback Stops in Lock Screen - Galaxy S10

RobertGraves
Casual Listener

I solved this problem by logging in to my account at spotify.com and then I clicked the "Sign Out Everywhere" button. Then I had to sign in again and everything worked properly after that. I hope this will help anyone. 

View solution in original post

102 Replies

Re: Playback Stops in Lock Screen - Galaxy S10

xoholo
Composer

Hello,

Thanks for reaching out to the community!

 

Since you've already tinkered around with the power settings, why don't you try doing a reinstall of Spotify?

 

Keep us posted!

🙂

Re: Playback Stops in Lock Screen - Galaxy S10

millkd
Casual Listener
I tried an uninstall and reinstall. It did not fix the issue.

Re: Playback Stops in Lock Screen - Galaxy S10

Cleohex
Visitor

I'm having the same problem and have played with the power settings too. 

It's so frustrating and I concur cancelling subscription if not resolved.

Re: Playback Stops in Lock Screen - Galaxy S10

millkd
Casual Listener
I spent an hour on the phone with Samsung support today and here's what I learned:

If you go to Apps > Spotify > Optimize battery usage, Spotify will continue playing after you've clicked the power button to sleep the display. However, if you allow the display to time out and sleep on its own, Spotify will continue to shut off when the display sleeps.

According to Samsung technical support this is a new issue and they are looking into a fix.

In the meantime I hope this temporary work around is useful for you.

Re: Playback Stops in Lock Screen - Galaxy S10

xeratus
Casual Listener

I'm also having issues with Spotify playback over Bluetooth with my S10+ and it's very frustrating. I'll be playing music and every few songs it will just stop playing and the media buttons don't work ever. Trying to use the tap shortcuts on my galaxy buds also only ever works half the time. 

Re: Playback Stops in Lock Screen Samsung buds don't work at times - Galaxy S10

Socio_God666
Casual Listener

Same

Solution!

Re: Playback Stops in Lock Screen - Galaxy S10

Manasdama
Casual Listener

Hey..

I use s9+ . From india. i was facing same issues. When locked my screen its stops playbacm aftr few seconds. 

 

I hope this might help you.

Just open the main menu (appdrawer) and search for sleeping apps.  Open it in the settings. Its a 90% chance that the list might include spotify in it. Just long press spotify if it appears there and click on the remove on bottom right. And try it out then 

 

I hope this solves your issues. 

Thankyou. Do revert if its solved.  Attached few screenshots tooScreenshot_20190314-011422_Device care.jpg

 

Screenshot_20190314-011344_Finder.jpg

 

Screenshot_20190314-011347_Finder.jpg

 

View solution in original post

Re: Playback Stops in Lock Screen - Galaxy S10

xeratus
Casual Listener

Thank you. I never noticed this before. I have just now removed Spotify from sleeping apps so hopefully playback will continue. I'll post later with an update. 

Re: Playback Stops in Lock Screen - Galaxy S10

Manasdama
Casual Listener
I was facing it since a week. I was finding a solution myself. And i saw
your post . And idk somehow i figured it out itself. I found the solution
just bcz of your question. 😄 coincidence.

Re: Playback Stops in Lock Screen - Galaxy S10

CDEvans
Newbie

Removed Spotify from sleeping apps but still got the same issue.

Solution!

Re: Playback Stops in Lock Screen - Galaxy S10

RedFreeman
Visitor

Settings>Apps>Spotify>Battery>Allow background activity

I also pulled up the optimized list and removed spotify from it and so far so good 

View solution in original post

Re: Playback Stops in Lock Screen - Galaxy S10

Katnic31
Visitor

Thank you!!! My Spotify was on that list and I removed it.

Makes sense. Much appreciated!

Re: Playback Stops in Lock Screen - Galaxy S10

Socio_God666
Casual Listener
Yeah I started to mess around with it and got it to work don't know how but
it plays now.

Re: Playback Stops in Lock Screen - Galaxy S10

leocalegari
Casual Listener

thank you. this step helped.

 

Re: Playback Stops in Lock Screen - Galaxy S10

leocalegari
Casual Listener

worked perfect after your advise... thank you

Re: Playback Stops in Lock Screen - Galaxy S10

Jason41090
Newbie

Here is the permanent fix for this issue. Go to settings, apps, click on spotify, click on battery. Then click on optimize battery usage. There will be a drop down menu at the top of the page that will let you click All. Then scroll down to spotify and toggle the slider to your left to where it is off. This should fix your issue. Happy listening! 

Re: Playback Stops in Lock Screen - Galaxy S10

Terrencef84
Casual Listener

Idk if you figured out how to fix this problem yet. Here's how to fix it, you need to go to settings. Then search for sleeping apps, once you do that you need to make sure spotify is not one of them. If it is take it off. Once you do that problem fixed 🙂

Re: Playback Stops in Lock Screen - Galaxy S10

jtfrazier
Casual Listener

This is also an issue with my S10. The Optimize - manually select power off button trick does not work for me. I also ensured that Spotify may run in the background (not in the sleeping apps)  NOTE: it doesn't permanently remain off. It "pauses" and will start playing again. It does this throughout its time with the screen off and the pauses are significant.  Like others, if this can't be resolved soon, I'll drop my Spotify premium subscription. There is no other music app that has this issue. Amazon music is fine. UPP app is fine. What's the problem with Spotify? Doesn't matter if the music is local or not. Overall, I love Spotify but this is intolerable (especially in the midst of workouts). 

Re: Playback Stops in Lock Screen - Galaxy S10

Fefirz
Newbie

Go to your phone Settings>Apps>Spotiffy>Battery>allow background activity

SUGGESTED POSTS