Help Wizard

Step 1



Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...


Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...


Sportify Connect does not connect

Sportify Connect does not connect






Samsung Note 9 and NAD amplifier with bluesound module

Operating System

Android 9


I have been using Spotify Connect without problems for the last 2 years. I use my Samsung Note 9 to control my NAD amplifier with bluesound streaming module.


Since last week, this does not work anymore. The amplifier/streamer is still listed as an available device in the Spotify app on my phone, but when I select it, a connection cannot be made. The amplifier/streamer does not seem to be the problem, because it streams without problems from other sources.


I can "solve" the problem when I delete all the data of my Spotify app and log in again, or if I reinstall the app completely. Then the connection can be made, but the problem reappears about one hour later.


I have tried all the usual tricks (unplugging/rebooting/reinstalling...) but nothing seems to work. I would be very happy if someone had an idea how to solve this problem.




My Question or Issue


15 Replies

Has nobody ever had a similar problem?

I have the same problem. Suddelny connect feature stopped working. Until few weeks ago I was able to connect to other android devices, windows 10 pc, bose soundtouch, sony soundbar and vice versa. And now none of them work anymore.

Reinstalling the android app solved it for a few songs (but with wrong song infos) only once. I have no Idea how to fix it.

Here is an update on my problem.

After I did not get any response in this forum, I contacted the Spotify support. I spent more than an hour in the chat, and in the end got a suggestion copy-and-pasted from the bluesound forum. I had already found and tried that suggestion (to disconnect Spotify in the bluos app and connect again) myself, and it did not help. Then the person in the chat told me that it is not a Spotify problem, and I should contact bluesound support.

Hence I contacted bluesound support, including sending a log file from my device. Eventually I got a generic email with a list of router settings. Not very helpful, since I had not changed any router settings.

Surprisingly, the problem disappeared around that time, without me changing anything. Unfortunately, the problem is back today. Again, I did not change any settings. This is getting annoying. Any suggestions by anyone?


Have you tried to connect while playing your liked songs playlist?

I have a problem to connect with spotify connect devices while i play an album from my library. The problem does not appear when i play a playlist.

Thanks for the proposal. I just tried this and you are absolutely right. The problem appears when I play from my library, but not otherwise. Playlists work. And as soon as I remove an album from my library, I can also play it. Knowing this helps a lot already, so thank you. It is still odd. Any ideas how to fix the problem?

i am discussing this problem with the support since 6 hours (!) and they are just, sorry, incompetent. "reinstall this, reset that, restart your router..."


It has nothing to do whether the album is saved in your library or not - you just dont can start the playback via the album library. if you "go to album" via the options or the artist page, it works fine.

here it seems the problem appears only with albums that are saved on august 19 or later. Cannot confirm that because i don't have albums that are saved bevore august 19.

Here it is reccomendet to install the version V8.5.18.932

I tried it an the problem disappeared. But using an old version cannot be the solution. spotify has to acknowledge this bug.


router restarting won't solve this problem.

Thanks for the update. The story about August 19 cannot really be true; the problem first appeared for me end of June.

Interesting - for me the problem appeared just a few days ago - on 3. Septembre.


Did you try the downgrade to V8.5.18.932?


Funny thing i found out: if you mark some or all songs of an album as favourite with the heart icon - it is no problem to play this songs from the album library view at all.

No, I have not tried the downgrade.

Another interesting observation: whenever the connection cannot be made, my bluesound streaming device shows me the information "Spotify is playing elsewhere" on the display and the app.

The spotify support just answered me, that they have forwarded all the information.

Let's hope that they'll fix this problem in one of the next updates.

I have exactly the same problem. Unsaved a album and could immediately transfer it to the speaker.

Same problem here. 

Two Bluesound Powernodes. This thread helped me see the pattern after having spent several hours going through my network settings.


When I add an artist to my library by following the artist. And then go to my library, the artist: All songs play


When I add an album by liking that album, and then go to my library, the artist: Playing a song results in the connected device disconnecting with the message 'Connecting'

When I go to my library, the album and play the same song, all works well.


If I like a song (not just the album) all works well


So to me it seems, that the only thing, that does not work, is trying to play a song from a liked album from My library -> Artists



The same problem here. If I want to play an Album I can't connect to Heos or Echo. I hope it will be fixed very soon, because I want to hear an Album with a good quality. 

I just got a Bluos speaker now and it worked perfectly for 24 hours. This morning Spotify connection stopped working. This whole time I have been playing songs that Ive qeued and it has not been a problem until now but I am still just playing my que. Qeued a buuunch of songs from different albums. Playing Am or Fm radio works in the bluos app but spotify connection says "Playing somewhere else". And in Spotify app it says that Spotify Connect is conneting for a long while until the trial to connect failed. 


Spotify really needs to do something about this! I cant even find a support email or phone number to call. Clearly Spotify problem, not my wifi or Bluos / bluos app.

Yesterday ist worked, and I was happy. Now it stopped working, and I'm waiting for a fix. 

Suggested posts