Announcements

Help Wizard

Step 1

NEXT STEP

FAQs

Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...

VIEW ALL

Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...

VIEW ALL

Spotify on android auto - Spotify doesn't seem to be working right now

Solved!

Spotify on android auto - Spotify doesn't seem to be working right now

Plan

Premium

Country

Italy

Device

Nokia 7 plus

Operating System

Android One version 10

 

My Question or Issue

It's some week that Spotify does not work anymore on android auto.

I tried to unistall the updates of Android auto and update to last version again. I also tried to uninstall Spotify and reinstall that. It worked only one time. When I attach my phone to my car and I select Spotify, on the screen of Android Auto appears the message "Spotify doesn't seem to be working right now".
If I connect my phone with bluetooth I can listen Spotify, but another problem is that the car screen show only the title of the first song and don't update it when the next song is played and the command of car (next and prevoius track) don't work on Spotify. (I have a Ford Fiesta with Ford Sync 3.0)

I think that the two problems are related because they started in the same time.

Reply
Top Answer
Peter
Spotify Legend

Hey folks,

 

Thanks for all your reports so far!

If you're experiencing the issue as described in the original post by @TizioIncognito, make sure to head over to this Ongoing Issue thread, where we'll be providing updates on our progress with the investigation into the issue.

 

Cheers!


Accepted Solutions
Marked as solution

Hey there @TizioIncognito

 

Welcome to the Community and thanks for getting in touch about this. 

 

You mentioned that you've already reinstalled the app, but would you mind going through the steps of a clean reinstall, as it's more thorough than a normal one?

 

On another note, we suggest checking if your phone's OS has any pending updates.

 

Let us know how it goes!

EniModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 
“Music acts like a magic key, to which the most tightly closed heart opens.”– Maria von Trapp

View solution in original post

18 Replies
Marked as solution

Hey there @TizioIncognito

 

Welcome to the Community and thanks for getting in touch about this. 

 

You mentioned that you've already reinstalled the app, but would you mind going through the steps of a clean reinstall, as it's more thorough than a normal one?

 

On another note, we suggest checking if your phone's OS has any pending updates.

 

Let us know how it goes!

EniModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 
“Music acts like a magic key, to which the most tightly closed heart opens.”– Maria von Trapp

Thank you, the solution of clean reinstall seems to work.

Hi @TizioIncognito

 

Thanks for getting back to us. 

 

We're glad to hear that things are now working as they should. 

 

If anything else comes up, we're always a message away. 

 

Cheers!

NovyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Hi, I have to reopen the thread because the problem is not solved.

If I clean reinstall Spotify it works, but I go to home with my car, I take the car again and the problem is still here.

I use Spotify also in my home with Google Nest and I recently created a new app in the developer dashboard for integrating Spotify with Home assistant. (I use this guide https://www.home-assistant.io/integrations/spotify/ )

Is this that break android auto integration and Ford Sync integration? (the command in my car don't work anymore)

Hey there @TizioIncognito,

 

Thank you for your reply.

 

Can you let us know which version of the app you have?

 

It would also be great if you can try from another device to see if the issue persist?

 

We'll keep an eye out for your reply.

 

Cheers!

JeremyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Live, love, laugh and listen to music 🙂

I have a Nokia 7 plus smartphone with android one.

I have android 10 with february patch (last patch released for my smartphone).

Spotify is updated 8.6.4.971 (Play store don't show me any updates)

In the next days I try with another smartphone, but I would like to use my smartphone in my car.

Hey @TizioIncognito,

 

Thanks for getting back to us 🙂

 

You can also try with another account on the same device. That way we can check if it's an account-related issue.

 

Let us know how it goes. If you have questions, you know where to find us.

Ver Moderator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

I created a new free account with a new email. It worked only one times and now same problem.

Hi again @TizioIncognito

 

Thanks for keeping us in the loop. 

 

Would you mind sending over a picture or a video where we can take a better look at this issue? 

 

Just attach it to your next response to us by using the Insert Photos or Insert Video option in the post editor and make sure to exclude any personal info from it. 

 

We'll keep an eye out for your reply.

NovyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

I made 2 video.
I uploaded them to Google drive because they are big.

In the first video you can see that I attach my smartphone to usb of my Ford car and Android auto starts. But Spotify doesn't work.

In the second video I connected my smartphone to my car with bluetooth. I can control the music, but the title of the songs is not updated on the screen.

I attach also a picture with the version of Ford Sync infotainment

 

https://drive.google.com/drive/folders/12x43G7HLnFN8OOVQ3ZqPDB-F17gjWnIf?usp=sharing

Hey @TizioIncognito,

 

Thanks for getting back to us with the videos and for the extensive troubleshooting done so far!

 

We've collected all the info you've provided and forwarded it to the right folks. They'll take a closer look in to the issue. We'll keep you informed on any news we have on the matter here, as soon as there are any.

 

In the meantime - don't hesitate to let us know if there's anything else we can help out with.

Mihail Moderator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Hey @TizioIncognito 🙂

 

There is a new version of the app. Could you check if the issue persists? 

 

If there are no changes, we'll need the exact Spotify version.  We'll pass the info on to the right team.

 

 We'll be right here if you have any further questions.

Ver Moderator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

I don't have any updates on play store. The current version is 8.6.8.1094.

Hi @TizioIncognito

 

Thanks for keeping us posted. 

 

We'll share updates about this as soon as we have any.

 

Cheers! 

NovyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Hi Spotify Support,

 

The issue TizioIncognito is describing is one I have been having on my OnePlus 6T with Android 10 as well for the past couple of weeks. The app is updated and the clean install works, but only for one time.

 

I have also tried the battery optimization solution from another thread ("do not optimize"), bit that does not work.

Hey there @Glivmo,

 

Thank you for your post in this thread and for the troubleshooting steps you've taken so far.

 

Can you let us know which version of the app you have?

We'll keep an eye out for your reply.

 

Take care!

JeremyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Live, love, laugh and listen to music 🙂

Hi @Jeremy

 

I had the latest version from the Google Play store installed (version 8.6.12.986). I have now installed 8.5.94.839 to see if 8.6 is the culprit, as the problems only started recently. I will get back to you after I tried it (later today).

Hey folks,

 

Thanks for all your reports so far!

If you're experiencing the issue as described in the original post by @TizioIncognito, make sure to head over to this Ongoing Issue thread, where we'll be providing updates on our progress with the investigation into the issue.

 

Cheers!

Suggested posts