Spotify won't pause music when the phone's locked

Reply
Highlighted

Spotify won't pause music when the phone's locked

Casual Listener

Hi, I'm having issues with Spotify.

 

Device: Samsung Galaxy S10+

OS: Android 9

So this kinda topic has already been opened, and it's now also in the FAQ. And the answer is "Just reinstall the app." Geee thanks. Though I wouldn't blame you if it worked for you. You should be blaming me or my phone. Just throwing all of this out there. So here's my issue, when I start any kind of music and then lock my phone, when I press the power button to wake it up and go to pause the music on the login screen, it stops and then just continuous to play. Heck it even rewinds a bit for some reason. I have tried the formula that has been said a thousand times; Completely wipe the app, and uninstall it, restart the phone, reinstall, and voila, it worked. Until a little while later when it stopped working again?! Now you could just say "Just do it again", but:

Problem No. 1; I'm just plain old lazy.

Problem No. 2; If I were to keep doing that I would have to then redownload all my music; see I listen to music on the road (what a surprise) and I value my mobile data connection, and I really don't want to waste 1 GB just to stream music. In fact a lot of times I actually (accidentally) waste all my mobile data. So downloading all my music is the way to go for me. And I just really don't care about Data Saver. It wouldn't save me from a throttled 32 kbit/s connection. Also any bits and bytes of my mobile data that I could have backed up for other more important things, the better.

Problem No. 3; I don't want to wreck my phone's internal storage by this constant deletion and rewriting. I just really don't.

This post may get turned down because it's already been opened and answered, and to be honest it's not professional at all - though I do believe that things can be better explained when stakes are more loose -, but either way, I couldn't find anything that could fix it permanently (!). I even thought of maybe some kind of other app glitching it out. But before I'd try that I'd love to hear from people over here. Your help is truly appreciated.

 

Sincerely,

SpeedRunHunter.

1 Reply
Highlighted

Re: Spotify won't pause music when the phone's locked

Casual Listener

Ah... This is embarrassing.

 

When you've got a problem that you just have no idea how to resolve, but then you try something and then it goes back to normal. This why it's good heading to tech support, because the second you ask something, you'll solve the problem on your own. So what I've done is I logged out, restarted my then logged back in, without using Facebook, and then it worked, not 100% sure if this is permanent or if it will reoccur, or maybe another app will glitch it out, but overall it is working again. Still I'll do some more investigation.

SUGGESTED POSTS