Help Wizard

Step 1


Why the hell can't I sync my local files by just plugging my phone into my computer?

Why the hell can't I sync my local files by just plugging my phone into my computer?

I have a Samsung Galaxy Note 2 N7100, which I'd like to sync my local files over to. I realize that you can do that by connecting to the same WiFi network as my computer. The problem is that I use a desktop, and I'm running it over an ethernet cable. So it's impossible for me and tons of other desktop users to sync our local files to our Android device. Why can't you atleast make it possible to play files that have already been manually transfered?


What the hell are the developers thinking? I've been using Spotify since 2009, and it feels like it's gone into a beta the last 2 years. On a side-note, what about the lack of support of FLAC files, which customers have been demanding for years?

9 Replies

Actually. as long as the mobile and the desktop are connected to the same network and subnet synching is possible. It doesn't matter if the PC is connected by wire and the mobile via wifi. But yes, this does mean you need a wireless modem/router.

How come it doesn't work though? I'm running Cyanogenmod 10.2.



This e-mail I got from the Spotify team says otherwise.

It should still work fine. You may need to temporarily disable any firewalls, antivirus and security programmes running on your PC and make sure that UPnP is enabled in the router settings. When I mentioned the same subnet, this means that your PC needs to be connected by cable to the router and not to the modem.

i love you so much no **bleep**, i turned my firewall off and it worked.

Hey @iATEepie,


Glad to hear turning the firewall off did the trick for you 🙂


We'll be here if there's anything else you need help with.


Have a good day!

Mario Moderator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

I turned off my firewall and it still doesn't work. I am using an Ethernet Cable. Any ideas?

Hey there @madtak59


Thanks for reaching out about this in the Community. 


If possible, could you try connecting your PC to a WiFi network to see if you notice anything new? 


If this doesn't do the trick, we'd recommend performing a clean reinstall of the app on your devices. This is often an overlooked step, but it can be helpful to get rid of any corrupted files that might be causing trouble. 


Let us know how it goes. We'll be on the lookout for your reply.

i have been trying to do**bleep** for actual months, mario I owe you my life

Suggested posts