Announcements

Help Wizard

Step 1

NEXT STEP

Hiding song on queue (dislike) does not work, song is not removed from queue.

Solved!

Hiding song on queue (dislike) does not work, song is not removed from queue.

Plan

Premium

Country

Poland

Device

iPhone

Operating System

iOS

 

My Question or Issue

 

Hi there!

Please help me hide songs that I disliked... Minus sign in circle icon does not prevent songs from being played again... disliked songs are still in my queue. What should I do?

 

Thanks!

Reply

Accepted Solutions
Marked as solution

Hi there @goscxyz,

 

Thanks for the videos you sent over.

 

We checked them and this is indeed expected behavior. When you hit the 'Hide song' button on any Spotify Radio/ Autoplay/ Discover Weekly, the song will be hidden and not played only in the current session. This means that if you go and start Radio again, the same song won't be hidden. Currently there is no way to permanently block or hide a song. 

 

What you can do is block the artist profile if you really don't like their music. This way all content from that artist will be skipped.

 

Hope this clears things up.

AlexModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

View solution in original post

6 Replies

Hey there @goscxyz

 

Thanks for reaching out about this here in the Community. 

 

Could you let us know with which playlists are you experiencing this? 

 

Also, sending us a screen recording of the issue happening would come in handy. You can attach it to your next response by using the Insert Video option in the post editor. You can also upload it to Google Drive and share the link with us (make sure the video has the permissions for anyone to see it).


Lastly, does this only happen on your iPhone or on other devices as well? 

 

We'll be on the lookout.

EniModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 
“Music acts like a magic key, to which the most tightly closed heart opens.”– Maria von Trapp

Hi @Eni, thanks for help 🙂

I've attached screen recording in two parts (sorry for that). I have this issue on web browser as well. I'm not using playlists. What I do is I select one song that I like and then hit "play next" so that Spotify can suggest some good song for me based on my preferences. 

Marked as solution

Hi there @goscxyz,

 

Thanks for the videos you sent over.

 

We checked them and this is indeed expected behavior. When you hit the 'Hide song' button on any Spotify Radio/ Autoplay/ Discover Weekly, the song will be hidden and not played only in the current session. This means that if you go and start Radio again, the same song won't be hidden. Currently there is no way to permanently block or hide a song. 

 

What you can do is block the artist profile if you really don't like their music. This way all content from that artist will be skipped.

 

Hope this clears things up.

AlexModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Why mark and issue has solved when you Just ignore the problem and call It an feature?

It would be so nice if you could block a song from playing across radio stations and playlists.

In order to get good recommendations from Spotify, one of the ways to do it is to use the hide/unhide function.

 

But not having it work with Spotify Radio/ Autoplay/ Discover Weekly is a major shortcoming.

 

Please fix this.

Suggested posts