Help Wizard

Step 1



Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...


Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...


Stop recommended songs from automatically playing on playlists

Stop recommended songs from automatically playing on playlists

I'm finding it increasingly frustrating that Spotify automatically plays recommended songs on my playlist. They usually have nothing to do with the playlist i have created for a specific reason! I should be able to choose whether i play them or not, and i should be able to say No thanks!! I have created a Christmas playlist and the recommended songs that automatically play are 'Apron Strings- Cliff Richard and The Legendary Sannin on the knightmare/frame Album' i mean seriously no one should have to listen to that!!  

6 Replies

Hi, @LJD1, Autoplay is a feature you can disable in your settings.


For example, if you're using the desktop app (I work on a Mac), you can go to the dropdown menu in the top right corner, and click on "Settings." Scroll down to the bottom, you should see something that looks like this. 
Screen Shot 2017-12-21 at 9.28.28 AM.png

Toggle that switch to the left, and playback will end when your playlist does.

If you're on a mobile device, click on the settings icon (it looks like a cog), then on "Playback." Scroll down a bit, and you'll find an "Autoplay" switch there. Again, toggle it to the left.

I move this switch a lot, because there are times when I want to listen only to the music on the playlist I've created, but other times I like setting a general tone and having Spotify fill in the blanks for me.

I hope this solves your issue — let me know if you have any other questions about it!

I don't have the autoplay option in my settings on the mac. I switched off autoplay on my mobile device and that does'nt work either.

Does anyone have any other suggestions? If I can't stop the recommended music from interrupting playlists or albums, I will quit Spotify. This is not what I signed up for!

@brian_mansfield wrote:


Screen Shot 2017-12-21 at 9.28.28 AM.png


Hi Brian,

That really helped me, indeed! I listen to songs in my car, on my phone and on my Macbook so I needed to turn off this feature as well.


Thanks! 🙂



you can click the button to make the playlist reproduce from the beginning, you know, the one opposite to the shuffle button, at least you're gonna be listening to songs you'd had previously picked,

for a normal Spotify app you can disable autoplaying, sometimes that option doesn't appear until the app at least autoplayed once.

add more songs

The auto play feature isnt the issue. I have it disabled and it hasnt made any differance, in my case, I absolutely hate it with a passion that Spotify is recommending songs in the middle of my playlist (not at the end). There doesn't seem to be any way to turn this off; my playlist is over 5 hours long. So, it should not be a case of not having enough content.

The only way I can disable it is by setting Spotify to offline mode, which is ok, except I then lose the ability to control it with my stream deck; this "feature" is really **bleep**. I hate it. If I can't fix it I will cancel my subscription because I am over it.

I am using Spotify for Windows (64 bit)

Suggested posts