Announcements

Help Wizard

Step 1

NEXT STEP

FAQs

Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...

VIEW ALL

Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...

VIEW ALL

Close button should minimize the Spotify window - Spotify won't minimize using Close button

Close button should minimize the Spotify window - Spotify won't minimize using Close button

Plan

Premium Family

Country

United Arab Emirates

 

Device

Desktop

Operating System

Linux Mint 19.3 Cinnamon

 

My Question or Issue

There is an option in Advanced Settings for "Close button should minimize the Spotify window". This morning I discovered this and switched it on. 

Closing the window, however, shuts down Spotify. 

 

I've tried the usual troubleshooting elements:

1. Clear cache

2. Clear storage

3. killall

4. Spotify dump (results in 0Kb text file)

 

Does this work on other Linux environments? Is there anything else I need to do to make Spotify minimize instead?

 

Reply
94 Replies

thanks for your hard work, it works perfectly now!

Everything is working great now, thanks for your work!

 

It's a pity though that the tray icon still can't be adjusted to the theme of the design like the rest of the apps for Linux, such as Telegram, Dropbox, Mega Cloud, Jetbrains Toolbox. It would be cool if you could add a style to the most popular icon pack for Linux, Papirus Icon Theme: https://github.com/PapirusDevelopmentTeam/papirus-icon-theme/

 

The papirus team on github has created a tray icon specifically for spotify,
spotify-indicator: https://github.com/PapirusDevelopmentTeam/papirus-icon-theme/blob/master/ePapirus/24x24/panel/spotif...

photo_2023-10-12_19-11-37.jpg

Hi temcodes, thanks for the nice message. I will try to take a look at the icon theme at a next time that I get to work at the client. I let you know of any progress

Hi, thanks for your work in this since I know it is not a main priority.

 

Unfortunately, this seems not to work in GNOME, I am on Fedora 38 GNOME 44.5. It might be a GNOME issue since they don't really have a system tray anymore. Can you confirm the DE you use to test? Thanks!

 

Hi evelez, make sure you are using all dependencies to display the icon. You may want to check this page: https://github.com/negativo17/spotify-client/issues/35.

 

Also make sure that the "Close button should minimize the Spotify window" feature is in disabled mode ("Startup and window behavior" section)

 

Do you have the "AppIndicator and KStatusNotifierItem" extension installed?
https://extensions.gnome.org/extension/615/appindicator-support/

 

I am using Fedora 38 with KDE, I confirm that the feature works without problems.

Hi again evelez,

you can learn about how to install the native spotify client (not snap version) for fedora on this page: https://negativo17.org/spotify-client/.

Hi, thanks for this info! I'll look into that native install. Your advice to install "AppIndicator and KStatusNotifierItem" actually worked! Spotify stays open in the tray. There is still the problem that I can't double click the tray icon to get the window back, but clicking the dash icon brings it back no ptoblem.

 

Thanks again!

 

Yes, the problem with double-clicking the tray icon is still an issue. Perhaps the developers should add the ability to switch the focus to an open Spotify window

fix it man. treat all of your users equally.

it has been almost 10 months man

where was it released and how can i download it ?

 

Hi x1ph3rr, what Linux distribution do you have?

jammy

Earlier in this topic already mentioned where you can download the latest version, but I think snap version will work for you (sudo snap install spotify --candidate) https://snapcraft.io/spotify.

nope, i meant, i already have the snap version. my problem was with this minimising tray issue. which has been fixed for others now i guess. so i am asking from where can i download that version which fixed this issue

Apparently, you have a stable version of the application installed. Run in terminal: sudo snap install spotify --candidate

You need to install the candidate version

so this is the version 1.2.22 that fixes the issue?

also, do you know how can i fix the "open spotify automatically after login" because i have enabled this setting to yes, yet it does not automatically open after i restart my laptop.

using jammy distribution

x1ph3rr_0-1697269100367.png

At this time, this functionality is still not available for Linux...

ah, okay. so it will take another 2 years to fix lol. anyways, thanks!

Suggested posts