Interface not scaling on HDPI screen based on System Settings [Ubuntu 18.04 and 18.10]

Solved!
Reply
Highlighted

Interface not scaling on HDPI screen based on System Settings [Ubuntu 18.04 and 18.10]

andreaolivato
Casual Listener

Plan

Premium

Country

Singapore

Device

Huawei Matebook X PRO

Resolution : 3000x2000

Scaling Factor: 200%

Operating System

Ubuntu 18.10 (and 18.04)

 

My Question or Issue

The Spotify interface doesn't follow the scaling factor set in the Gnome Settings (200%). Everything is super small, as the rest of the desktop would appear at 100% scaling since the resolution is very high. 

I think the problem is with Electron that is not correctly configured, and I found this Github topic for support: https://github.com/electron/electron/issues/615 

Attached is a screenshot comparing everything else VS Spotify

screenshot from 2018-10-19 18-17-32.png
1 ACCEPTED SOLUTION

Accepted Solutions
Solution!

Re: Interface not scaling on HDPI screen based on System Settings [Ubuntu 18.04 and 18.10]

ddtaycl
Casual Listener

Repeatedly pressing

[CTRL]  [=]

also did the job. You often see

[CTRL] [+]

being written on here, but in fact that doesn't work (involves holding the shift key). So, counter-intuitively, the three keyboard shortcuts for zooming in Spotify for Linux are:

[CTRL] [0]    to return to default zoom

[CTRL] [-]    to zoom out

[CTRL] [=]    to zoom in

These keyboard shortcuts, once used, should persistently affect the zoom level. As it turns out, the Spotify front-end is highly optimised for high-DPI screens; they just haven't placed a suitable option in the settings, which is crazy if you ask me because it's 2018 and everyone's buying high-DPI monitors now.

4 Replies

Re: Interface not scaling on HDPI screen based on System Settings [Ubuntu 18.04 and 18.10]

ddtaycl
Casual Listener

They really, really need to sort this out.

Saying it's not an official product just doesn't wash; more than half the world's computers run on Linux for crying out loud.

Re: Interface not scaling on HDPI screen based on System Settings [Ubuntu 18.04 and 18.10]

andreaolivato
Casual Listener

 I read your own thread and looked at your solution, which didn't work on the Snap version.

 

I edited the .desktop file to make your workaround work:

 

sudo vim  /var/lib/snapd/desktop/applications/spotify_spotify.desktop

 

And changed 

Exec=env BAMF_DESKTOP_FILE_HINT=/var/lib/snapd/desktop/applications/spotify_spotify.desktop /snap/bin/spotify %U

 

to

 

Exec=env BAMF_DESKTOP_FILE_HINT=/var/lib/snapd/desktop/applications/spotify_spotify.desktop /snap/bin/spotify --force-device-scale-factor=1.5 %U
Solution!

Re: Interface not scaling on HDPI screen based on System Settings [Ubuntu 18.04 and 18.10]

ddtaycl
Casual Listener

Repeatedly pressing

[CTRL]  [=]

also did the job. You often see

[CTRL] [+]

being written on here, but in fact that doesn't work (involves holding the shift key). So, counter-intuitively, the three keyboard shortcuts for zooming in Spotify for Linux are:

[CTRL] [0]    to return to default zoom

[CTRL] [-]    to zoom out

[CTRL] [=]    to zoom in

These keyboard shortcuts, once used, should persistently affect the zoom level. As it turns out, the Spotify front-end is highly optimised for high-DPI screens; they just haven't placed a suitable option in the settings, which is crazy if you ask me because it's 2018 and everyone's buying high-DPI monitors now.

Re: Interface not scaling on HDPI screen based on System Settings [Ubuntu 18.04 and 18.10]

andreaolivato
Casual Listener

This is by far the user-friendliest solution. I had tried CTRL + and as you reported it doesn't work.

CTRL= instead works perfectly

 

Apart from adding an option under settings, I think it should read from system settings and apply the same zoom lvl.

BTW, thanks a lot for sharing this

SUGGESTED POSTS