[SOLVED] PulseAudio + Volume Control

Solved!
Reply

[SOLVED] PulseAudio + Volume Control

Vt4Ly6J7
Casual Listener

Plan

Premium

Country

United States

Device

Dell G7 7590

Operating System

Debian 10 (Buster)

 

My Question or Issue

Is there any way to disable the shared volume control between the Spotify client and system volume (PulseAudio)? When I change the volume on Spotify it effects the entire system which makes Spotify a bit pointless to use when trying to game as I have now lost the ability to fine tune the volume of the Spotify client.

 

If there isn't a way to do this could you please implement an option so that we can have the option to fine tune the volume of the Spotify client again, it wasn't like this before the most recent updates.

1 ACCEPTED SOLUTION
Solution!

Craythur
Music Fan

Do only spotify have this behaviour? Or other programs have it? In the latter case you probably have flat-volumes turned on in pulseaudio.

If you (in a terminal) run:
grep flat-volumes ~/.config/pulse/daemon.conf /etc/pulse/daemon.conf
it will show what your pulseaudio is set to (to turn it off simply change the "yes" to "no" with your favorite plain-text edit) (lines starting with ";" are comments (do no confuse with ":"), and restart pulseaudio)

(To explain that command. it will search for the phrase "flat-volumes" in the file daemon.conf in the user directory and the system wide settings respective (it is highly likely you have the file in only one of the locations, user directory version is used if both are present)).

View solution in original post

2 Replies
Solution!

Craythur
Music Fan

Do only spotify have this behaviour? Or other programs have it? In the latter case you probably have flat-volumes turned on in pulseaudio.

If you (in a terminal) run:
grep flat-volumes ~/.config/pulse/daemon.conf /etc/pulse/daemon.conf
it will show what your pulseaudio is set to (to turn it off simply change the "yes" to "no" with your favorite plain-text edit) (lines starting with ";" are comments (do no confuse with ":"), and restart pulseaudio)

(To explain that command. it will search for the phrase "flat-volumes" in the file daemon.conf in the user directory and the system wide settings respective (it is highly likely you have the file in only one of the locations, user directory version is used if both are present)).

View solution in original post

Vt4Ly6J7
Casual Listener

Thank you so much, this was exactly the problem. Much appreciated!

SUGGESTED POSTS