Spotify 0.9.11 for GNU/Linux

Solved!
Reply

Spotify 0.9.11 for GNU/Linux

parbo
Spotify Legend

Hi, fellow penguin fans!

 

Today we've pushed version 0.9.11.26 of the Linux desktop client to our public repo. Just update your system!

 

General release notes: http://community.spotify.com/t5/Help-Desktop-Linux-Mac-and/Release-Notes-Spotify-for-Desktop-0-9-11/...

 

Linux specific changes:

 

 - collectionCache.bnk is no longer written to $HOME

 

Known issues:

 

 - It still doesn't work to drag from an HTML5 view to a legacy view (such as the sidebar).

 - On first start, the HTML5 views may not appear (just empty black views), try restarting the app if it happens

 - Some users have reported problems with the new track change notifications. If you experience problems, you can start the client with "spotify --ui.track_notifications_enabled=false", or you can edit the file called ~/.config/spotify/Users/<your-spotify-username>-user/prefs and add a line with "ui.track_notifications_enabled=false". Sorry for not having this option available in the UI.

 - No 32-bit build is available

 - This build is not compatible with debian squeeze or wheezy

 

If you don't already have the Linux client installed, install like this:

 

# 1. Add our repository. As root or with sudo, create
#    a file called /etc/apt/sources.list.d/spotify.list and add
#    "deb http://repository.spotify.com/stable non-free" to it.
#    Here's a one-liner:
sudo sh -c 'echo "deb http://repository.spotify.com/stable non-free" > /etc/apt/sources.list.d/spotify.list'
 
# 2. If you want to verify the downloaded packages,
#    you will need to add our public key
sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 94558F59
 
# 3. Run apt-get update
sudo apt-get update
 
# 4. Install spotify!
sudo apt-get install spotify-client
 
You don't have a debian based system? Well, it's still possible to get things running. Either you convert the debian package to something else using alien, or you can just download and extract the stuff you need from the package. There is no need to install the client, it can be run from anywhere.
 
# 1. Get the right filename
SPOTIFY_DEB=http://repository-origin.spotify.com/pool/non-free/s/spotify/spotify-client_0.9.11.26.g995ec04.78-1_`uname -m | sed s/x86_64/amd64/ | sed s/i686/i386/`.deb
 
# 2. Download the package
wget repository.spotify.com/pool/non-free/s/spotify/$SPOTIFY_DEB
 
# 3. Extract the required parts
ar p $SPOTIFY_DEB data.tar.gz | tar -zx --strip-components=3 ./opt/spotify/spotify-client
 
# 4. Go in to the extracted folder
cd spotify-client
 
# 5. Setup symlinks to libs (NOTE: this script assumes Fedora 17, edit to suit your needs)
./linklibs-fedora.sh
 
# 6. Optionally register icons and menu item
#    Note: for the menu item to work, you need to ensure
#    spotify is in your $PATH, either by symlinking
#    it from /usr/bin or /usr/local/bin, or by adding
#    the spotify-client folder to your $PATH
./register.sh
 

 

16 ACCEPTED SOLUTIONS
Solution!

rannyakuza
Casual Listener

Hmm, this seems to be because of an erronuous http/dns redirect. As a workaround, place the following in /etc/apt/sources.list.d/spotify.list:

 

deb http://repository-origin.spotify.com stable non-free


This URL does not have the spotify-redirect-to-our-homepage-because-i-dont-know-why-argh redirect rule, therefore apt-get will work. After Spotify fixes this, you should be able to change the apt-get URL above back to its default (ie. without -origin in the URL).

View solution in original post

Solution!

CaptDragon
Newbie

This worked for me, Thanks!


@rannyakuza wrote:

Hmm, this seems to be because of an erronuous http/dns redirect. As a workaround, place the following in /etc/apt/sources.list.d/spotify.list:

 

deb http://repository-origin.spotify.com stable non-free


This URL does not have the spotify-redirect-to-our-homepage-because-i-dont-know-why-argh redirect rule, therefore apt-get will work. After Spotify fixes this, you should be able to change the apt-get URL above back to its default (ie. without -origin in the URL).


 

View solution in original post

Solution!

webrunner1981
Regular

Remove the spotify repository from software sources , then add spotify source with origin in name

 

In terminal

sudo add-apt-repository -r "deb http://repository.spotify.com stable non-free"

sudo add-apt-repository "deb  http://repository-origin.spotify.com stable non-free"

sudo rm /var/lib/apt/lists/* -vf
sudo apt-get update

sudo apt-get upgrade

 

Let me know does it work for you.

 

View solution in original post

Solution!

StefanoRadice
Music Fan

Hello, I had the same problem and solved it thanks to your advice but in a slightly different way. I am running Ubuntu 14.04 64 bit, Spotify 0.9.11. The file you suggest to edit does not exist on my system. Creating it has no effect. I edited  /etc/apt/sources.list instead and replaced repository.spotify.com with repository-origin.spotify.com, now it works. Thanks!

View solution in original post

Solution!

porkchopper
Casual Listener

Thanks!

I did not copy and paste because I'm trying to learn to program. I followed some advice I read and tried reading what I typed backwards, but still missed it.

View solution in original post

Solution!

Peter__
Community Legend
There is nothing above 0.9.4 if you are on a 32-bit system due to the developers having issues with the Spotify build system.

Swap to 64-bit?

Peter
Spotify Community Mentor and Troubleshooter

Spotify Last.FM Twitter LinkedIn Meet Peter Rock Star Jam 2014


If this post was helpful, please add kudos below!

View solution in original post

Solution!

sleeksorrow
Roadie

@blurk wrote:

Also, the thing that shows suggestions when you search for something won't disappear unless you hit search


... or unless you press "tab".

View solution in original post

Solution!

olejon
Roadie

@HarmoAx wrote:

Hello,
I have installed the linux version of Spotify and the install went fine. Although, I'm experiencing problems with the launch of Spotify : when I launch it (either with the spotify icon or with command line) I'm getting this error : "spotify: error while loading shared libraries: libpangoxft-1.0.so.0: cannot open shared object file: No such file or directory"...
Any idea about how to solve this ? (I've done a quick search through the web and I haven't been able to find a solution...)
Regards.


Looks like you're missing a package (for some reason...).

 

Run this command to install it:

 

sudo apt-get install libpangoxft-1.0-0

 

In the future, you can use the "Search the contents of packages" search here to find out which packages provides what files.

SpotCommander - The most elegant, intuitive, feature-rich & universal remote control for Spotify, exclusive for Linux users!

View solution in original post

Solution!

TheTimeSInk
Regular

@wade1987:

 

Try changing your repo to: http://repository-origin.spotify.com 

 

We had this problem last spring and this fixed it. I haven't had any issue with installs on Ubuntu, but on a Mint install the other night I had to use this fix.

 

Reference:

http://community.spotify.com/t5/Help-Desktop-Linux-Mac-and/Spotify-0-9-11-for-GNU-Linux/m-p/845435/h...

 

View solution in original post

Solution!

olejon
Roadie

@Poltiser wrote:

 

There are differences between Xubuntu 14.04 (plays music from local HD) and 14.10 (does not play mp3 from HD) even after installing ffmpeg on Xubuntu 14.10


@Poltiser:

 

I just got local files working on Ubuntu 14.10 following my earlier instructions for 14.04 when the Spotify client was not updated yet.

 

Here you go:

 

http://community.spotify.com/t5/Help-Desktop-Linux-Mac-and/Linux-Local-files-do-not-play-on-Ubuntu-1...

 

It plays MP3s perfectly after doing this for me.

SpotCommander - The most elegant, intuitive, feature-rich & universal remote control for Spotify, exclusive for Linux users!

View solution in original post

Solution!

muammar
Music Fan

Yes, this is known. It has to do with notifications. So, if you run spotify as follows:

 

spotify --ui.track_notifications_enabled=false

 

 

it should work fine. 

View solution in original post

Solution!

olejon
Roadie

 

Now that local files playback doesn't work on Ubuntu 14.10, I'm reposting a fix I wrote back when it didn't work on Ubuntu 14.04. The fix still works.


I just compiled a minimal FFmpeg 0.10.12 from source (the version from the Saucy PPA), and extracted the necessary files to get local files playing. This way, we don't have to install an entire FFmpeg + libx264 built for an older version of Ubuntu library that potentially can disrupt other applications.

 

To get local files playing, simply run the commands below in a terminal.

 

  • Each command should be on one line (they get wrapped here)
  • This does not overwrite any files on a Ubuntu 14.xx system
  • Don't forget to the ldconfig and install the necessary codecs (the last two commands)

64-bit users:

 

sudo wget https://dl.dropboxusercontent.com/u/8593574/Spotify/ffmpeg/libavcodec.so.53 -O /usr/lib/x86_64-linux-gnu/libavcodec.so.53
sudo wget https://dl.dropboxusercontent.com/u/8593574/Spotify/ffmpeg/libavformat.so.53 -O /usr/lib/x86_64-linux-gnu/libavformat.so.53
sudo wget https://dl.dropboxusercontent.com/u/8593574/Spotify/ffmpeg/libavutil.so.51 -O /usr/lib/x86_64-linux-gnu/libavutil.so.51
sudo ldconfig
sudo apt-get install ubuntu-restricted-extras

32-bit users:

 

sudo wget https://dl.dropboxusercontent.com/u/8593574/spotify/ffmpeg/32-bit/libavcodec.so.53 -O /usr/lib/i386-linux-gnu/libavcodec.so.53
sudo wget https://dl.dropboxusercontent.com/u/8593574/spotify/ffmpeg/32-bit/libavformat.so.53 -O /usr/lib/i386-linux-gnu/libavformat.so.53
sudo wget https://dl.dropboxusercontent.com/u/8593574/spotify/ffmpeg/32-bit/libavutil.so.51 -O /usr/lib/i386-linux-gnu/libavutil.so.51
sudo ldconfig
sudo apt-get install ubuntu-restricted-extras

Please tell me if it doesn't work.

SpotCommander - The most elegant, intuitive, feature-rich & universal remote control for Spotify, exclusive for Linux users!

View solution in original post

Solution!

user-removed
Not applicable

Spotify segfaults after ~50sec when playing music if gtk+-2.24.26 is installed. Downgrading to gtk+-2.24.25-r1 resolves this.

 

[ 6564.483737] spotify[26506]: segfault at 7f6ddaad1dd0 ip 00007f6ddaad1dd0 sp 00007fff247c1878 error 14
[ 6564.483775] audit: type=1701 audit(1424437880.831:10): auid=1000 uid=1000 gid=1000 ses=1 subj=kernel pid=26506 comm="spotify" exe="/opt/spotify/spotify-client/spotify" sig=11

 

View solution in original post

Solution!

olejon
Roadie

@rainest wrote:

Ah, yes, Albums, I used to have those. Now they are all gone, who knows where.

 

Why do half the screens just bring up a big blank void.

 

2015-03-02-004340_2560x1440_scrot.png.png

 


Not seeing the same issue on a clean Ubuntu 14.10 64-bit virtual machine.

 

Try exiting Spotify completely, and remove your config and cache.

 

rm -r ~/.config/spotify
rm -r ~/.cache/spotify

 

SpotCommander - The most elegant, intuitive, feature-rich & universal remote control for Spotify, exclusive for Linux users!

View solution in original post

Solution!

cHagHi
Gig Goer

Thanks for the update!

 

I'm on Ubuntu 14.10, and I'm experiencing (almost) the same problems as Nico751:

  • I have an icon on the taskbar, but it's the standard "X11" plain icon, not Spotify's
  • The window decoration is wrong
  • I have no application menu
  • Media keys do not work
  • Spotify Connect does not work, the button seems to be disabled or inactive
  • There's no menu entry (presumably because the .deb does not install a .desktop file in /usr/share/applications)

The scrollbars work for me though, both with the mouse and the keyboard.

 

Any help will be gratly appreciated!

 

 

View solution in original post

Solution!

sleeksorrow
Roadie

@antortjim wrote:

Although I have been able to run the most recent version (1.0.1), I am experiencing the same issues as those you mentioned above. Also, I am unable to play local files, and the upper toolbar has dissapeared. What can I do to fix it or at least contribute to the development of the Linux client?? Running Ubuntu 14.04 64 bits. Thank you


I am not aware of a toolbar in versions below 1.0. If you mean the menu bar, the menu now is behind a little downward arrow in the upper right corner.

 

For playing local files, it may be that 1.0 still has the same issues with trusty as the older versions had. Try a search in this forum, a quick hit would be https://community.spotify.com/t5/Help-Desktop-Linux-Mac-and/Linux-Local-files-do-not-play-on-Ubuntu-...

 

Edit: I'm not sure if your local files show up, but are not playable, or if they don't show up at all. In first case, see my hint above. In the latter case, it may be that you just need to re-add the local music folders in your preferences. As far as I remember, the settings have been resetted to default for me.

 

Edit2: Indeed, Spotify 0.9 is using $HOME/.config/spotify and Spotify 1.0 is using $HOME/.config/Spotify (note the uppercase "S"). That's why the config was all default after update, and it means your old config for 0.9 is still there and untouched.

View solution in original post

368 Replies

Harrys69
Newbie

Same problem for me.

 

Ubuntu 14.04

Spotify 0.9.10.17

alfuente
Newbie

Hi:

  I'm using ubuntu 14.04 and with the last update of spotify client I get this error during the "apt-get update" command:

 

Reading package lists... Error!
E: Encountered a section with no Package: header
E: Problem with MergeList /var/lib/apt/lists/repository.spotify.com_dists_stable_non-free_i18n_Translation-en%5fUS
E: The package lists or status file could not be parsed or opened.

 

  I haven't got problems with the previous version.

  Best regards

 

            Alejandro Fuentes

f_b
Roadie

I seem to have the same problem..

Running xubuntu 14.04.

Torpedo_Smash
Newbie

Idem

tigeli
Newbie

Seems like the spotify's repo is broken...

Morwald
Newbie

I'm having the same problem. I also keep getting "internal error" pop-up notifications from ubuntu with the same error message.

 

I tried removing Merge List and then running apt-get update, but I have the same problem.

 

The little red circle in the top right corner says to run Package Manager to see what is wrong and that this is usually due to unmet dependencies, but I tried clean, autoclean, check and -f install to fix the dependencies, but nothing changed.

pelm
Music Fan

Having same problem (Ubuntu 14.04), but i used:

 

sudo rm /var/lib/apt/lists/* -vf
sudo apt-get update

 

Tried again with Spotify installed, the same, then i removed it, and ran the same commands, then it is ok again. Something is wrong.

f_b
Roadie

@pelm wrote:

Having same problem (Ubuntu 14.04), but i used:

 

sudo rm /var/lib/apt/lists/* -vf
sudo apt-get update

 

Tried again with Spotify installed, the same, then i removed it, and ran the same commands, then it is ok again. Something is wrong.


Is that all you did? I tried to do the same as you, but I still get the same error. (And, of course, now I don't have 0.9.10 anymore either)

plinne
Newbie

It's not working for me either. I'm running xubuntu 14.04 (32 bit).

 

I get this error after "sudo apt-get update":

 

E: Encountered a section with no Package: header
E: Problem with MergeList /var/lib/apt/lists/repository.spotify.com_dists_stable_non-free_i18n_Translation-da%5fDK
E: Pakkelisterne eller statusfilen kunne ikke tolkes eller åbnes.

What could be wrong?

hormosapiens
Newbie

+1 its not working. I get this on kubuntu 14.04

 

I get this on terminal:

W: Failed to fetch gzip:/var/lib/apt/lists/partial/repository.spotify.com_dists_stable_non-free_binary-amd64_Packages Hash Sum mismatch

E: Some index files failed to download. They have been ignored, or old ones used instead.

 

and then:

sudo apt-get install -f
Reading package lists... Error!
E: Encountered a section with no Package: header
E: Problem with MergeList /var/lib/apt/lists/repository.spotify.com_dists_stable_non-free_i18n_Translation-en
E: The package lists or status file could not be parsed or opened.

 

Spotify version: 0.9.10.17.g4129e1c9 (works ok)

Kubuntu 14.04 latest softaware updated.

Solution!

rannyakuza
Casual Listener

Hmm, this seems to be because of an erronuous http/dns redirect. As a workaround, place the following in /etc/apt/sources.list.d/spotify.list:

 

deb http://repository-origin.spotify.com stable non-free


This URL does not have the spotify-redirect-to-our-homepage-because-i-dont-know-why-argh redirect rule, therefore apt-get will work. After Spotify fixes this, you should be able to change the apt-get URL above back to its default (ie. without -origin in the URL).

View solution in original post

sebfoy
Newbie

I am on 14.04.1 LTS and spotify for desktop crashes a lot. It's a bit sad for I find more music on spotify than on Deezer ( yes I'm french) and I would have liked to subscribe on Spotify family it it was reliable on my ubuntu...

I describe the issue : spotify opens. I choose my music. It works. Cool. Wait a minute ou more or, more efficient, move your mouse and click a button. The music keeps going on but that's all. Nothing else. I have to make a hard reboot. A solution ?

regards


@rannyakuza wrote:

Hmm, this seems to be because of an erronuous http/dns redirect. As a workaround, place the following in /etc/apt/sources.list.d/spotify.list:

 

deb http://repository-origin.spotify.com stable non-free


This URL does not have the spotify-redirect-to-our-homepage-because-i-dont-know-why-argh redirect rule, therefore apt-get will work. After Spotify fixes this, you should be able to change the apt-get URL above back to its default (ie. without -origin in the URL).


 

jooon
Spotify
Spotify

@sebfoy wrote:

I am on 14.04.1 LTS and spotify for desktop crashes a lot. It's a bit sad for I find more music on spotify than on Deezer ( yes I'm french) and I would have liked to subscribe on Spotify family it it was reliable on my ubuntu...

I describe the issue : spotify opens. I choose my music. It works. Cool. Wait a minute ou more or, more efficient, move your mouse and click a button. The music keeps going on but that's all. Nothing else. I have to make a hard reboot. A solution ? 


Spotify hanging like that was a common problem with version 0.9.x. Have you tried installing the latest version? 1.0.38

 

https://www.spotify.com/download/linux/

 

daddybell
Casual Listener
Nailed the blank screen issue for me - thanks.

wincus
Newbie

@rannyakuza   Worked for me! Thanks!!

balcuta
Regular

@rannyakuza, placing "deb http://repository-origin.spotify.com stable non-free"  in /etc/apt/sources.list.d/spotify.list  worked for me, one million thanks!! 😄

 


Best regards!!

jram0421
Music Fan
The deb http://repository.spotify.com stable non-free repo is working again. No need to use the other one.

teemu_leisti
Newbie

@jram0421 wrote:
The deb http://repository.spotify.com stable non-free repo is working again. No need to use the other one.

It wasn't working for me about half an hour ago. I had to use the repository http://repository-origin.spotify.com, as advised by rannyakuza's answer.

laptaper
Regular

I'm glad this is fixed, but as a loyal, paying customer I'm still furious at the fact that I was up all night dealing with this issue, worried that with my ability to update hampered by this error my computers were at risk.  Why does something so simple have to be so @#%!ing difficult??  I'm grateful for the solution, but it's something that never should have been broken in the first place.  I am really FED UP with companies acting as if the money of their Linux customers is somehow worth less than that of Windows or Mac users.  We pay the same, we should be TREATED the same!!!!!

laptaper
Regular

What I mean by that last sentence is that Spotify should stop expecting their programmers to work on Linux solutions for free in their spare time and instead start PAYING them to fully support Linux.

Eadword
Regular

One thing to note though: there is a web client; the very fact that they are making a Linux client is supprising considering the 5% of computers running it, and that is from w3 so it is likely to be skewed towards Linux because of the devs. And I am very thankful that they have made it. The efforts like theirs make Linux more appealing to the people debating if they want to switch.

SUGGESTED POSTS