Announcements

Stuck in Full Screen

Solved!

Stuck in Full Screen

Hello,

 

A while ago, Spotify decided that it should be in Full-Screen (taskbar not visible anymore) and I cannot figure out how to undo this. I tried F11 and Alt-Enter, but nothing seems to work.

 

Can anyone help me with this annoyance please? Thank you very much in advance.

 

Anna

Reply

Accepted Solutions
Marked as solution

Install wmctrl if you don't have it.

 

Then pause the music and run "wmctrl -r spotify -b toggle,fullscreen" while spotify is running.

View solution in original post

Marked as solution

In my case, wmctrl solved. However, you have to give it the name of the window you want to toggle fullscreen. You can see the name of the screen by using:

 

wmctrl -l

In my case, it listed Spotify as "Lynyrd Skynyrd - Freebird". Then I did:

 

wmctrl -r "Lynyrd Skynyrd - Freebird" -b toggle,fullscreen

And it solved it.

 

 

View solution in original post

34 Replies

I am sorry for the inconvenience, it has fixed itself allready.

 

 

Screen Shot 2012-09-30 at 4.05.02 PM.png

 

I had to do View -> Full Screen (see above screen shot).

 

Hi, I'm stuck in full screen also.  I use Windows 7.  When I click on the 'View' dropdown as mentioned above, I don't even have a 'full screen' option on the list.  I've never had this problem before, and it seems to have started about a week ago.  Any suggestions?  Thanks!  

This happens on MAC OS Lion continually. The software is a bit buggy and this version of MAC OS is particularly frustrating.

 

Only useful tip I have found is to press Cmd + Shift + F to toggle in and out of full screen mode. Note that this is different and more controllable than pressing F11 to toggle full screen mode. 

Did you ever find out how to get out of Full Screen mode? I see the user that suggested hot keys to get in and out for Mac, but what about Windows 7??

There are some arcane key combinations for this and I think you can assign your own in Win 7 but it's so much easier to double-click the top of the application screen 🙂

Well, I was fiddling around with the mouse, and when you take the mouse to the top of the monitor, the Spotify drop down menu pops up.  Select View, then Full Screen.  Works like a charm.

 

(I am running Mac OS 10.8.5.)

In my PC with Windows 7 this Full Screen Option es absent. I have other PC with the same situation. I have the last black version but not works. In the Web Player this is not a problem, but in the PC version not works.

The dropdown view menu doesn't include "full screen" any more but are you saying you're missing the usual maximize window button in the top right? Any chance of a screen capture to show this?

I had the same problem, tried everything, even logging in again didn't work. But there is a fix!

 

My problem was that the buttons where all just outside of screen-space. This means that if you click and hold on the space next to the drop-down menu's, and drag your mouse, spotify will move with your mouse.

 

Aka -- You are not in full screen mode! You simply cant see the buttons anymore because you eather switched displays, changed resolution, or made a mistake by making it too large. Dragging spotify to the left, and resizing the screen will fix this.

 

Hope this helps,

 

- Sjoerd

 

 

I'm running into an issure on RHEL 7.1 where after upgrading to spotify-client-1.0.17.75.g8f111100-2.el7.x86_64, it launches in full screen mode and I haven't found a way to get out.  My quick fix is to launch spotify with the '--minimized' option: /usr/bin/spotify --minimized &

Marked as solution

Install wmctrl if you don't have it.

 

Then pause the music and run "wmctrl -r spotify -b toggle,fullscreen" while spotify is running.

Thanks man!
This solution worked on Antergos with Gnome

CentOS7 here, happened to me also after I changed my big monitor with a smaller one.
The config files are in $HOME/.config/spotify
I deleted that folder and the application started with its window decorations as expected.

thanks, it works for me in ubuntu gnome !

lol. in my case, the spotify wasn't called "spotify" because the window title is by the name of the song ( list all windows using wmctrl -l ). so in my case i had to run wmctrl -r "Immolation - Passion Kill" -b toggle,fullscreen. Thany you very much 😄

GOD BLESS YOU! Exactly what I need right here! I rarely use mac. Stupid arrows are there to make it full-screen and then disappear to exit.

Did NOT work under Mint Mate 64 bit 17.3

Suggested posts