Stuck in Full Screen

Solved!

Stuck in Full Screen

Ignotus

Hello,

 

A while ago, Spotify decided that it should be in Full-Screen (taskbar not visible anymore) and I cannot figure out how to undo this. I tried F11 and Alt-Enter, but nothing seems to work.

 

Can anyone help me with this annoyance please? Thank you very much in advance.

 

Anna

Reply
34 Replies

xxx30

ubuntu 16.04:

ALT + F11

MikeH2

Linux Mint 17.3, this does not work. Spotify is in full screen and refuses to switch to windowed mode.

MikeH2

Sorry, this did not work either. I clicked and dragged all around the border. Still full screen. I -CAN- use Alt-Tab to change to other windows, read mail and surf while Spotify is playing in the backgroud. But I can do these things correctly in windowed mode by using Treacle and Pandora.

MikeH2

/usr/bin/spotify --minimized &

 

I tried the above. Got a string of errors about GPU and then it launched full screen once more. Phooey!

MikeH2

No. Music playing or music paused, neither do any good.

jooon

@MikeH2 wrote:

Linux Mint 17.3, this does not work. Spotify is in full screen and refuses to switch to windowed mode.


I could not work around this issue with Alt-F11 either in Unity or Gnome on my Ubuntu installation. In Unity on Ubuntu you can hold alt and grab the window with the mouse and drag it make it windowed again. In Gnome this does not work for me.

 

I treat this as a bug in the Spotify client and it is tracked in our bug tracker and will be fixed eventually.

 

The only workaround that I know that always work is removing the window prefs and restarting the client.

 

rm $HOME/.config/spotify/window_position.prefs 

 

burneykb

Worked on Mint w/ Cinnamon 3.0.7. Thank you so much!

fholst

I got a situation were my Spotify window was invisible due to a size of 1x1 (width and height). The music was playing and I did not know how to stop that. I noticed the window title was changing with each song using:
wmctrl -l

 

So I could do something like: wmctrl -r Sting -e 0,45,62,800,800

Restoring to a window 800x800 nearly top left on my screen. Obviously a song by Sting was playing.

andrealmeid

In fact, you just need to delete window_position.prefs, doing

rm ~/.config/spotify/window_position.prefs

on Linux and restarting the aplication.

Marked as solution

douglasrizzo

In my case, wmctrl solved. However, you have to give it the name of the window you want to toggle fullscreen. You can see the name of the screen by using:

 

wmctrl -l

In my case, it listed Spotify as "Lynyrd Skynyrd - Freebird". Then I did:

 

wmctrl -r "Lynyrd Skynyrd - Freebird" -b toggle,fullscreen

And it solved it.

 

 

sonance207

This worked for me with Antergos/Arch:

 

Make your pref files look like this and restart spotify.

 

pref location:  /home/john/.config/spotify/prefs

 

storage.last-location="/home/john/.cache/spotify/Storage"
#app.window.position.height=768
#app.autostart-configured=true
#app.window.position.saved=true
#app.autostart-mode=""
#app.window.position.width=1366

ultramelon

Under Solus Linux (and probably other Linux distros) you can edit Spotify prefs:

 gedit ~/.config/spotify/prefs

end alter width/height entries to smaller values:

app.window.position.height=800
app.window.position.width=600

The issue appears when I set the desktop resolution to smaller (or equal) to values in Spotify settings. Real software development bummer, to be honest.

 

maty_in

This works, thanks mate!

brianzammit

This worked for me.. Thanks a lot! 🙂

DarrelAlex

Linux 18.3 hit Windows Key, Main Menu comes up select any APP, taskbar comes up. Right click to close Soptify without logging out , or carry on using ALT/TAB.

Suggested posts