How to stop the app Automatically Open on Mac desktop

Solved!
Reply

How to stop the app Automatically Open on Mac desktop

am41077
Casual Listener

Hi, I selected "Don't open automatically" on the setting. However, whenever I start up the desktop, the Spotify app still open automatically, how can I stop it?????

 

In addition, I already restart Spotify manytimes for upgraded version, the message still keep popping out, what can I do?

 

I've highlighted both problem marked in red arrow!

 

I am using OS X Yosemite 10.10.2

Spotify.png
1 ACCEPTED SOLUTION

Accepted Solutions
Solution!

Re: How to stop the app Automatically Open on Mac desktop

MattSuda
Community Legend

Go to login items in the Mac settings and see if Spotify is there. If so remove it. 

 

http://www.maclife.com/article/howtos/how_remove_startup_items_os_x

 

System Preferences > Users & Groups. Once there, click your username, and then click on the Login Items tab.


Here, you can see all of the items that you've selected to launch at startup. To remove an item, select it in the list, and then click on the minus (-) button.

View solution in original post

13 Replies
Solution!

Re: How to stop the app Automatically Open on Mac desktop

MattSuda
Community Legend

Go to login items in the Mac settings and see if Spotify is there. If so remove it. 

 

http://www.maclife.com/article/howtos/how_remove_startup_items_os_x

 

System Preferences > Users & Groups. Once there, click your username, and then click on the Login Items tab.


Here, you can see all of the items that you've selected to launch at startup. To remove an item, select it in the list, and then click on the minus (-) button.

View solution in original post

Re: How to stop the app Automatically Open on Mac desktop

am41077
Casual Listener
Thank you so much MattSuda, the problem is solved, you're a genius :D

Re: How to stop the app Automatically Open on Mac desktop

MattSuda
Community Legend

You're welcome =)

Re: How to stop the app Automatically Open on Mac desktop

amatrade
Newbie

Same problem here. The "preference way" didn't solve it at all. After deleting Spotify from startup items and starting/closing the App – whop! the startup item is back!

 

In addition: After disabling the automatic start in Spotify's prefs I logged out and quitted Spotify. The system prefs were showing no "Spotify" entry (which was new!). Woohoo! – But next time starting Spotify and loggin in the Spotify prefs showed "Minimal" again … 

 

What a bother!

Re: How to stop the app Automatically Open on Mac desktop

hnschneider
Newbie

if you dont want to do all that, you can easily pop up this menu and click options and then unlick "open at login" 

Screen Shot 2015-08-03 at 4.03.22 PM.png

Re: How to stop the app Automatically Open on Mac desktop

kesabeth
Newbie

I'm having the same issue with Windows 10 - pretty rude in my opinion,

Re: How to stop the app Automatically Open on Mac desktop

Louphenou
Newbie

Thanks Matt. Irksome little problem solved in an instant. Has prompted me to purge other unnecessary items from Users and Groups.

Re: How to stop the app Automatically Open on Mac desktop

JacobPintle
Casual Listener

Thaaaaanks! I had several days trying to find this! Thanks :)

Re: How to stop the app Automatically Open on Mac desktop

Bieeel9
Newbie

Thank you very much! :)

SUGGESTED POSTS