Mac desktop app bluetooth speaker volume lowering automatically

Solved!
Reply

Mac desktop app bluetooth speaker volume lowering automatically

broadbeanprop
Casual Listener

When playing music in the Spotify Desktop app for Mac over my bluetooth speakers (Argon Alto 4 Active) the volume of my speakers are lowering automatically.

This happens randomly in the middle of a song and keeps happening every X (feels like 10 or 15 but haven't timed it) minutes.

The system volume and Spotify app volume will stay full, the app is actually lowering the volume of the speakers themselves which is pretty strange (I bought the speakers recently and was about to return them until I had the idea to test some other apps).

I already tried disabling the normalize volume setting, but this doesn't help.

This issue doesn't occur in any other apps, and also not in the Spotify Web Player.

Also doesn't occur when using a cable.

 

Plan

Premium

 

Device

Macbook Pro (Retina, 13-inch, Mid 2014)

 

Operating System

macOS High Sierra, 10.13.6

 

Spotify Version

1.0.88.353.g15c26ea1, but I also had this in previous versions.

 

2 ACCEPTED SOLUTIONS

Accepted Solutions
Solution!

merlijnv2000
Composer

Hi! I hope you're doing fine!

 

Have you tried deleting Spotify completely and reinstalling? You should delete Spotify first, then restart your computer and download and install it again.
It's often overlooked. Please let me know if this worked!

 

Have a nice day!

View solution in original post

Solution!

broadbeanprop
Casual Listener

Hi!

I'm using a Mac, so I don't have an appdata folder.

Tonight I'll look around in the ~/Library and /Library folders to see if I can find some more Spotify related folders.

 

Edit: I reïnstalled by also removing the ~/Library/Application Support/Spotify folder and it's been playing music without dropping the volume for about an hour now!

View solution in original post

5 Replies
Solution!

merlijnv2000
Composer

Hi! I hope you're doing fine!

 

Have you tried deleting Spotify completely and reinstalling? You should delete Spotify first, then restart your computer and download and install it again.
It's often overlooked. Please let me know if this worked!

 

Have a nice day!

View solution in original post

broadbeanprop
Casual Listener

Hi!

I am, hope you are too!

Thanks for your answer, I have tried reïnstalling, this didn't work.

I didn't however try it with also removing the caches, so I just did. However, with the caches removed Spotify is still automatically logged in after the reïnstall, is there something more I need to delete to remove everything?

merlijnv2000
Composer

Hi! 

I found this solution, I hope it helps!

 

Windows 7:

 

Click the start button, type "%appdata%" into it without the quotation marks.

Delete the folder marked spotify

 

If it says that spotify is open, then right click spotify on the taskbar and click quit spotify.

Solution!

broadbeanprop
Casual Listener

Hi!

I'm using a Mac, so I don't have an appdata folder.

Tonight I'll look around in the ~/Library and /Library folders to see if I can find some more Spotify related folders.

 

Edit: I reïnstalled by also removing the ~/Library/Application Support/Spotify folder and it's been playing music without dropping the volume for about an hour now!

View solution in original post

twowaystairs
Newbie

This was happening for me too, only from my MacBook and only when connected to Bluetooth. I found that disabling the "Normalize Volume" option in the settings seems to have helped but not fully solved it.

SUGGESTED POSTS