Announcements

Help Wizard

Step 1

NEXT STEP

Spotify showing wrong song lengths of some local files

Spotify showing wrong song lengths of some local files

Device

Macbook Pro mid-2012

Operating System

macOS Catalina 10.15 - 10.15.4

 

My Question or Issue

This has been an issue for months now. For some reason Spotify shows some local files length's as 1 second shorter than they really are. And for some local files it shows 0:01 instead of the actual length.

This might sound like a pseudo problem but since I have my mp3's in two different computers (mac and Windows 10) it creates a problem. I've created album playlists from those local files in order to sync them onto my mobile device. The problem is that since the issue only happens with the Spotify macOS client the songs that are in a playlist and have a wrong length are unplayable in the Spotify Windows client. And if I then replace those unplayable songs in a playlist in the Spotify Windows client then they become unplayable in Spotify macOS client.

The files themselves are fine because Finder shows correct length for those files and they have correct length in Music app.

Let me add screenshots with some of the songs:

Metallica in SpotifyMetallica in SpotifyMetallica in Finder infoMetallica in Finder infoDre in SpotifyDre in SpotifyDre in Finder infoDre in Finder infoGoldie in SpotifyGoldie in SpotifyGoldie in Finder infoGoldie in Finder infoJoe in SpotifyJoe in SpotifyJoe in Finder infoJoe in Finder info

 

I've done clean installation of Spotify. Currently using 1.1.29.584.ge16e8692.

Reply
20 Replies

So I recently got a Macbook and I wanted to transfer all of my songs from my windows pc to my new laptop. For the most part I had no issues, but for some reason, a few local files don't work because Spotify changed the length of the local file on my Mac to be one second shorter than that same exact file on my PC. Because of this, I'm not able to play those few tracks on my Mac because of the different track time, but I'm not sure how to fix this because the files are exactly the same. I have pictures below to further explain:

 

Here's how the local file looks on my PC. The track length is correct and the file plays normally. 

 

Here's how that track looks in the same playlist on my Mac. I can't listen to the file even though i have it downloaded. 

 

This is the file of the song on my Mac in my local files folder on Spotify. Same exact track, but for some reason It's a second shorter and I can't play it on my playlist. 

 

This is the files metadata on my Mac. The runtime matches the runtime on my PC, so I know it's not an issue with the file. For some reason Spotify is shortening the track by one second. This is one of a few local files that have this same issue and I'm not sure how to fix it. I've tried deleting Spotify, as well as the cache, but I still can't play the file. I've also tried deleting and redownloading the file to my Mac, as well as my PC. If anybody knows how to fix this problem please let me know.

Did you ever find a fix for this?

Nope and it’s still not fixed. 

I had this problem aswell, but i found the Fix,

 

You need to download "GoldWave", after you installed it, just place you'r File into the Editor, and save it, now it should show the correct time, it worked for me.

Got to try this. Any difference between GoldWave and and Audacity? I remember I tried Audacity and it didn't do anything.

Audacity wont work from what I know, I usually finish my songs with a Vegas Pro 15 Render, so i dont know

I am having same issue in 2021.

 

Can't believe it is still not fixed in 2021. I have same issues, some random files decide to be 1s shorter on MAC and also have some issues with encoding in album or artist metadata having ; (windows) and / (mac os 11).

 

I tried saving with Audacity, doesn't help. Didn't try Goldwave but from what I can see it is not free and why would you need to do that? It is a bug in Spotify on MAC! Android is fine.

 

Hi folks,

 

Sorry for the late reply, we just came across this thread. 

 

First off, let us know if you've already tried performing a clean reinstall of the app. This is often an overlooked step, but it’s more thorough than a regular one and can be helpful to get rid of any cache that might be causing trouble. 

 

It's also a good idea to change the source of the local files. Simply create a new folder in a different directory on your device and move your local files to this folder. Then just delete the old folder used for the local files. Now you can try importing the files again. 

 

Keep us posted!

JulianModerator
 
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 

Hi Julian,

 

Thank you for reply.

 

Yes I had done clean reinstall and cleared cache. That doesn't help because the problem is how Spotify parses the file and it is only apparent on Spotify. VLC or any other player on Windows or Mac report correct metadata.

Files work both on Windows 10 and on Mac OS 11 but it gets greyed out due to minor difference. It could be either metadata having / instead of ; OR 1 second difference. 

 

The entire point of this is to use something like Dropbox to store files and then add the location on 2 computers as Local Files.  Moving files out didn't do anything.

 

I have attached 3 files:

1. Shows metadata ; and / issue

2. Shows times issue (JP chars)

3. Shows times issue (EN chars)

 

It is from Windows perspective. From Mac perspective it is opposite one is greyed one and playable. I have added both files from same location from Dropbox.

 

The thing is that this happens very often and randomly for no apparent reason. So I am ending up adding same file twice in order to play it on different machine.

 

1.png
2.png
3.png

Goldwave is Free, there is a paid Version, but the Free Version is enough for the Fix

Thanks for info.

I tried and it sorta worked on some files but didn't work for 1 even though it no longer had / instead of ;

It is still tampering with original files so which I don't like and you shouldn't need to do that.

Thanks anyway.

Hey @XEnderFaceX, thanks for jumping in here.

@martybalandis we're glad to know that the suggestion above worked for some of the songs, but we're aware this isn't ideal.

On another note, keep in mind that local files can only be played from the device that the files are actually stored in. Even though you have the same files on a Dropbox  folder, they need to be inside the device's storage and can only be played from the app on that desktop device. This is why when you see the local files from your Windows device, some of the songs are greyed out, but when you see those local files from your Mac, the opposite songs are greyed out (even though they're the same songs, the source files are stored on different devices).

It's not possible to sync the same local files between 2 desktop devices, but you can sync them between a desktop computer and a mobile device (if you have Premium). You can find more info on how to do it here

We hope this clarifies some of the things, but we'll be here if you still have questions.

JulianModerator
 
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 

This is not the reason it is grayed out. I assure you the files are stored locally on both devices and it identical file and just some are not working properly. Same files can be played on the local files: Your library -> local files on both machines but the value in the playlist differs between Windows and Mac.

Hey @martybalandis,

 

Thanks for the reply.

 

We cannot guarantee proper playback of files that are not part of our library. So the best thing to do is tweak the metadata and formatting of the files.

 

What you can try is to get the audio file from a different vendor and ensure there's no DRM, or if it's an originally created track, to try and convert the master audio with different encoding settings, use the OGG Vorbis codec and format for example.

 

Hope this helps.

 

 

AlexModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

You can't change the length/duration of the track by "tweaking" metadata.

Simply changing the source of the local files worked for me. In case anyone was wondering, my duration was way off for almost 80% of the songs I uploaded to local files. Which were stored in the music folder, so to fix this I followed Julian's advice and temporarily switched the source of the local files to a different place and back. It ended up working after that and the duration of the time was correct. Also, this was also what was preventing me from downloading these songs on my mobile device. Only the songs with incorrect durations were unable to download, while the 5/15 songs that showed the correct duration actually downloaded. Thanks Julian.

Hey @MAXcartier,

 

Thank you for your reply in this thread

We're glad to hear that everything works as it should for you.

We've checked your profile and it looks like you're new to the Community. Have you checked out our Music exchange section? You may find song recommendations there!

If you like, you can go ahead and introduce yourself here in this thread as well.


Take care! 

LyubkaModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.

i have found the solution from this forum lemme break it down. yes you have too plug the mp3 files into a different audio program like audacity too resave and unglitch them. this actually doesnt work on audacity so i found someone reccomend goldwave in this very forum and it worked great but hen it asked me tooo buy a lisence so i backed out. then after some searching i found a program named ocenaudio and it works even better then gold wave and is completely free all you have too do is open the glitched mp3 file then go too save as annd change the name too whate r u want i just add a 1 too the end then go back on spotify and put it into a folder. the duration should b fine and it should not b greyed out on your phone sorry for spelling mistakes idc

Solution: Edit the music file and trim it down to a whole number length (in seconds)

I had this problem with one local track. On my Windows 11 PC, the length was 3:01 while on my Android 14 phone; the length was 3:00. I used an audio file editor to check the file's exact length, and it was 3:09876. So, the PC rounds up while the Phone rounds down. A Mac and other platforms might handle this issue separately. It has to choose between 3:00 or 3:01. So, this is a platform issue, e.g. Windows, Mac, Android, iOS, etc. Usually, most music files are edited to whole number seconds to avoid this, but not everyone follows best practices.

 

I solved the issue by editing the file down to 3:00 exactly and the issue went away. I think this is the best way to go. Use any preferred audio file editor that has timeline and export features.

Suggested posts