Help Wizard

Step 1



Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...


Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...


"Browse" page "Doesn't Exist"

"Browse" page "Doesn't Exist"



iMac 27in late 2013 macOS 10.14


I'm so tired of all this nonsense. I'm constantly having to mess with things to get my desktop app to work... excruciatingly slow loading times. Have to manually delete cache files so frequently, turned hardware acceleration off, disable local files... turn wifi on and off, blah blah blah.
Anyways this has been happening all day today no matter how many times I quit and restart Spotify. Every other section works fine, it's not my internet connection. I am tired.


Screen Shot 2018-11-06 at 5.26.46 PM.png


16 Replies

I'm getting the same thing


I am facing with same problem! So annoying! 

Screen Shot 2018-11-07 at 13.57.07.png

I'm also experiencing the same issue! 

Same here. Tried to reinstall, but it doesn't work.

Same problem here mate, out of nowhere

Still happening today. Okay Spotify, what is going on?

Hi all!


It seems that this issue is already being investigated. Check out this ongoing issue thread. To help +VOTE and post a comment with the required info.


Hope it will be fixed soon 🙂

Guys. What's happening here? I know we're all fed up with our "Browse" page being empty, but a larger problem has come out of this: the background image for the empty "Browse" page.

Dude looks uncomfortable. Like...REALLY uncomfortable. I mean, don't get me wrong. I love the feeling of grip tape on the back of my head as much as the next fellow, but this is just unacceptable. And is this guy just napping it off while there are other skaters doin' their thing right next to him? We got a **bleep** over here. This boy's about to catch a deck to the temple. I would've accepted a picture of a ham sandwich before this.

In conclusion:
10/10 for inconvenience
0/8 for background image selection


I did the whole uninstall, clear cache, reinstall thing and it worked for a little while but then it went back to the "Browse page doesn't exist" message. Not gonna waste anymore time going throught the trouble to fix this again since the recommended solutions are only temporary anyways. So if anybody was considering doing the uninstall/reinstall, don't bother. It's not worth the trouble.

Having the same issue. Reinstall does not fix it.

I solved... It is so funny 🙂

I switch to offline mode then online again. And Voila! it works

Great, that worked for me too!

I switch to offline mode then online again. And Voila! it works

Thanks, it's worked for me too!

great, I am glad to hear that 🙂

Hi all!


The issue should be fixed by now 🙂

Suggested posts