Announcements

Audio popping and cracking. Reinstalledm, updated drivers, disabled hdwr accel, nothing.

Solved!

Audio popping and cracking. Reinstalledm, updated drivers, disabled hdwr accel, nothing.

I'm running the Windows 10 desktop audio app and I've been having audio pops and cracks at random intervals in all the music I listen to (It's not clipping or part of the song). It happens more often when my computer is doing a high intensity task like livestreaming or gaming, though it persists even if Spotify is the only app open. However, Audio is perfectly fine if I run the web app. I've done a lot of research into this and nothing so far has fixed this.

 

Things I've done to try and fix this:

  • Cleared spotify cache
  • Disabled Spotify's High quality streaming
  • Disabled Spotify's hardware acceleration
  • Changed the sample rate/bit depth in playback devices
  • Tried different audio jacks
  • Tried different headphones
  • Updated my audio drivers
  • Updated and clean installed all of my drivers
  • Reinstalled spotify (Deleted every file remotely tied to spotify and reinstalled)

If you have any other suggestions for me to try, I'd love to hear them. This has been driving me crazy for a while now.

Reply

Accepted Solutions
Marked as solution

I think I found the fix, though it's not in the form I'd like. Uninstalling EqualizerAPO has fixed all cases of audio popping (And everything is a few decibals louder now which is nice too). If you know of a good EQ program that doesn't interfere with sound quality/adds popping please do let me know? 😛

View solution in original post

4 Replies

Hey @Avera9eJoe

 

The first thing that comes up for me is latency-related lags / dropouts.

 

However, at first I'd recommend trying out the Windows Store app. Maybe this one will work normally.

 

You can also try disabling sound effects provided by the audio driver:

1. Go to Taskbar, find and click on the speaker icon. Click the speaker/device icon again on the volume slider popup.

2. Go to Sound Enhancement tab and disable them.

3. If there are additional tabs like Dolby or similar, try disabling these too.

and the Communications setting:

1. Find the speaker icon on Taskbar again. Right-click on it and select Sounds.

2. In the opened window go to COmmunications and set Windows to do nothing.

 

Some antivirus software with active http scanning can cause this issue as well. Windows Defender is not known for doing this, but some third-party software may cause issues by scanning the audio stream among other stuff.

 

If the issue persists,  please try playing Youtube videos as well as local library with Windows Media Player or other players you have installed, and report back if the clicks still happen. 🙂

SebastySpotify Star
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.
Marked as solution

I think I found the fix, though it's not in the form I'd like. Uninstalling EqualizerAPO has fixed all cases of audio popping (And everything is a few decibals louder now which is nice too). If you know of a good EQ program that doesn't interfere with sound quality/adds popping please do let me know? 😛

@Avera9eJoe

 

It's nice you found the cause! 🙂

 

I haven't used any sound enhancers at my end, except for what came with the Asus soundcard, and it died recently.

I use studio headphones with Focusrite now and all I'm getting is this sort of flat detailed response and 2 volume knobs.

 

However, this article may be useful for you - link here.

And if you care, you can get a dedicated customer-grade soundcard which will likely come with some pretty decent sound control tools (i recommend reading reviews!). The Sonic Studio by Asus was fun (virtual surround is real good with this one), useful and didn't cause any issues.

 

There's a Spotify-specific equalizer called Equalify, but it's a paid program and works only for the standard (not Windows Store) Spotify installation.

 

Hope this helps!

SebastySpotify Star
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.

I pass this along also... Check out cables in your sound system. I have to use a digital optical cable output from TV to Zvox sound system. Those optical cables fit loosely and age. Try wiggling it, and replace it with something that's expensive if that works.

Suggested posts