Help Wizard

Step 1


Can't Play the Current Track

Can't Play the Current Track





Operating System

Windows 10


My Question or Issue

Woke up this morning after using Spotify on my desktop app successfully all day yesterday. Now I can't play any songs without getting a message "Spotify can't play the current track. If you have the track in your local files, you can import it."


Things I have tried unsuccessfully:

- Uninstalling and reinstalling the app.

- Turning off Hardware Acceleration.

- Updating my sound drivers.

- Clearing the cache

- Restarting computer

- Updating operating system


Note: when I look for the Spotify folder under Roaming in %appdata%, there is literally no Spotify folder. I have no idea where it installed too.


I am running the most recent version of Spotify and most up-to-date Windows 10 as of the time of this posting.


The Web Player on the desktop in question works, and using Spotify on another device works fine.

1 Reply

Loads of people are having this, go take a look at my post with the rather long list of things I tried.

Running as admin works for me, but I'd rather a 3rd party app didn't have admin rights on my PC if it can be helped.  There have been other methods to get it to work but admin rights seems to help most people.

Suggested posts