Help Wizard

Step 1

NEXT STEP

Can't play spotify from desktop client

Can't play spotify from desktop client

I am using a laptop with Windows and since few days back I can't play music (with/without headset) from the desktop client.

It works in the webplayer.

I have restarted the client, logged in/out, uninstall/install again without success.

Reply
11 Replies

Hi @aryhann,


Thank you for reaching out to the Community.

 

Can you confirm that you followed the steps that's provided in this article? There's some more steps to help thoroughly uninstall the app from your phone so if you haven't, we'd highly suggest it since the steps will make sure there's no old cache files causing this.

 

If that doesn't do the trick, we suggest that you remove all lines from your hosts file by following the steps bellow:

  1. Open Notepad as an administrator (right-click - Open as Administrator)
  2. go to File - Open and navigate to C:\Windows\System32\drivers\etc
  3. Choose "All Files" instead of "Text Documents" next to the File Name box. You'll see a handful of files. Pick hosts and click on Open
  4. When the file is open, you will see a block of text with # in front of each line and might see entries like 0.0.0.0 website.com127.0.0.1 website2.com
  5. Check for any entries with Spotify in the address. Examples may look like: 0.0.0.0 weblb-wg.gslb.spotify.com0.0.0.0
  6. If you do find any lines with Spotify, please remove them
  7. Save your changes and restart Spotify

Let us know how it goes.


Take care 🙂

JeremyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Live, love, laugh and listen to music 🙂

I have the same problem - hosts file is empty - no spotify entries

Hey @VFRBoy,

Thanks for posting on this topic and welcome to the Community!

We understand your hosts file doesn't contain any lines for Spotify, so this doesn't help in your case. Have you tried other steps from the above proposed troubleshooting already? If not, then it's a good idea to try and reset the client two times in a row, this is a bit odd, but it can resolve possible cache-related issues. If this doesn't help, then we suggest you to try making a clean reinstall of the app, as this is more thorough than the normal one and ensures that no cached data will cause interference with the new installation of your app. 

 

If nothing of the above helps, then please share some more details such as the exact number of your Spotify desktop client version, and also the OS and version of your desktop device. Also a short video recording of the situation could really help us to advise you better.
 

Hope you find this useful. We'll be keeping an eye out for your reply, thanks!

Kiril Moderator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Hi, 

 

My hosts file is empty as well.

Still, after a clean reinstall of the desktop client, the client is still not able to play music (while the webplayer works just fine, on the same computer).

This is the version installed.

aryhann_0-1638182986182.png

 

I am using a Windows 10 machine.

My suspect is that it is not routing the audio to the right device for some reason. How can one check the device settings?

 

Hey @aryhann,

 

Thanks for the post.

 

You can check out which audio device your system is defaulting to and check your audio quality settings.

 

Right click the Sound icon > Sounds > Select your playback device > Properties > Advanced > Set audio quality rate to 44.1kHz (then click Apply), and raising it to a higher value after. 

 

Let us knwo if that helps.

AlexModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Hi, 

 

sadly that didn't help at all. 

The webplayer works as any other software I have on my laptop. The client still doesn't play nor with any of my headset, neither with the laptop speakers.

Hey @aryhann,

 

Thanks for your reply.

 

Can you let us know your laptop's Windows version along with the exact Spotify version you're running?

 

Additionally, can you double check in the computer sound panel if the Spotify app isn't muted?

 

We'll be on the lookout.

CarlosEModerator
 
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 

Hi, 

 

I am using Windows 10.

I posted the spotify version earlier. Was it incorrect?

 

Please, explain to me on how I should check if spotify is muted in the sound panel. I don't find that.

Thanks.

Hi @aryhann,

 

Thanks for your reply.

 

My bad, I didn't see it. 

 

You can open the Volume mixer by right clicking on the volume icon in the lower right corner of the Windows taskbar and clicking on open Volume mixer. There you'll see a dedicated volume bar for Spotify - make sure that it isn't muted or the volume is too low.

 

Keep us posted.

CarlosEModerator
 
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 

Hi!

 

Thank you - it was *that* the problem.

All is working fine now!

Thanks a lot.

Regards

Arianna

Hey @aryhann,

 

Thanks for letting us know that everything is working fine now. Don't hesitate to give us a shout if you have more questions.

 

Have a great day!

MafeGModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Suggested posts