(Desktop/Windows) Won't play sound on Airpods

Solved!
Reply
Highlighted

(Desktop/Windows) Won't play sound on Airpods

Inverted_Fire
Casual Listener

So I recently got a used pair of 1st gen Airpods and they've worked on my phone perfectly (iPhone SE) but when I'm using my Windows laptop (ASUS Zenbook) and connect them to my laptop through Bluetooth, Spotify won't play through the Airpods. The sound will instead be played by the speaker of the laptop. This isn't the case however when I play any other audio from another application like Chrome and Netflix. I've also made sure that when connecting my Airpods it says "Connected voice, music" and that when I click on the sound icon it says above "Headphones (Airpods Stereo)" as the output for the sound. Is there anything I'm missing or a setting that doesn't allow the desktop app of Spotify to play through Bluetooth?

3 ACCEPTED SOLUTIONS

Accepted Solutions
Solution!

Re: (Desktop/Windows) Won't play sound on Airpods

user-removed
Not applicable
Howdy!

Can you try using the Spotify web player (https://open.spotify.com)?

Or try to update the Spotify application (https://spotify.com/download)?

Hope one resolves the issue. :)

View solution in original post

Solution!

Re: (Desktop/Windows) Won't play sound on Airpods

Rock Star 16
Rock Star 16

Hey @Inverted_Fire 

 

When you check the Playback Devices (right-click on speaker icon for selecting that), does it say "default device" on your Airpods?

If not, try setting them as Default and if still not working, restart Spotify.

 

Another thing you can try is checking if Spotify is muted under Windows sound mixer (right-click on speaker icon again, select volume mixer). You can also try checking if muting and unmuting Spotify and then restarting the client will change anything.

 

Let me know how things go! :)

SebastyRock Star 16
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.

View solution in original post

Solution!

Re: (Desktop/Windows) Won't play sound on Airpods

Inverted_Fire
Casual Listener
When I looked at the playback devices my Airpods were listed there but were not set as default (which I don't know how to do). Along with this, the Spotify application didn't even show up in the Windows Sound Mixer. So I went digging into the sound settings and found an option at the bottom of the screen that said "Advanced Sound Options" and below it "App volume and device preferences". When I clicked on "App volume and device preferences" I found that I could set the device which each application outputted sound to and was able to set my Airpods to be the output manually whereas before it just said default. Interestingly, I see that Chrome's output is also default but since it does play sound through Chrome I believe that the Spotify application might not be able to detect my Airpods as the default.

View solution in original post

4 Replies
Solution!

Re: (Desktop/Windows) Won't play sound on Airpods

user-removed
Not applicable
Howdy!

Can you try using the Spotify web player (https://open.spotify.com)?

Or try to update the Spotify application (https://spotify.com/download)?

Hope one resolves the issue. :)

View solution in original post

Solution!

Re: (Desktop/Windows) Won't play sound on Airpods

Rock Star 16
Rock Star 16

Hey @Inverted_Fire 

 

When you check the Playback Devices (right-click on speaker icon for selecting that), does it say "default device" on your Airpods?

If not, try setting them as Default and if still not working, restart Spotify.

 

Another thing you can try is checking if Spotify is muted under Windows sound mixer (right-click on speaker icon again, select volume mixer). You can also try checking if muting and unmuting Spotify and then restarting the client will change anything.

 

Let me know how things go! :)

SebastyRock Star 16
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.

View solution in original post

Re: (Desktop/Windows) Won't play sound on Airpods

Inverted_Fire
Casual Listener
I tried both of the solutions that you proposed and the web player works but the application itself doesn't. Thanks!
Solution!

Re: (Desktop/Windows) Won't play sound on Airpods

Inverted_Fire
Casual Listener
When I looked at the playback devices my Airpods were listed there but were not set as default (which I don't know how to do). Along with this, the Spotify application didn't even show up in the Windows Sound Mixer. So I went digging into the sound settings and found an option at the bottom of the screen that said "Advanced Sound Options" and below it "App volume and device preferences". When I clicked on "App volume and device preferences" I found that I could set the device which each application outputted sound to and was able to set my Airpods to be the output manually whereas before it just said default. Interestingly, I see that Chrome's output is also default but since it does play sound through Chrome I believe that the Spotify application might not be able to detect my Airpods as the default.

View solution in original post

SUGGESTED POSTS