Announcements
We're aware that some of you are currently experiencing issues with redeeming your gift cards! We'll keep you posted here.

Help Wizard

Step 1

NEXT STEP

FAQs

Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...

VIEW ALL

Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...

VIEW ALL

Local files

Solved!

Local files

Country

Germany

Device

PC

Operating System

Windows 10, 2004

 

My Question or Issue

I have a large amount of mp3 files on my hard drive (> 90k) and have unticked the option to include/show them in Spotify.

However, everytime I'm searching for an artist, it easily takes up to 30 seconds until the results show up. In the meantime I can hear my harddrive rotating, I can see a reading access in the task manager and the app is using large chunks of CPU.

 

So, despite the option not to list local files (which Spotify doesn't), it still searches, indexes or looks through my hard drive.

 

Please update your desktop player to truly respect the decision concerning local files or give a workaround on how to prevent this behaviour. Waiting 30 seconds (not exaggerating) for your search results is barely acceptable, tbh. Let alone that the app got no business on my hard drive outside of its installation folder.

 

Kind regards

pakz

Reply

Accepted Solutions
Marked as solution

Hey folks,

 

Thanks for reaching out with this one.

 

If you're experiencing slow search results and the option Show Local Files is disabled, you can try the following:

  1. Enable Show Local Files
  2. Untick all Sources that appear bellow
  3. Disable Show Local Files

If the issue persists, it might be the case that some of the apps files have gotten corrupted. In such cases a clean reinstall usually rectifies the situation. 

 

@ShiftedPhase your issue seems to be a bit different. Note that for the import of local files to function properly, they have to be present as files in the system. This could explain why the downloads start automatically. 

 

Hope you find this useful. Keep us posted how you get on.

Mihail Moderator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

View solution in original post

5 Replies

Same problem here!

Same here.

Having the same issue.

I keep my music files (>60GB) in OneDrive (with the Music files only in the cloud by default).  Whenever it tries to scan for local music files, it ends up trying to download all of those files to the local drive.

Marked as solution

Hey folks,

 

Thanks for reaching out with this one.

 

If you're experiencing slow search results and the option Show Local Files is disabled, you can try the following:

  1. Enable Show Local Files
  2. Untick all Sources that appear bellow
  3. Disable Show Local Files

If the issue persists, it might be the case that some of the apps files have gotten corrupted. In such cases a clean reinstall usually rectifies the situation. 

 

@ShiftedPhase your issue seems to be a bit different. Note that for the import of local files to function properly, they have to be present as files in the system. This could explain why the downloads start automatically. 

 

Hope you find this useful. Keep us posted how you get on.

Mihail Moderator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Yep, the fact that it starts downloading the files is expected behavior - I just didn't want it to scan those folders at all.

 

Your steps to Enable Show Local Files, untick all sources and Disable seems to have worked for me - thanks!

Suggested posts