Announcements

Help Wizard

Step 1

NEXT STEP

Not Playing Through External Device (Windows 10) 'Spotify can't play this right now'

Solved!

Not Playing Through External Device (Windows 10) 'Spotify can't play this right now'

Plan

Premium

Country

United Kingdom

Device

HP Elitebook

Operating System

Windows 10

 

My Question or Issue

When I try to play any track through my external Soundcard/speakers I get the message: 'Spotify can't play this right now.If you have the file on your computer you can import it.'

 

It plays through my laptop speakers fine. If I change the speakers to external while it's playing, it plays through the left speaker only for a few seconds and then Spotify crashes.

 

When the speakers are set to external, Spotify usually disappears from the Volume Mixer. When it doesn't disappear no sound appears in the volume bar even though volume is on max and mute is not selected.

 

I've looked for this problem across Spotify community...

I have disabled hardware acceleration

I have deleted local-files.bnk from the appdata folder

I have changed the app to run in Windows 7 compatibility mode

I have checked the volume mixer (see above)

 

Any other suggestions???

Reply

Accepted Solutions
Marked as solution

Thank you. Weirdly Spotify doesn't always appear in  'App Volume And Device Preferences' with this problem.

 

I downloaded the soundcard desktop application so I could look at DSP mode settings, and installing the app actually fixed the problem for me, so I guess perhaps there was a problem with the driver or something. A bit odd because Spotify was the only app with a problem, but there we go!

View solution in original post

2 Replies

Hey @charo 

 

The issue might likely be caused by the fact Spotify might have the onboard audio set as its audio output of choice. This can be modified in Windows' settings as follows:

1. Right-click on the speaker icon on your system tray
2. Select 'Open Sound Settings'

3. Scroll down to 'Other Sound Options' to click on 'App Volume And Device Preferences'.

That's it! Here you can choose what output Spotify should use. Windows will remember these settings.

 

It also sounds rather similar to this issue some users (mostly using Asus Xonar cards) are having. One possible method is to disable DSP mode within the soundcard settings, another is resetting sound settings as guided by this user.

 

Let me know how it goes 🙂

Marked as solution

Thank you. Weirdly Spotify doesn't always appear in  'App Volume And Device Preferences' with this problem.

 

I downloaded the soundcard desktop application so I could look at DSP mode settings, and installing the app actually fixed the problem for me, so I guess perhaps there was a problem with the driver or something. A bit odd because Spotify was the only app with a problem, but there we go!

Suggested posts