Announcements

Help Wizard

Step 1

NEXT STEP

Spotify Desktop App not redirecting on login, error code desktop_login_accounts:3

Solved!

Spotify Desktop App not redirecting on login, error code desktop_login_accounts:3

Plan

Free

Country

Pakistan

Device

HP Laptop

Operating System

Windows 10

 

My Question or Issue

So the desktop app just updated and im logged out of my account. As soon as I press log in, the error code pops up AND THEN im redirected to my browser. The login is successful there, but when I click the Open Spotify App button, it fails to redirect and Im redirected to this local ip that doesn't load. I'm using the desktop app downloaded from their website, I've also tried doing a clean reinstall 3 times. Order of screenshots is 2,3,1. Please Help

Screenshot (71).png
Screenshot (69).png
Screenshot (70).png
Reply

Accepted Solutions
Marked as solution

I was stuck on exactly the same issue as you for AGES. I tried the support system and everything but nothing worked UNTIL I tried disabling my wallpaper engine/rain meter. From the looks of it you also have quite a fancy wallpaper background and maybe are also using the same software. Try disabling them and let me know if it works. All the best!

View solution in original post

11 Replies

Order of screenshots is 2,3,1

I have the same issue but it's not redirecting to anything, it just stays on the open Spotify page...

!POSSIBLE SOLUTION! Try refreshing cookies, or try using a different browser or even a different computer if you can. Had the same issue on Firefox, tried using Chrome and it worked, was able to get back into my Spotify account.

I'm using chrome, tried to use firefox, still the same issue

Hi there folks, 

 

Thanks for posting in the Community and welcome.


@DestructiveLogic, thanks for sharing the steps that worked for you! @Musab-Shah, first go to this link and if you're logged in, log out. Then try to access your account from the app again. Additionally, could you try using a different Internet connection? If you don't have any available, you could create a hotspot network from your mobile device and use it to check.

 

On another note, are you perhaps using a VPN? Take into account that using one can affect the performance of the app. So in case you are, we’d suggest turning it off and checking if that makes any difference.

Lastly, let us know if you're able to log into your account from other devices.

 

Keep us posted!

Susan_GPModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a "Like".
Are you new to the Community? Take a moment to introduce yourself!

I tried a sepereate connection, im not using a vpn, but the issue still exists. Also I can easily log in on my android phone.

 

Hi @Musab-Shah,

 

Thanks for your reply and for trying out our recommendations. 

 

In this case, you could try resetting your password. Before trying to log in again, go here and make sure to log out from there. That way, you'll need to re-enter your credentials. If that doesn't help, try to log in again, but using your username (not your email) and the new password. 

 

If the issue persists, we recommend adding Spotify as an exclusion to Windows Security. You'll find the steps to do it on the Microsoft Support page.

 

Lastly, are you able to open the Web Player?

 

Keep us posted!

Susan_GPModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a "Like".
Are you new to the Community? Take a moment to introduce yourself!
Marked as solution

I was stuck on exactly the same issue as you for AGES. I tried the support system and everything but nothing worked UNTIL I tried disabling my wallpaper engine/rain meter. From the looks of it you also have quite a fancy wallpaper background and maybe are also using the same software. Try disabling them and let me know if it works. All the best!

Hi @Susan_GP,

Resetting my password did nothing. Im easily able to log in on the website but the app still says the same. I added thr exclusion to windows security too, and that didn't work. Also the web player works fine

I don't use wallpaper engine, however disabling rainmeter fixed the issue! Thanks Alot!

Hey there folks,

Thanks for your replies in this thread!

@KaiLikesCode  thanks for sharing the info on how you resolved the situation. And @Musab-Shah , we're glad to know everything seems to be working now, and thanks for trying out all the steps we suggested. 

If you have any questions or need anything else, the Community is here for you.

Susan_GPModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a "Like".
Are you new to the Community? Take a moment to introduce yourself!

Suggested posts