Help Wizard

Step 1



Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...


Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...


Spotify Offline

Spotify Offline






(Google Pixel 3a)


My Question or Issue

I am unable to play Spotify when Im not connected to the wifi.


Im on a paid plan, and I've checked offline isn't ticked in settings.

I've cleared the cache, turned my phone on and off, uninstalled and reinstalled the app and still nothing works. 


I've seen a few topics on this already, but with no definitive answer on how to fix it. Has anyone else had this issue? Are there any trouble shooting things Im missing?


Thank you!


3 Replies

Hey @holmesco


Thanks for posting your questions here in the Community and welcome.

Just to confirm, it'd be helpful to quickly double-check with your provider that you have enough data available to run the app.


It'd also be very helpful to make sure the 'data-saver' mode is not currently enabled on your Google Pixel device, since this might prevent Spotify to run unless being on WiFi. To do so:


  1. Open your phone's Settings app.
  2. Tap Network & internet > Data usage Data saver.
  3. Turn Data saver of if it's currently on.

Furthermore, some apps and services won’t work as expected with the device you're trying to access Spotify with unless you let them run in the background even when you’re not using them. To let apps run in the background using mobile data, you can turn on data saver mode. To do so:


  1. Open your phone's Settings app.
  2. Tap Network & internet > Data usage > Data saver Unrestricted data.
  3. Turn on the app or service you'd like to use mobile data while in data saver mode.

Hope you'll find this info useful. We'll be keeping an eye on your reply and get back to you if we can help any further!

Mario Moderator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Hi Mario - thanks for that. I've got a 30gig data cap for my plan, and definitely have data saver turned off. However, the background data setting is the most interesting point there - I wouldn't be surprised if this is the winning solution. Spotify wasn't enabled, so I've switched it on. Only time will tell if this works though, so I'll test it out as much as I can and get back to you.

Thanks for your help!

Hey @holmesco,


We just wanted to check in with you and see if you were able to resolve this with the help of @Mario.


If not, let us know and we'll see what we can suggest next.


Thanks - keep us posted!

Suggested posts