Announcements

Spotify Skipping every song, not playing for more than a second

Solved!

Spotify Skipping every song, not playing for more than a second

I just installed Spotify onto my brand new lenovo laptop and copied my backup from my old laptop over. These problems started immediately after I copied my backup over so I think it has to do with that as I previously had spotify installed on my old laptop. I went and reinstalled spotify completely, running CCleaner after uninstallation, then reinstalling it and it still won't play any songs. Just skips every song and no matter what it is. I went and deleted spotifys storage folder and cache folder manually then restarted spotify, still didn't work. Unchecked all of the checkboxes in preferences including hardware acceleration and it still won't work.

 

Any help would be appreciated otherwise I'll have to cancel my premium subscription before it renews this month

 

Running Windows 10 home edition

Reply
42 Replies

Wish I had a fix. Tidal works seamlessly

Resetting my audio device worked - you are a legend!

Hi

I'm on Windows 8 and am having the same issue: Every single song brings up the 'This track is not available.' Message

I've tried changing my playback audio settings and everything in there is as it should be.

Please help.

Regards,

Mark

 

 

worked for me, thanks!

aaaand today it's working normally again.
Oh well.

Omigosh! It worked! Thanks so much!!!


@ThePonti wrote:

Hello!
Please try changing your default playback device to your computer's speakers (http://www.7tutorials.com/how-change-default-playback-recording-audio-device) restart Spotify and try it again.
Tell me if it worked, please. You can give me a kudo too if you want 😉





What I did is specified No Proxy. I'm at home so there isn't any proxy anyway. Worked immediately for me.

Thank you so much! I've been looking for a while for a solution. I'm glad someone referred me to this post!

 

Much Love,

 

Mx

Also happens on Android devices. Bose Bluetooth headphones support multiple concurrent connections so they drop from the device that's not talking to them. Consequently at the end of an album, the headphones drop and Spotofy app stops working. Restarting Spotify and reconnecting headphones fixes it, but I would expect that Spotofy should revert to default output device - i.e. my tablet's speaker.

i changed the playback device to my speakers and it still dosent work

My spotify keeps skipping every single song and it's really annoying. It says 'this song is not available. If you have the file on your computer you can import it'

I have windows 8 on a hp laptop

I have tried restarting my laptop and logged in and out of my spotify.

I recently had premium and I removed my subscription after having it for a few months.

I have never incurred this problem before. I have also tried changing my default playback device but it didnt work. Does anyone have any other solutions?

For me it doesn't work either. I only have headphones, no speakers. Plugged them at the front and back, no sound. On Spotify Webplayer I have sound, but I don't like the interface.

Did not F*ing work. Tried everything on here. **bleep**?????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! POS software.

Marked as solution

If solution above does not work for you try this solution first close spotify, find the control panel>admin tools>services>Windows Audio Endpoint Builder (near the bottom of the list) Restart the service, check spotify. This solution is primarily for people want play music through the audio jack and and any default speakers on like a laptop. Step by step picture instructions will be uploadedFinding Control PanelFinding Control PanelFinding Admin ToolsFinding Admin ToolsTo ServicesTo ServicesTo Windows Audio Endpoint Builder then resettingTo Windows Audio Endpoint Builder then resetting

2 Spot Fix.JPG
3 Spot Fix.JPG

Ignore the last to imgs

THIS WORKS **bleep** THANK YOU SO MUCH!!!!!

I found that my issue was related to my NVIDIA graphics card. I use a creative soundcard to handle my PC audio (Win7) and it seemed to be conflicting with the NVIDIA HDMI audio. I just disabled the HDMI audio facility in the NVIDIA control panel as I never use it and it solved the problem. Good luck peeps!

Hiya...this sort of worked for me. What I had to do was change the plug in ports I was using for my headset. Odd as it sounds,that was the solution. Thank you!!

THIS FIXED IT FOR ME

 

THANK YOU 

Thank you so much, it was annoying me but that fixed it without a problem. Also the pictures were a huge help too!

Suggested posts