Announcements

Help Wizard

Step 1

NEXT STEP

Spotify can't find my Onkyo Reciever via Spotify Connect anymore.

Spotify can't find my Onkyo Reciever via Spotify Connect anymore.

Since i've built a new PC and installed Windows 11 on it freshly Spotify Connect only sees my Google Chromecast Ultra. But not my preferred Onkyo Multimedia Reciever. I've tried reinstalling Spotify. My Android phone doesn't have this issue where i use the App and can normally see my Onkyo Multimedia Reciever as Spotify Connect device.
Reply
3 Replies

Little addition to my problem: I also discovered that when opening the app on my phone. Spotify connect doesn't synchronise my current playing track. See attached screenshots from my computer and phone simultaneously. I'm certain that I'm logged into the same account, otherwise my playlists wouldn't be there.

It seems that the Windows 11 app doesn't properly or partially detect Spotify Connect devices. 

image.png
Screenshot_20230116_142536_Spotify.jpg

Okay, I figured out one step towards the solution. It has something to do with my VPN. I use Nord VPN. I need to exclude Spotify from the VPN connection. Having done that I can see I detect my Onkyo Stereo Reciever again. However, when I try to connect to it keeps grey and loading. Only when I disable my entire VPN it works again. I've already excluded the three executables in the installation folder. However, it's still not working.

Hey @XcelentTom,


Thanks for reaching out about this in the Community.

 

We can confirm that VPNs can cause issues such as the one you had experienced. They can mask the real IP address and device that is being used to access your account. Usually a VPN also switches between multiple IPs from different locations.

 

A lot of sites and services will either block known VPN IPs or can be a reason to trigger security protocols based on location and device access. In other words, using a VPN can make the security system think that your account is being accessed by multiple unknown locations.

 

Spotify does not currently block VPN usage, but we also do not support it and we can't guarantee that the service would work as expected when using one.

 

Hope this clear things up,

 

Cheers! 

LyubkaModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.

Suggested posts