Help Wizard

Step 1



Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...


Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...


Spotify connection status depends on Windows connection state

Spotify connection status depends on Windows connection state


Premium (Family)




Custom Build PC

Operating System

Windows 10 Pro (2004)


My Question or Issue

I figured out, that spotify says it's offline even when I have internet connection. I first thought it is a problem with the store app. So I uninstalled it and installed via the Windows Installer.

But the problem still occurs.

I figured out, that spotify detects the windows connection state of my network interface and is "playing dead" when windows says "no internet connection".

But I HAVE internet connection. Windows tells otherwise, because I disabled some microsoft telemetry services which seems to be used to detect the connection status.

Shouldn't spotify use it's own connection status?

I have working DHCP, DNS and internet... So please spotify: use it!



Spotify version:

5 Replies

I also uninstalled and reinstalled the app.

AppData was clear.

After reinstall I had to login again which works perfectly. But then it says I'm offline and nothing will be displayed...

How can I help to fix this issue? tcpdump, ...?

Hey @koechr,


Thanks for searching for the answer you need here!     


We hope you don’t mind us replying now as we just stumbled upon this thread. We appreciate the reinstall you've done so far, but could you do it once more using the steps in this guide? They are more thorough and make sure that no leftover files that might be causing this behavior remain.


If that doesn't fix things, its a good idea to try and resolve the issue using the instructions here. They're for an article on a slightly different topic, but they're quite relevant also here.


Hope you find this useful. Keep us posted how you get on.

Mihail Moderator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Hey @Mihail,

I tried this procedure before but I tried again (Windows 10):

Step 1 - 9: clear, so far so good. No leftovers found in steps 8 & 9

Step 10: Also no leftovers in:


C:\Program Files

C:\Program Files (x86)


Step 11: done

Step 12: Cant install from MS store because this stup!d OS thinks it is offline... I downloaded the "oldschool" application and reinstalled it.

Step 13: Login using Spotify account -> Logged in saying it is offline again... But WebPlayer in Firefox (on the same device is working!) and the application showing spotify connect (see screenshot attached)


Result: nothing changed...



@Mihail wrote:

If that doesn't fix things, its a good idea to try and resolve the issue using the instructions here. They're for an article on a slightly different topic, but they're quite relevant also here.

Well, I tried Safe mode with network -> same result

Ad-blocker apps -> Nothing installed

No changes to windows host file

I'm on a personal device


I would say that I'm a professional IT guy. So please let me know if I can help you by sending some wireshark snippets or tcpdumps. Is there any special address or port I have to check on my firewall?




Well I started with wireshark. Maybe that will help you:
1. I deleted local DNS cache "ipconfig /flushdns"
2. Started wireshark
3. started spotify application

The following infos I got from a few packets:
The app is trying to connect to the following hosts: (which will be translated to A record (translated to CNAME which has an A record
After resolving the hostnames a connection to both on port 443/TCP is established.
The connection is used to get/send some application data over via TLSv1.3 and TLSv1.2

After trying to click here and there in the application it also tries to connect to (which is translated to CNAME which as an A record Also communicating via 443/TCP (TLSv1.3)

So as I can see the connection is working and the app doesn't want to use it?

Hi, did you resolve the issue?
I have the exact same problem, I allso has the telemetry services disabled.
If i try to play a song, i get "This content is not available", but no problems on web player og android phone.

Edit: Found solution here: 

Suggested posts