Announcements

Help Wizard

Step 1

NEXT STEP

FAQs

Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...

VIEW ALL

Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...

VIEW ALL

Spotify keeps connecting to other devices

Spotify keeps connecting to other devices

Plan

Premium Family 

Country

United States

Device

experienced on IOS and Windows.

Operating System

IOS 1.10-∞ and windows everything.

 

My Question or Issue

When I try to play songs on one of my devices while another device connected to my wifi is playing, it switches and plays my song on that device. If I change what device the song plays on, the song changes to the one I selected, plays on my device, then goes back to the previously playing device a few seconds later, still playing the newly selected song. This issue has persisted through multiple online forms and FAQ's, and I'd appreciate some help on the matter.

Reply
17 Replies

Hey @BigFeeet,

 

Thank you for reaching out to the Community and welcome.

 

When someone is playing music on a Bluetooth device using your same WiFi network, the system will usually ask you if you want to join or play music over that speaker as part of a new “group session feature”.

In order to avoid this behavior, you’ll need to disable the Speaker session on that bluetooth device. You'll find the steps to do it in this article.

 

Hope this helps. If you have any additional questions, don't hesitate to ask. 

OscarDCModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

How do I keep my Roku's and other devices from showing up in my Spotify app? This is extremely annoying as I only use 1 tablet for dedicated music streaming. 

Hey @drexellake,


Is this recent behaviour or has it always been like this?

Are the other devices only showing up as playback options, are you getting prompts to connect to them or are they taking over the playback as described in the initial post?
Let us know & we'll take a look at how we can assist you here 🙂
Many thanks!

VasilModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

It's always been like this.  There needs to be a way to ignore other devices that I'll never use like Roku sticks. And we need a default device option so we don't have to select a device every time we open Spotify. I would love it if I could only add the device I want to use without it auto connecting to everything in my house. 

Hey @drexellake,

 

Thanks for your reply and for the info shared.

 

We can confirm that currently this is not possible. We think this is a great idea too! Another user had a similar request, so they posted this idea about it.  

 

Even though the status is set as Case Closed, it doesn't mean the idea has been rejected. We’d suggest adding your vote in the thumbs up icon and subscribing to the idea to get notified as soon as we have any updates to share.
 

We hope you found this helpful. We're always here to help.

AlejaRModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.

My Spotify keeps changing to playing on another device when I’m driving down the road.  It’s connected to my car’s blue tooth and jumps to another device, someone’s desktop or iPad that I don’t recognize. In doing so it changes to that person’s playlist.  How do I stop this from happening.  This occurs about 6 to 8 times a day.  I’m about ready to cancel my membership 

Hey @Marktaylor,

 

Thanks for reaching out.

 

If you're experiencing this behavior, we'd suggest securing your account using these steps.

 

Let us know if this helps.

MihailYModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

I have deleted devices from my account, both in the app and on the desktop, MULTIPLE times, and they keep popping up. These devices are NOT connected to my wifi, but were once connected to my account. How can I stop this from happening?

Hey @Nefertyty05,

 

Thanks for posting in the Community.

In this case, you can enable "Show only local devices" in the app's settings.

We hope this helps. Let us know if you have other questions.

MihailYModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

This doesn't help. Even when I select Forget Device it pops up again and
will stop playing in my car and connect to one of those. How do I remove
these from my account?

Hey @Nefertyty05

 

Thanks for getting back in touch. 

 

Just to confirm, are you experiencing this issue? If so, please make sure to leave your info in the comments there. 

 

If the issue you're experiencing is different, could you let us know if it started happening after a specific event such as an update?

 

We'll be on the lookout.

EniModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 
“Music acts like a magic key, to which the most tightly closed heart opens.”– Maria von Trapp

No, that's not the issue. The issue is, my Spotify was once connected to
other devices. I no longer live where those devices were, connected to that
wifi or anything. For maybe 6 months now. But for some reason it keeps
connecting to them after I hit "forget device". So when I get in my car and
start playing. It'll stop playing in my car and connect to one of those
devices

Hey @Nefertyty05,

 

Are the devices you mention smart speakers (Amazon Echo Dot, Sonos etc.)? If yes, and you've connected your account to them, you'll need to unlink it in the app that was used to set them up.

 

If not, please let us know the type of device so we can investigate further.

 

Keep us posted.

MihailYModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Yes they are, but not an account I have access too.

Hey @Nefertyty05

 

Thanks for getting back to us. 

 

In this case, we suggest that you head over to your Account page and click on Remove access on the devices (Alexa, Sonos) you don't want to connect anymore. 

 

Let us know how it goes.

EniModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 
“Music acts like a magic key, to which the most tightly closed heart opens.”– Maria von Trapp

Hi,

 

im having similar issues where if I use my AirPods, then Spotify connects to my Sonos speakers automatically every 15 min or so and the music is paused. This is true even if I am not at home and have access to the Sonos speakers.  

How can I stop the auto-connect without removing Sonos access, since I do want to use Spotify to play on my Sonos when I’m at home?

It's always been like this, and it still is today.  I just got to the point where its fixed today or I'm cancelling my sub.  This is crazy. I see Roku Sticks, Roku soundbar, TV's, other phones, etc.  This should not be happening.  I should be the one selecting what devices are available in the app from my account. Many times I'll be trying to play a device in one room and hear music blasting on the other side of the house.  Nuts! 

Suggested posts