Announcements

Help Wizard

Step 1

NEXT STEP

FAQs

Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...

VIEW ALL

Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...

VIEW ALL

Spotify won't play through wireless headphones

Solved!

Spotify won't play through wireless headphones

Plan

Premium

Country

Australia

Device

PC 

Operating System

Windows 10

 

My Question or Issue

 

Hi guys, recently got a pair of Sony WH-1000XM3 for my birthday.

 

Tried to connect them to my PC to listen to music however my PC didn't have bluetooth, so I went out and bought an adapter.

 

Came home connected them up all good. Youtube plays through them on my PC and I can hear the windows sounds. However nothing when in spotify. I tried looking at the mixer and thats not muted.

 

Did turn on my speakers and they were playing through there. I've looked through my sound settings and have even tried setting the default output of spotify to my headphones but nothing works.

 

Any help would be appreciated.

 

 

 

 

 

Reply

Accepted Solutions
Marked as solution

I'm sorry my earlier post seems to have been altered.

 

Go to  <Control Panel> <Sound> and ensure that your headphones sound device is set to default. It should have next to it a green circle containing a white tick .

 

Whilst in there, check to see if there is a sound device called Speakers/headphones. If so, disable it as this will divert sound output to speakers.

 

Hope this works for you.

 

View solution in original post

Marked as solution

Other Solution:

  • Go to Settings
    • Bluetooth & other devices
      • Go to related setting and click on "Sound settings".
      • Look for Advanced sound options: Click on "App volume and device preferences".
        • Here you will find default for several apps. If you have the Spotify application, the default output can be adjusted here. Set the appropriate output so you can hear it on speaker or Bluetooth headphones. 

View solution in original post

Marked as solution

Try disabling "Headset". Then after it works, re-enable "Headset". Mine started switching for Spotify, Skype, videos, etc. automatically and working as expected.

View solution in original post

34 Replies

I have the identical position with these headphones. Somebody must be able to listen to Spotify with them. Please share your solution.

I have the same problem with JBL Tune500BT headphones. Spotify plays fine via speakers, but nothing on the headphones. Everything else is playing fine, just not Spotify. 

 

Switched BT off/on, headphones off/on, restart Spotify, restart PC, nothing helps. It just doesn't work, Spotify needs to look at this. Is this perhaps related to HDCP ?

 

I'm running latest version (1.1.10.540.gfcf0430f) on Win10. This is a Lenovo laptop with embedded BT via Intel chipset.

 

I solved my problem eventually by going to:

  and disabling Speakers/headphones.

I hope this works for you.

Alan Hodges

I cant seem to use my sony wf 1000xm3 to play spotify through my laptop as well. My laptop model is acer swift 3.

I have the same headphones on a Lenovo laptop

these headphones worked for months until suddenly today they aren't working with Spotify. Spotify needs to fix this. I've deleted and redownloaded Spotify, turned Bluetooth on and off, unpaired and unpaired my headphones and restarted my laptop and unpaired/paired

Marked as solution

I'm sorry my earlier post seems to have been altered.

 

Go to  <Control Panel> <Sound> and ensure that your headphones sound device is set to default. It should have next to it a green circle containing a white tick .

 

Whilst in there, check to see if there is a sound device called Speakers/headphones. If so, disable it as this will divert sound output to speakers.

 

Hope this works for you.

 

Thanks, but that's not it. I'm an IT guy, and this is clear: no matter what
you do, some BT headphones will not work with spotify. Everything is set
correctly - BT sound works for any other application including Windows
sounds, just not with Spotify.

There are hundreds of posts about this issue scattered on this support site
and around the web, but Spotify apparently can't be bothered.

Yes this works very well for me thankyou Alan!

Marked as solution

Other Solution:

  • Go to Settings
    • Bluetooth & other devices
      • Go to related setting and click on "Sound settings".
      • Look for Advanced sound options: Click on "App volume and device preferences".
        • Here you will find default for several apps. If you have the Spotify application, the default output can be adjusted here. Set the appropriate output so you can hear it on speaker or Bluetooth headphones. 

I hope the message reaches you well.

 

I figured it out, took 2 weeks, but i did it.  

 

Alan had us almost there, but my case was more unique.

 

For me, my headphones were working perfectly until one day they decided they would work for literally everything on my laptop except Spotify. Here's how I fixed it:

 

Go to Control panel > search for "Adjust System Volume" > click "Adjust System Volume" > make sure the volume for Spotify is turned the same level as your device (refer to attached screenshot).

 

I used to work in IT and after trying every trick i knew (updated sound settings, updated drivers, updated OS, restored OS, forget/reconnect device, update bluetooth drivers/BIOS settings, update network settings) this finally did it for me. 

 

Hopefully you've already fixed your problem, otherwise, I hope this helps!

spotify 1.png

Please go to the Settings --> Home --> sound settings --> Advanced Sound options --> App volume and device prefrences. Under those settings set Spotify to use default, my settings were set to inbuilt speaker and rest of the apps were on default. Once I change spotify to default the sound started playing in my bluetooth headphones.

 

Hope this helps!

 

nehadevil3__0-1587343500762.png

 

I solved my issue by going into the recording section of the sound control panel and disabling the headset WH-1000xm3 hands-free AG audio.

Best solution. Thanks

@guerrero_dan 

This worked for me.
For Spotify, the input/output was set to Default and the volume was at 100 but the volume icon showed the speaker was muted. Had to adjust the slider to "unmute" the icon.

Same. I'm using Skullcandy Crusher Wireless headphones. I disabled my microphone device associated with the headphones. Disabled "Crusher Wireless Hands-Free AG Audio" which seems to be added with any bluetooth device with a mic. I had "Crusher Wireless Stereo" set as default, but spotify seems to favor the mic incorrectly.

Dude, I have the same headphones and the same prob, The Sony wireless 1000XM4. Does anyone know a fix?

Hey everyone,

 

Thanks for reaching out to us 🙂

It's a good idea to give these steps a go. If the issue still persists, you can run a clean reinstall with the steps mentioned here. That way you can make sure the app is up-to-date and the cache is not causing any issues.

 

If that doesn't help, you can try with another device. That way we can see if it's a device-related issue. Does the issue persist?

 

Let us know how it goes. If you have questions, we are here for you.
 

 

 

 

 

Ver Moderator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Have the same issue with my wirless headsets both of them.
One being B&O B9I and the other PS3 Gaming headset.

 

Found a workaround, if I use the spotify online in the webbrowser it works correctly

Hey @jsahib,

 

Thanks for posting and sharing your experience 🙂 

 

Did you give the steps and suggestions mentioned by @Ver a go already? 

 

If your account works correctly in the web-browser form it's likely there's something going on with the app on the device(s) you experienced the issue with.

 

You'll find us here in case. Cheers!

Mario Moderator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Suggested posts