Announcements

Unable to control spotify when connected to my Google speakers

Unable to control spotify when connected to my Google speakers

Charlie_theory

Today when I connected my spotify to my google speaker, I no longer have the ability to control which song is playing. The previous song button is greyed out and whenever I click to play a song it says it can't do it. Works perfectly fine unconnected. I've tried using a family member's account and that works fine when connected to the same speakers. 

 

I've uninstalled the app on my phone and on the computer and reinstalled. I've relinked the accounts on google home several times. Still having the same issue. Had no problems with this last night.

Reply
5 Replies

Alex

Hey @Charlie_theory,

 

Thanks for reaching out about this in the Community!

 

Can you clarify if this is happening both on your phone and the computer? It would also be good to know your device models, OS versions and Spotify versions.

 

Does this happen only when you're connected via Spotify Connect or on Bluetooth as well?

 

The more we know about this issue, the faster we can get to the bottom of it. 

 

Keep us in the loop.

 

 

 

 

 

AlexModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Pokced

Hello,

I would like to tell more details about this issue as I have been investigating it for a while because I can't seem to find the fix.

 

Here is a screen recording video (link to google drive as the file is big).

The sound of the device is on (loud music) and the microphone is on (music that seems far away)

 

- At first I play music on my device, nothing fancy, and I jump on the progress bar so we are not at the beggining of the song (Y.M.C.A.)

- Then I decided to connect my smart device (Google Home Mini)

- When you saw the progress bar disappear, the music picked up at the right progress on my smart device (one minute and a couple seconds into the song)

- Although the music plays on my smart devices, Spotify connect doesn't show my connected device AND the progress bar isn't there

- I then go to the smart device app (Google's "Home" app) and we can see the song currently playing as well as its progress bar

- I try to put the volume up and total crash, both service (Google and Spotify) disconnect from one another

- I start the process again and this time you can hear when the song plays on my smart device (microphone)

- I try to change the song on Spotify but it doesn't work and my smart device still plays Y.M.C.A. (we can see the smart device is still trying to connect on Spotify Connect and no progress bar, as if out of sync)

- I go back to "Home" and see everything is normal

- I go back to Spotify and we can see Spotify Connect is connected, although no progress bar (still out of sync)

- I try changing the song through Spotify again even though I know it seems out of sync... Not working on my smart device

- I go back to "Home" just for proof

- Go back to spotify, bam, not showing the next song but Y.M.C.A. again... (are they synced? There is no progress bar)

- I try again to change the song, no success

- I go in "Home" and try changing the song. It works! Although it is NOT the same song as shown by spotify as the "next one"

- I go back to Spotify, it is blocked on Y.M.C.A.

 

IF I was to let the music play, after the 2nd or 3rd song (which is not the one in the Spotify Queue) the music stops playing but both services stay connected together because when I manually disconnect them on Spotify connect with "this device", my Smart Device tells me: "Sorry, your music stopped playing since your Spotify account is being used on another device"... But it wasn't playong anything.

 

In my opinion, both service are "connected" but do not share info.

 

I also

- Disconnected Spotify from my Google Account

- Uninstalled both "Home" and Spotify

- Reset my Home Mini

- Installed both app again

- Set up my Home Mini through "Home"

- Linked back my accounts

Not working.

- I used a brand new phone (well used but factory reset)

- Took a Home Mini I was being given (give away by a store if I bought for X $). It was brand new, out of the box.

- Set it up ina  totally isolated environment at my parents place (new network)

Nothing will do.

OscarDC

Hey there @Pokced,

 

Thank you for keeping in contact and for the info you shared.

 

We appreciate the troubleshooting you've done so far, but to be sure that we're on the same page - did you use these steps for a clean reinstall of the Spotify app? They are more thorough than a regular one. That way you can make sure the cache is not causing this syncing issue.

 

Also, would you mind checking if it happens connecting your Google speaker to another different phone to see if it makes any difference?

 

We'll be on the lookout for your next response.

OscarDCModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Pokced

I think this issue is linked to another one that can be found on your forum (link) maybe you can look if both are linked by asking the original user if it's linked to a BIG playlist.

OscarDC

Hey @Pokced,

 

Thank you for keeping in contact.

 

The thread you're sharing is currently under investigation and it looks very similar to the issue you're getting. In this case, please add the information requested by @Ver on that thread you sent before. Any updates about it will be posted there.

 

In case you can't find the requested information, here it is again:

  • What device you're casting from as well as the receiving device.

  • The exact Spotify version that is running on the device.

  • How many songs are in the playlist that you're trying to play?

  • Does this happen only with large playlists?

  • If the devices disconnect when you try changing the volume from the casting device.

 

We appreciate the time you’re taking reporting this issue. If anything else comes up, the Community is just a reply away.

OscarDCModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Suggested posts

Env: prod