White Noise on Surface Pro 7 Windows 10 using Spotify desktop app

Reply

White Noise on Surface Pro 7 Windows 10 using Spotify desktop app

leaglealien
Visitor

Plan

Family

Country

USA

 

Device

(Surface Pro 7)

Operating System

(Windows 10.)

 

I'm a satisfied Spotify customer just migrated from a MacBookPro to Surface Pro 7. My only major bug is with Spotify desktop App. Almost every time I use it then after a period of time - anywhere for 10 to 25 minutes - it suddenly starts blasting white noise. Windows is up to date; I've run teh Surface Diagnostics and there are no evident problems.  I'm running the sound out through USB2.0 to a Steinberg 242 interface (which has NEVER had problems on any other hardware; it's high-end). I've done this through a USB hub and also direct and the problem replicates. Searching the community here I see people posting about the exact same problem 3 years ago but not recently. Any one else have the same problem and preferably, a fix?

 

1 Reply

Sebasty
Rock Star 18
Rock Star 18

Hey @leaglealien 

 

Do you get this issue when you're running sound through the internal audio too (speakers, plugging headphones in)?

 

Reinstalling Spotify is a recommended step as it can help getting rid of any in-program errors. 🙂

 

If not, you could check your power options:

1. right-click on battery icon on Taskbar

2. select 'Power Options'

3. click on 'Change plan settings'

4. click on 'Advanced plan settings'

5. in the list, look for USB and disable USB selective suspend.

 

As well as check your interface's ASIO settings. For example I've found that lowest sample rate with maximum buffer size results in bad audio.

 

Is the Steinberg using the newest driver found on their home page?
You can also disable the onboard audio driver you're not using in Device Manager.

 

Let me know how you get on 🙂

SebastyRock Star 18
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.
SUGGESTED POSTS