"Spotify can't play this right now. If you have the file on your computer you can import it."

Solved!
Reply

"Spotify can't play this right now. If you have the file on your computer you can import it."

suicidegrrrl
Casual Listener

Plan

Free

Country

 Canada

Device

Dell laptop c. 2015

Operating System

Windows 10

 

My Question or Issue

 Spotify gives me the error message "Spotify can't play this right now. If you have the file on your computer you can import it." when I try to play any song from a certain album (TeenWitch by BONES). It has happened at least 4 times between opening and closing the app. I have the album downloaded as well and it is imported to spotify. Is this album being censored by spotify? I am allowing explicit songs and have good connection. Everything else works. Let me know if this is the wrongsection/forum.

4 ACCEPTED SOLUTIONS
Solution!

Keanu_C
Rock Star 8
Rock Star 8

Hmmm.... i checked to make sure that songs were available in your region and it is so im not sure whats going on.  However another thing you could try is delete local file cache. To do this go to %appdata% > roaming > Spotify > User > Your Account Name > delete Local-Files.   Also make sure that you are closed out of Spotify before doing this so then when you launch Spotify again it would already be corrected. 

 

Let me know how it goes!
Keanu_C

Keanu_CRock Star 8
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.

View solution in original post

Solution!

Mike_van_esch
Newbie

Okay, so incase that didn't work for you, as it didn't for me, I found another solution.

Open control panel and go to Hardware and Sound>Sound. Click on your default device and open properties>Advanced. Then change the format to something higher or lower. After pressing 'Apply' My Spotify worked again. (After it worked, set your quality to the highest it can go, better audio quality and all)

View solution in original post

Step 2.png
Step 3.png
Step 4.png
Solution!

newbie1966
Casual Listener

I know it doesn't make a lot of sense on the face of things, but try changing your speaker output. (on your system)

View solution in original post

Solution!

LuckasKings
Visitor
If anyone still wondering here, like me, and tried all methods here and none resolved. It was so simple which made me think I'm the dumbest person in the world.

Windows Settings > System > Sound > Advanced Sound Options > App Volume and Device Preferences.

If Spotify isn't showing, try to play anything. If showing in the list, check if the "Output" box is selected with the your Output device you are using (Headset, speakers, TV, etc.). Mine was blank, I switched to my Headset and it solved.

Best regards from Brazil

Lucas L. C. Reis

View solution in original post

173 Replies

Chiguy1
Regular

Ultimate fix is to uninstall Spotify, restart desktop PC, reinstall Spotify, and problem for me was fixed.

adzmusic
Visitor
I just found that deleting the windows store-downloaded version, restarting the computer, and then downloading the version off the Spotify website directly worked! plays music fine now.

Zackfletch00
Music Fan

This issue still happens for me--specifically, it happens when my DAC is set to a very high sample rate, such as 352kHz.  When I go down to 176kHz or lower, the Spotify Windows app works again.

MrGoai
Visitor
Try find and install audio driver on your mainboard website, it worked for me, this problem sloved.

Vct4
Casual Listener
thanks, worked for me to.

DavidITunstall
Casual Listener
Another post on here says to change your Sound device output. This worked for me two times out of three.
Whats going on here, Spotify?
EVRYTHING else I have plays through my default speakers fine. WHat is Spotify trying to do that gives such a weird message

Xenia
Moderator
Moderator

Hey all,

 

Just jumping in here to confirm that our developers are aware of this issue and are looking into it.

 

We'll keep everyone updated in this Ongoing Issue thread, so make sure to subscribe. It's also containing some solutions worth checking.

 

Hope you'll find this info useful. Give us a shout if there's anything else you need help with!

XeniaModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
"Where words fail, music speaks." - Hans Christian Andersen

BenderClark
Visitor

Thanks !  Great tip !

joshbmusic
Regular

For me, I needed to update my audio driver.

Solution!

LuckasKings
Visitor
If anyone still wondering here, like me, and tried all methods here and none resolved. It was so simple which made me think I'm the dumbest person in the world.

Windows Settings > System > Sound > Advanced Sound Options > App Volume and Device Preferences.

If Spotify isn't showing, try to play anything. If showing in the list, check if the "Output" box is selected with the your Output device you are using (Headset, speakers, TV, etc.). Mine was blank, I switched to my Headset and it solved.

Best regards from Brazil

Lucas L. C. Reis

View solution in original post

beki1
Newbie
Thanks,🙏 you're a literal savior! I was trying everything, thinking how can I be so dumb, but you actually helped me.

Wild1
Casual Listener
This has been doing my head in for about a week, somewhere I saw to update or install Java.
I have no idea why this is related to Spotify App but once I updated Spotify worked again fine.

jakegoldsmith
Newbie

I found that the problem was that I didn't have an audio device connected. My computer was not recognising my bluetooth headphones for some reason. Once I connected my wired headphones, the error message went away and Spotify started working again.

samya022
Regular

oh my god.... You are so right.... Issue got fixed when I switch the device as my wireless headphone was out of battery. Thanks 

 

mindbender9
Casual Listener

Hi everyone,

 

Sorry for the long post, but this worked for me.

 

I was also having the dreaded error message or having the app zip through an entire album without playing anything. None of the suggestions worked.

- Deleting the local-files.bnk file in Roaming?   Nope

- Running the Spotify app as Admin?   Nope and this is a huge security issue

- Uninstall/reinstall with either the downloaded Spotify installer from Spotify OR the Windows Store version?  Nope

 

But I found something else. I am running two separate USB DACs on my Win10 PC (excessive, I know). And both have their advanced settings set to the highest bit rate possible. Other music apps and services (e.g. Qobuz) allow me to resample the streams to the DAC's highest levels (one is 24bit/352800Hz and the other is 32bit/192000Hz), but the Spotify app won't play its streams unless I dropped the sample rate to 192000Hz or lower.

 

Solution: The Spotify app would not let me upsample the stream through my DACs unless my Windows Audio settings had its sample rate set to 192000Hz or lower.

 

The bit rate (24bit or 32bit) did not make a difference but changing the sample rate did.

 

If you don't have any external DAC's or fancy soundcards, this probably won't help you. But if you suspect you do, try this to test:

 

Note: Do this at your own risk. I am not liable for anything you do to your equipment or the results that may happen. Use caution if you're not sure what to do - which means don't touch anything.

 

1. Go to Windows Settings (Win10) or >> System >> Sound  (or Control Panel >> Sound)

2. In the "Output" area, you'll see your Output Device set to something in a dropdown box - don't change this. Below that is a link that says "Device properties" - click that.

3. In the "Device properties" section, scroll down until you see a link for "Additional device properties" - click that and another window opens.

4. In this new popup, click on the "Advanced" tab.

5. In the "Default Format" section, *WRITE DOWN THIS SETTING* before changing anything. Take a screenshot of this popup window in case you need to roll back and restore this original setting.

6. In the dropdown box, select a lower value to test with - 24bit/44100Hz (CD quality) would be a safe setting since Windows should play CD's without issues (it did for me). Click Apply and note down any warnings, then click OK.

7. Keep the other Settings windows open and switch to the Spotify app. Close the Spotify app and reopen it and try to play a song. If this works, you will have to test which sample rate is the highest setting that the Spotify app will allow resampling and playback from. For me, it was 192000Hz - anything higher would prevent the Spotify app from playing, even though I have hardware that can play higher.

 

Note #2: If you have any playback issues, change your audio settings back to the original settings that you wrote down in Step #5 above.

 

I hope this makes sense and works for you. Either way, Spotify's developers need to add some functionality that will AT LEAST display a warning if a user has sample rates higher than what the app will allow. I say this because Qobuz and Tidal (Spotify's competitors) allow their apps to stream without issues if the Win10 user has a high sample rate. Spotify doesn't - so fix your app.

 

Good luck everyone.

4b9-a_ce1e39e
Newbie
F*ck, this was it! changed the audio device and it worked! thank you!

astocke
Casual Listener

Thank you Jakegoldsmith!!  You are an answer to prayer.  I’ve tried all of the above...forgot that I unplugged my headphones....duh!  No device!

 

thanks again!

IgorKosov
Casual Listener

You can use MusConv.

erwin_m
Regular

This topic isn't about importing music, it is about playing it.

dseanjohnston
Casual Listener

Changing my speaker selection worked for me. Now, let's talk about how an app that I pay over ten bucks each month for can't be intelligent enough to TELL the user that "this is what the situation is- change this and you'll be good to go again".

 

Shoddy.

SUGGESTED POSTS