Announcements
Current information of our Google Nest Mini Offer can be found here.

[All Platforms][Playlists] Switch on/off crossfade in certain playlists

Hello Community!

 

In Spotify there are some playlists with automatic crossfade. That means there's a smooth transition between songs. However, not everyone likes that, since the next song starts later (from minute 0:45, 0:26, 1:02...). That's why I thought it would be a good idea a to have the ability to switch it on and off depending on what the user prefers.

That way, there wouldn't be any problems with that.

 

This is an example of one of the playlists:

https://open.spotify.com/user/spotify/playlist/37i9dQZF1DWZtGWF9Ltb0N?si=anA9lzv8S5akXzC4r5AvBA

 

In my opinion, it would be a good idea. If you agree, make sure to leave your vote/comment and hopefully they'll consider this idea.

Updated on 2020-01-15

Hey folks,

 

Thanks for coming to the Community.

As mentioned in many of the recent comments here, you can now head to Settings and turn off 'Automix'.
Hopefully this helps!

Related Ideas

Comments
Gig Goer

OK, I just needed to restart on the desktop version as well. Weird, I thought it updated on its own. Well cool, I guess we've solved it!

Visitor

Cross-fade is so annoying on these playlists. One way to stop it is to download the playlist, go to offline mode and restart the app, which is more of a hassle than it should be. Just let us turn it off.

Gig Goer

This issue has apparently been solved. You can turn it off with the setting "AutoMix" in the "Playback" category of settings.

Regular
They’ve just released the solution- you can now turn off Auto-Mix in the playback settings. 
Visitor

ok good it seems fixed

Regular
They have fixed it now - this was an older post. I can verify the fix works
on PC and iOS. Go to Settings, Playback, and turn off AutoMix. All fixed.
Newbie

I abhore the inability to turn off crossfade in playlists which have it locked on, and would greatly appreciate the ability to disable that. For me, it's incredibly jarring to have a song crossfade when I'm trying to focus, especially when two random songs in the playlist absolutely do not go together. It ruins an entire playlist.

 

Please, please make this something we can turn off!

 

Not looking through absolutely all the comments has bit me, apologies for digging this back up. I saw the Automix option mentioned. Thanks for hearing community feedback! (yay it's already done!)

Regular
You can now. It’s a feature called auto mix. It’s in settings. Just switch it off and you’re good to go. 
Community Manager
Community Manager
Status changed to: Implemented

Updated on 2020-01-15

Hey folks,

 

Thanks for coming to the Community.

As mentioned in many of the recent comments here, you can now head to Settings and turn off 'Automix'.
Hopefully this helps!

Newbie

I don't see 'Automix' option in Linux client (from Spotify's Debian repository). "Crossfade songs" is off, but still some playlists get mixed.