Downloading on Apple Watch stuck at first song

Hey folks,


We're receiving reports that some users are unable to download music for offline listening on their Apple Watches. The download is stuck on the first song and doesn't progress.


If you’re experiencing this issue, make sure to add your +VOTE and follow the instructions in the Status Update below.


We'll be keeping everyone up to speed here, so make sure to Subscribe to this thread. 



Hello everyone,


We want to confirm, we're still investigating this. We're gathering your reports and passing them on.


Based on user feedback and tests, we've gathered some recommendations that yield positive results, which we'd like to add to what we previously shared with you.


When attempting to download music to your watch for the first time, make sure to keep your phone as close as possible to your watch until the download of the 1st track finishes. Best to have them side by side for best results. This should only be necessary initially.


As previously mentioned the very first download is expected to take more time and stay in the 'Downloading 1 of ...' state for a few minutes, but if the watch is connected to and in close proximity to the phone with a stable network, it should start progressing after a while.


Additional troubleshooting steps we can recommend that have been reported to work are:

  • clean reinstall the app on both your smartphone and the smartwatch
  • unpair and pair the watch again
  • connect the watch to a charger
  • restart the watch
  • try a different internet connection


We’ll get back to you again when we have new info. Thank you!

Worked for me. THANKS.

where is Accept as a Solution?


Hi @Joe418,


It's great to know it worked for you. 


As a heads-up, the Accept as a Solution button is only available for the author of the original post, but we appreciate you taking the time to share with the Community that it worked.


For anything else you need, the Community is here for you.


Have a good one 🙂


Well this doesn’t seem to work at all.  I am stuck at 1 track downloaded and no amount of messing seems to sort it out.  When I try and change to play on watch and select my AirPods it connects, then just blasts the music out of my phone speaker and says there was a problem.  

Ok, so, what worked for me was putting my iPhone into Airplane mode, with WiFi and Bluetooth also turned off. With the watch only connected via WiFi, it suddenly started downloading the playlists I had requested.

Hey @Deejaycrox,


Thanks for your posts and welcome to the Community.


We appreciate you taking the time to share what worked for you. Just to confirm, did everything work as expected with your downloads after turning Airplane mode on and all your connections in the phone again?


Keep us posted.


Yes, so it would seem downloads don't sync if the watch is connected to iPhone.  Here’s the exact steps I take to make it work, ensuring Apple Watch is connected to WiFi:

  1. With everything as normal (iPhone not in airplane mode, with WiFi and Bluetooth on) select a playlist to download to Apple Watch in the Spotify app on iPhone
  2. Playlist appears in the Apple Watch downloads list, in grey with “1 of x downloaded”.  This never appears to go any further.
  3. Put iPhone into Airplane mode with WiFi and Bluetooth also switched off
  4. Force close Apple Watch app
  5. Relaunch Apple Watch app
  6. Apple Watch downloads the songs over WiFi 

Same issue for me. Apple Watch 4 says the playlist is downloading but even after 24 hours still hasn't downloaded a playlist with 1 item!


Hey @Deejaycrox,


That's great to hear!


Again, thanks for sharing the detailed steps that worked for you. We'll mark your reply as a solution for now, as it may be helpful for other users.


If you need anything else, the Community is here for you.


Cheers 🙂


which step made it work? Or did you do all of them?

Env: prod