Help Wizard

Step 1


Google Clock won't play any playlist from Spotify; Error: (message: failed to switch to local device




United Sates


Motorola Droid Turbo 2

Operating System

Android 7.0


My Question or Issue

The issue started this morning. Spotify was in sync with Google Clock (used as my alarm clock every morning). This morning, the alarm clock gave me a beeping tone with a error on the bottom saying "{"message": "failed to switch to local device"}" even though it says both apps are connected and in sync


So far, I've cleared data and re-installed the app both apps, and did a hard restart on my device and the issue is still ongoing. App version


EDIT: Google Clock app version: 6.1.1, Here is my most recent test and the error that is still ongoing today.  I tried Pandora with Google Clock, since it's capable of syncing to these two apps along with Youtube Music app (which I don't have).  The alarm works fine with Pandora. 


Looking for help on other ways to fix this issue.


Many Thanks





Hey everyone,


Thanks for your replies! This should be fixed now.


If you're having troubles after updating to the latest version available, we'd recommend trying a clean reinstall of the Spotify app with these steps.


If none of these help, we'd still like to know. In that case, we'd suggest starting a new thread in the related Help Board and we'll be happy to lend a hand. 


Have a lovely day 🙂


Same problem..after re-installing Spotify and Clock apps

Device- Moto X4

Andriod Version 9.0


Clock 6.1.1



Same issue - latest versions of both clock and Spotify, Android 9 and Motorola G7 Plus.


No sound in the alarm preview, despite the EQ animation.


This also started for me a couple days ago, uninstalled and thought that had done the trick but no dice, it didn't work. 

Pixel 3a

Android version 9

Clock version 6.1.1


I was connected to the internet when this was occurring but it made no difference


Would love to get this working. Hope is fixed soon


Mine plays no sound about first 30 secs, and then plays default alarm sound with error message. Error message is same as the screenshot above.


Android version: 9.0 Pie

Spotify version:

Clock version: 6.1.1


I usually use wifi at home. So I also tried using lte connection, nothing changed.


Same problem here. Pixel 3 XL USA. Android 9.0


Pixel 3a

Android Version: 9

Google Clock Version: 6.1.1

Spotify Version:


Uninstalled/Reinstalled still the same issue every morning here on my Motorola G7 Power. Both on wifi and on data.


I have the same problem for about a week now I guess. It worked again right after reinstalling Spotify but the problem reappeared a day later. First the default tone sounded instead of the Spotify Playlist but now there is no sound at all.


Model: BQ Aquaris X2

Android Version: 9.0

Spotify Version:

Google Clock Version: 6.1.1


Same issue as everyone else, "Failed to switch to local device". I've reinstalled both Google clock and Spotify.


Note 8

Android version 9


Clock 6.1.1 (238466778)