Help Wizard

Step 1



Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...


Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...


[Mobile] Issue playing filtered Liked Songs via Connect

Hey folks!

We've been receiving reports that the Search function stops responding when Connect is in use. Tapping on a song search result doesn't do anything and the Now Playing view stops responding. This is being looked into.

We currently can't provide you with an exact timeframe in which a fix for this will be released but it's on our radar. As a workaround - try adding the song to the queue instead.

Keep us posted in case anything changes on your and we'll do the same 🙂
Many thanks!







(iPhone 11

Operating System

(iOS 13.6


My Question or Issue:

Whenever I’m connected to my Echo dot or Nvidia Shield I can’t play songs that I have searched for in my “liked” songs.



  • My Question or Issue

I have Spotify premium running on an iPhone 11 Pro Max. Occasionally when I search a song and tap to play it, it won’t play. It seems that this only happens when I’m using Apple CarPlay. In order to fix it, I must restart the app. It seems to happen when I’ve been streaming an album or playlist for a longer duration and then attempt to search for another song. When I tap the screen it doesn’t even recognize the input such as the animation you get when selecting something, as if it doesn’t even acknowledge I’m touching the screen. 


Hey there @Bocwilson,


Thanks for reaching out about this here in the Community!


Apologies for the delayed response, we just came across this thread.


As we haven’t seen any similar posts about this recently, could you let us know if you’re still having troubles with this?


If you are, can you let us know if you've already tried to log out > restart your device > log back in? It's also a good idea to try a clean reinstall to clear any old files that might be causing issues.


If a family member has a Spotify account, it could also be a good idea to ask them to log in on your device to see if the app behaves the same way.

Keep us in the loop here.

This happens all the time, please fix!! It’s been going on for years!!
It happens after you search for a song (either in your library as filter or general) and happens when you play directly through the device or Spotify connect. If something was already playing it would cut it off and the now playing bar would disappear. If nothing was playing, by simply tapping the song, nothing would happen on the search results page. If you can however click on a playlist result and play songs in there. If you got back and try the song again, it would cut out and nothing would happen. You can’t play something from inside the playlist then come on out and queue the searched song either. Please fix, this has been going on for years!!!

Hey there @Calctinho,


Thank you for your reply in this thread.


Can you confirm if you performed a clean reinstall that @Elena suggested? This is different than a quick reinstall and could be helpful to get rid of any cached files that might be causing trouble.


If that doesn't do the trick, can you log in with another account - such as a friend's or a family member's to see if the issue persist?


It would also be great if you can let us know which version of the app you have?

We'll keep an eye out for your reply.




Yep, this has happened on various devices for me. Clean reinstall / rebooting does make the bug go away but it is temporary and it will come back. 


Hey again @Calctinho,


Thank you for getting back in touch with us.


It would be great if you can try to log in with another account to see if the issue persist.


Also - can you try with another internet connection to see if you can notice any difference?


If that doesn't do the trick - can you let us know which version of the app you have?

Keep us posted 🙂

Take care!


Sorry I don’t have another Spotify account lol


It’s an intermittent issue that can’t be replicated on demand and isn’t always happening but when it does it’s annoying and it shouldn’t be happening - right?

This issue is on both wifi and cellular (tried and tested). 

app version is:


this website has crashed and deleted my comments a few times. It makes it quite discouraging to flag issues to you and made to feel it’s my own fault this is happening lol


Hey @Calctinho,


Thanks for keeping in touch.


If you don't have another account to borrow and test this, you can create a free account here using a different email address. This would help us determine if this is account-related.


We're sorry to hear you're experiencing some issues when trying to post your reply here. We recommend trying using an incognito/private window and a different browser to see if that makes any difference.


Keep us in the loop.