[iOS] Cover art + track title is "stuck" on the first track played on BMW head unit

Track titles and cover art is not displayed correctly on BMW (2015) when playing through Bluetooth or the USB interface in the center console.

 

Symptom: Music plays and it is possible to switch tracks, but the cover art and track title is "stuck" on the first track played. It played great in the past and playing well with other music apps.

 

Device

(iPhone Xs) Running version 13.3.1

Car: BMW X6M 2015

Hey folks,  

 

We haven't had any updates for you all in a while and in the interest of keeping this thread updated for other users stumbling upon it, we'll go ahead and mark it as Won't Fix for now. 

 

Rest assured that we've passed on your reports to the teams around this. This is a very specific issue to this particular device setup with BMW head units and seems to be affecting only a smaller subset of users. However, if you're experiencing something similar but on a different head unit, we'd recommend starting a separate thread here so we can take a look. 

 

Keep in mind that this doesn't eliminate that a future update of the app could improve things for you, so keeping the app always updated is a great idea.

 

We do appreciate you taking the time to add your comments in this thread! If we have any further updates for you regarding this, we'll make sure to share them in this thread with you.

Comments
Wyllliam
Casual Listener
I have the samen issue, but on and android phone and Toyota audio.
nadais-br
Casual Listener
Same issue,
I updated Spotify, now version 8.5.41.669 and the problem still remains.
BMW 3 Series 2014
Iphone 11 Pro
counting6
Regular

I am experiencing the same issue on my BMW X3. I have reinstalled the Spofify app several times. I'm not able to advance to the next song and my IDrive is "stuck" with the first song information.

drftorres
Casual Listener

I still have the problem. In the past it was not an issue. I think maybe is the beta version of iOS 13. It is happening with other similar music apps

deanphan
Visitor

I have the same issue. Tried uninstalling and installing as well as unpairing and repairing my Bluetooth but nothing has worked. Issue started about 2 weeks ago

counting6
Regular
My Spotify was working fine with the UBB in my car till two updates ago. I
don’t think it has to do with the iOS but with Spotify.
jonbloom
Visitor
I am also experiencing this issue. iOS 13, 2015 M235i, latest Spotify app.
counting6
Regular
Until Spotify acknowledges and fixes this issue I'm using Amazon music. I
find it in poor business practices to not even respond to repeated reports
of an ongoing issues.



francomg69
Visitor
I also have the same problem! In December and early January 2020 Spotify was working flawlessly, but then this annoying art cover stuck in 1st music appeared and I haven't been able to solve it so far. My car is a BMW 528i 2015 model and using iPhone XS Max 13.3. I've just updated my iPhone to version 13.3.1 and also Spotify to version 8.5.42.1040 and I'm hoping they have fixed this weird issue. Crossing my fingers...
counting6
Regular
I updated my Spotify yesterday in hope the issue was resolved. No. My
account is a Premium family account. So I don't think it's unrealistic to
want a PAID for service to actually work.