Help Wizard

Step 1


Alexa "I cant find songs by..." for artist that played fine last week

Alexa "I cant find songs by..." for artist that played fine last week

So the issue is similar to others however others report success by de-registering and re-registering aleaxa to their account. Most seem to be to be europe bases account. I am in the US and a little over a week ago it worked well. For example when I ask Alexa to play "caspar babypants" (for my infant son) it can not find the artist. However, last week it had no issue doing this. It does similar for other artist but not all. Not sure if there was an update that created this issue but I am hoping someone has a solution. 

2 Replies

It seems to be specific to Caspar Babypants. This is a stage name for Chris Ballew when he is doing children's music. Alexa (and Google Home) will repond to "Play songs by Caspar Babypants" and say "Here is a mix of songs by Chris Ballew." (both Alexa and Google Home.)


The songs under his actual name are very different than the songs under the pen name of Caspar Babypants.


With a baby in the house, this is an important destinction. There seems to be no way to open a trouble ticket with Spotify for this issue.

I have the exact same issue. If we say "Alexa, play songs by Caspar Babypants on Spotify" she will reply with "I can't find songs by Caspar Babypants on Spotify." But if we say "Alexa, play Butterfly Driving a Truck by Caspar Babypants on Spotify," she will play it. Same thing happens with Elizabeth Mitchell. Now, if I say "Alexa, play Queen," she will play songs by queen. But if I say "Alexa, play Radio Ga Ga by Queen," she says that she can't find it. THEN, if I go to the Spotify app, search for Radio Ga Ga, and play it, it will play through the Alexa. 


I'm in the US with an Alexa purchased in June 2016; not sure what generation it is. We have a Spotify Premium Family account. The Spotify account is under my name, and the Alexa device is registered to me. I have tried unlinking and relinking my account, and I have tried resetting the device. A call to Alexa tech support tonight did not help: they are forwarding it on to their tech team. This occurs on our other Amazon voice devices as well.

Suggested posts