BMW Connected and Android 9 issue

Reply

BMW Connected and Android 9 issue

groove2spotify
Roadie

Plan

Premium

Country

Germany

Device

Nokia 8 BMW 4er Gran Coupe (2016)

Operating System

Android 9

 

My Question or Issue

 BT connection or the BMW Spotify App never worked properly on my Nokia 8 with Android 8.1. Now that i got the Android Pie update i tried it once more and now Bluetooth streaming as well as the BMW Connect App work perfectly. But the Spotify App does not. It is detected and i can select the App in the car, but then the App does not start. Can you please help me to get the App integration working?

21 Replies

Jemi
Spotify Legend

Hey @groove2spotify, help's here. 

 

Our best tech folks are on the case as we speak. Hopefully we'll have a fix soon!

 

Let us know if there's anything else!

 

Forre2
Newbie

Hi,

 

what was solution to this as "best tech folks" are still working on this ? (assuming so when problem still exists..)

groove2spotify
Roadie

the problem itself is not solved yet, but i don't think i can get a better solution for now than that the technical team is working on that problem

Tpeguk
Newbie

I like how they say solved when actually it’s not. I have the same issue, I play my iPhone lead in got to my connected devices and Spotify doesn’t show up anymore at all, it used to. I figured it was connected service having expired. Should it be there, and Spotify....it isn’t solved.

groove2spotify
Roadie
It wasn't Spotify how set this topic to solved.


But I wonder that you have problems with your iPhone because in my car there is no problem with Spotify on iPhone. Only my Nokia 8 with Android pie and previous Oreo has the problem



man13080
Casual Listener

@Jemi wrote:

Hey @groove2spotify, help's here. 

 

Our best tech folks are on the case as we speak. Hopefully we'll have a fix soon!

 

Let us know if there's anything else!

 

What's the resolution or eta for one?

 


 

man13080
Casual Listener

@jemi, would you kindly update us on this. Thank you

 

jakej90
Casual Listener

Have the same issues with my Nokia 8 on Android 8.1 and now on Android 9.

My BMW will show the Spotify logo on the Media-tab and I can select it. Music will play if I start it in my phone, but the screen will show no information. It,s a blank screen without any buttons. Changing to Bluetooth audio at least gives me the option to change to next or previous track.

With my Samsung s6 I don't have these issues. I see all information and buttons to control the app through idrive.

An ETA for the solution would be really interesting!

Plz mark as unsolved!

 

groove2spotify
Roadie

little update from my side.

Yesterday i noticed that the current playlist screen changed when connected to the car. Furthermore i got the notification that i should connect to waze in order to use Spotify in the car. Well so Spoitfy know that it's in the car, why does the iDrive integration not work? btw the waze notification sucks. After i pressed deactivate waze it pops up the next time i connected to the car.

Nokes320
Newbie

I have the same Problem with BMW iDrive ID6 + Huawei Mate10P: BT-Streaming works well but the Spotify-App in my iDrive is just able to freeze the screen. Frustrating fact: if i connect my old Samsung S5, everything is fine with Spotify & idrive. After imagining what kind of function an old Galaxy can have and new Huawei not..... - i only installed manually the old Spotify-Version which is on the Samsung also on my new Huawei + disregard auto-update. Now, old Spotify works fine in Idrive ID6!!! - so the Bug is somewhere in the newest Spotify App. I hope you get it fixed with the next update....

jolaca01
Regular

Waiting for a new BMW and having a Mate 10 with Android 9, I really hope Spotify developers will soon solve this issue. It's been quite a lot of time since the experts were trying to solve it. So here's another long time Spotify customer concerned about the issue. So please, put it first in your priorities Spotify!!

groove2spotify
Roadie

I'll give Spotify one more month. If there is no update on this issue (https://community.spotify.com/t5/Ongoing-Issues/BMW-Connected-Drive-spotify-shows-up-but-does-not-pl...) i'll contact BMW and complain about not working features. I paid a lot of money for the Connected Drive Services and now it does not work. Let's see if BMW can motivate Spotify to solve this issue when they stop the collaboration because of too many complains.

fjlour
Newbie

Samsung Galaxy S9 here, recently updated to Android Pie 9.0, then Spotify app no longer loads in the car, just a blank screen. The app shows in the connecteddrive apps, but when open it's blank. Sometimes Audio passes through.

 

Via normal Bluetooth connection works fine, can pause/play next/back the tracks.

 

This must be an app problem. Already contacted BMW ConnectedDrive support, to let them know about this bug.

 

Still waiting for Spotify to fix this issue.

ColinGee
Newbie

Hi

I too have the very same issue,  it works with my old galaxy S6 without any android update, but will not work on my new S9+ , same issue, the icon is there but nothing happens when trying to connect... works fine with std bluetooth connection.. I took it into BMW this weeks and the technician demonstarted that it worked fine with his iphone6 ... but as soon as we connected my S9 it stopped working again... he confirmed it was an Spotify on android issue.   

Please Spotify revert back to your old software to find a solution ASAP... as it is getting frustrating.  

jolaca01
Regular

Spotify , it's been a long time since you've been working on the issue. Any update, PLEASE??

jakej90
Casual Listener

Right now Spotify is unfortunately the only option for usage in my BMW. But as soon as they support Deezer or something like that for android, I'm outta here. And don't underestimate the impact of word-to-mouth recommendation.

So please Spotify, take this problem seriously.

groove2spotify
Roadie

I found a solution!!!!

 

Not sure if it'll last for ever or if it works for you, too. But let's start at the begin:

1) You need to enable the developer settings

2) In the developer settings find Bluetooth AVRCP Version (Audio Video Remote Control Protocol)
3) It was AVRCP 1.4 (Standard) for me. I changed it to 1.6

4) In the car it did not work 😞

5) I changed to 1.3 and restarted Bluetooth

6) Spotify App started in the car!! It took very long until the car loaded all data (Playlists...). In the Head Up Display the current playlist wasn't displayed and it showed "Loading" all the time. The music seamed to be a bit faster then normal and sometimes it stuck for a milisecond

7) Well nothing that i'd be happy with, so out of the car, change AVRCP to 1.5 restart bluetooth, restart phone

😎 next time i was in the car spotify started automatically and the music was no longer speed changed 😄

 

I'll check if this will be a durable solution. But maybe you can try to reproduce the solution, too. Have fun!!

 

Was an accidental discovery, when i wonder what AVRCP stands for google autocompleted my search "Bluetooth AVRCP" with "Bluetooth ARCRP bmw" and so i found this:

https://www.motor-talk.de/forum/lieder-schalten-bei-bluetooth-audio-mit-android-8-und-navi-plus-t612...

 

So @Spotify go ahead and find out why the app does not work with Android Pie AVRCP 1.4 or 1.6

allan_clarke
Regular

 Interesting! Might give it a try.

AshAlex34
Gig Goer

Thanks @groove2spotify I can confirm this is working , latest update of Spotify too. No lag at all but one cannot see the duration and time left of the song, there is a progress bar though.

SUGGESTED POSTS