Announcements

Help Wizard

Step 1

NEXT STEP

FAQs

Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...

VIEW ALL

Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...

VIEW ALL

Connect - Autoplay DISABLED, but still ACTIVE

Solved!

Connect - Autoplay DISABLED, but still ACTIVE

Plan

Premium

Country

Germany

Device

Samsung Galaxy A51, Windows 10 notebook

Operating System

Android 11, Windows 10

My Question or Issue

I'm listening on several Sonos speakers via Connect. Recently, Spotify has started playing other music once the album I listen to has finished - i.e. it's using the Autoplay feature. Problem is: Autoplay is DISABLED on all devices, but it's still being used. How do I fix this? (I've already reinstalled Spotify on all devices.)

 

Reply
328 Replies

Hey everyone,

 

Thanks for your replies.

 

To further look into this, could you let us know the make, model and OS version of the devices where you're experiencing this, and if the same happens in any other devices where you use the web player?

 

Additionally, let us know if it keeps happening when using a different connection, like another WiFi network or a mobile hotspot.

 

We'll be on the lookout.

CarlosEModerator
 
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 

Hey folks! 

 

Thanks for all the info you've sent so far.

 

Could you share with us the following? We'll look into this further.

  • Device + OS,
  • Exact Spotify version,
  • The troubleshooting steps you've tried so far.

We'll be waiting for your replies.

EniModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 
“Music acts like a magic key, to which the most tightly closed heart opens.”– Maria von Trapp

I have the same behavior now in both Chromium Version 94.0.4606.81 (Official Build) Arch Linux (64-bit) and Firefox 93.0 (64-bit) on Manjaro Linux. Make/model is probably not really relevant as this is a desktop PC. 

 

CarlosE can you confirm that it isn't simply intended behavior? It looks like this isn't platform-specific, but rather consistent behavior of the web player across all browsers/platforms.

The issue happens on both of my devices:

  • Spotify 8.6.72.1273 on iPhone 11 running iOS 15.0.2
  • Spotify 1.1.70.610 on PC running Windows 10 21H1

Speakers that have the issue (these are the only speakers I use):

  • Sonos Move via Spotify Connect
  • Sonos Five via Spotify Connect

I've tried these things:

  1. Signed out of all devices via web and signed back in
  2. Uninstall and reinstall app on iOS
  3. Toggling Autoplay on and off again (both devices)

None of those fixed the issue.

 

The issue is easy to reproduce for me:

  • With Autoplay off and with Spotify connected to a wireless speaker, if I play a single or album, when I go to the queue I can see a bunch of tracks queued up after the single or album I played. The single/album plays and then the other tracks play.
  • With Autoplay off and playing via the iPhone or PC speaker, it plays only what I choose to play, which is how I believe it should work.
  • If I start playing on the iPhone/PC speaker, with only the selected content queued up, if I then switch to playing on a wireless speaker the additional tracks appear in the queue without me doing anything else.

My devices / OSs:

  • Spotify 8.6.72.1121 on Samsung Galaxy A51 running Android 11
  • Spotify 1.1.70.610.g4585142b on PC running Windows 10

I've tried these things:

  1. Signed out everywhere via the button on the website and signed back in
  2. Uninstalled and reinstalled the app on both devices
  3. Toggled Autoplay on and off again on both devices

My Devices / OS

Spotify for macOS (Intel)
1.1.70.610.g4585142b

 

MacBook Pro (13-inch, 2017)

MacOS Big Sur Version 11.6

 

Toggled Autoplay on and off multiple times

Uninstalled and reinstalled app multiple times

Signed out and signed back in multiple times

 

 

I have multiple devices that all does this. Haven't found any that doesn't. Tried updating to the latest version, no difference (here's a version for you: Spotify för macOS (Intel)
1.1.70.610.g4585142b).

@Eni , you don't need to wait for our replies to escalate this. Please try this out yourself in the web player, you will find that this is a real issue.

Here's another thread about the web player that does this too (the web player seems to use Spotify Connect to play in the browser):
https://community.spotify.com/t5/Other-Podcasts-Partners-etc/Web-player-autoplay-can-t-be-turned-off...

The issue exists also in an older build I have on another Mac: 1.1.55.498.gf9a83c60-a . It is however not likely to be a client issue, this started less than a week ago in all my clients at the same time.

It happens to me in both a mid 2014 iMac running Big Sur 11.5.2 and in a desktop PC running Windows 10.
I tried with 3 different networks, the problem persists in all of them

Plan

Premium

Country

France

Device

PC, Firefox

Operating System

Windows 10

 

My Question or Issue

Since this weekend, it isn't possible anymore to disable autoplay on the web player. I'm paying for this service and I find it extremely annoying when spotify adds random songs I haven't chosen at the end of my queue. 

If this is some measure to force the Desktop app adoption or to get the users to stay longer on the site, it's extremely cynical and I expect better from Spotify. I can't install the desktop app and I want to remain in control of what I am listening to.

 

I hope you will bring back this feature which is the bare minimum for paying customers.

I came here for the same issue! It´s extremely annoying. Please fix it or tell me how to turn this option off because I can´t download the desktop app.

This has nothing to do with specific devices/connections. This is a change that was made for some reason and is extremely annoying. I much prefer to use the browser version of Spotify and since the desktop app is probably just a React Native version of the app I have no idea why the settings are unavailable in the web browser.

Same issue here!

Spotify 8.6.72.1121 

OnePlus Nord 

Android 11 (Oxygen OS 11.1.6.6.AC01BA)

 

Please bring this option back! I hate the autoplay and i find it extremely annoying but i can´t download the desktop app. Thats why I use the web player.

I'm also having this problem. It's fine when I switch to the Windows desktop app but as soon as I revert to the web player the additional tracks appear.

Hi,

 

I've got a premium account that I frequently use on my work desktop, and recently the autoplay feature has started to act up. It is on by default, and I can't shut it off - there is no option to.

 

The settings tab under my profile does not appear, and regardless of whether I start the playlist from my mobile or my desktop, the autoplay is on. Once an album is finished spotify will continue to play random, similar songs.

 

Using my mobile I can see that autoplay is turned off, but it doesn't seem to have an effect. I am using the web player as this is a work desktop, and listening to albums and only albums have not been an issue before.

 

How can I stop this annoying behaviour of random tunes appearing?

 

This might be the final straw for me to cancel Spotify since it is impossible to get good help from them and this BS they keep doing.

Hi folks,

 

Thank you for your replies and sharing that information. 

 

After doing some tests we were able to reproduce the same issue on our side. 

 

We went ahead and reported this to the right team, who will look into it backstage. At the moment we're not able to provide you with a timeframe for a fix, but we can recommend keeping the app updated.

 

To anybody else experiencing this issue, please share with us the information requested by @Eni, this way we can keep reporting it. 

 

Let us know if you have any questions.

MafeGModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Same, replying to follow.

I'm also having this issue. As a Premium subscriber, I would expect my app settings to carry over to the web player. It's especially annoying when I am listening to an album, and only want to listen to that specific album. 

Suggested posts